• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 204
  • Last Modified:

Windows Explorer freezes with new DVD-RW drive

I have a custom built PC with a Pioneer DVR-106D drive and an Intel D845PEBT2 board. It's a new clean install of Win XP Pro SP 2.

When I put a disk in the drive Windows Explorer freezes in "My Computer" As soon as I eject the disk, Win Explorer goes back to normal. I have tried many different disks so as to rule out that it could just be any given disk that was the problem.

I have updated the bios to the newest on the board and the latest firmware on the DVD drive.  I pulled the drive from an AMD socket A box and the drive worked flawlessly for over a year on that machine.  

The event log says:
"The driver detected a controller error on \Device\CdRom0."

There are two hard drives, primary master and slave and the DVD drive is secondary master, jumpers seem to check out ok. I also tried deleting the drive from device manager and restarting for the computer to re-find the hardware but this did not work either. I also tried starting with the secondary hard drive detached, that did not work.

Any ideas how to solve this problem?

0
danomatic
Asked:
danomatic
1 Solution
 
WatzmanCommented:

Just for kicks, remove the 2nd hard drive and try the pioneer burner as a primary slave and see what happens.  You've looked at most of the obvious things, correctly, and one has to wonder at this point if the motherboard might have a problem with the secondary IDE port.
0
 
WatzmanCommented:

Also, if you have not done so, try a different IDE cable.
0
 
danomaticAuthor Commented:
ok, thanks, I will try both.  I was also thinking there is a MoBo problem.  It's a fairly low end 478 board anyway. I think I will also try a different optical drive in the machine as well, just thought of that.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
danomaticAuthor Commented:
Reset CMOS? will try...
0
 
smiffy13Commented:
Is it just DVD's you're having trouble with or CD's as well? I assume you installed windows from this DVD drive. Can you boot from the windows CD?
0
 
danomaticAuthor Commented:
I flashed the 106 firmware back 2 versions and that fixed it.  Went from 1.08 to 1.06.  

I had to first use:
"Force_Official_1.07.ZIP"

then I did:
"A06_v1.06_DOWNGRADE.zip"

For future people who may have the same problem here is the firmware link:
http://flashman.rpc-1.com/Firmware/PIONEER/DVR-106D/


0
 
danomaticAuthor Commented:
NOTE for above: Flash firmware at your own risk.
0
 
OzzModCommented:
Closed, 500 points refunded.
OzzMod
Community Support Moderator (Graveyard shift)
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now