dos application fails on wireless network - worked on ethernet

Posted on 2005-04-16
Last Modified: 2008-02-01
We moved our video rental store this week and installed a wireless network.  We were networked by wire at our old site.  The network works well - shared files transfer through the explorer, all th systems appear in the network connections.  Our main application (called Rapid Rental written in Turbo PASCAL) however is DOS based, residing on a shared directory on one of the PCs.

When we click on the shortcut, the screen goes black with the cursor blinking and hangs there where the menu usually would appear quickly, eventually it might go to the menu program, other times it gives an error message: " internal error 0222  initialize page table" and , then goes to the menu when the user hits enter.  

If it does get to the menu, selecting a program to run causes the same black screen (I think it is either "Chaining" or "Shelling" at this time) and hangs.  In either case you can alt-tab and pull up the task manager and it shows the shortcut (not the target EXE) as "Running".

On the wired system we used static tcp/ip addresses - we tried them on the wireless network (though a bit different as indicated by the Linksys manual)  but it didn't seem to help.
Question by:murrayself

    Author Comment

    I got it to work by deleting instances of CONFIG.SYS and AUTOEXEC.BAT (both 0k in length) lurking in the root directory, allowing the DOS program to use the ones in the SYSTEM32 directory.

    Don't know why - but everything is OK now.

    Murray Self
    LVL 1

    Accepted Solution

    Submitted to PAQ with points refunded (500)

    Community Support Moderator

    Featured Post

    What Security Threats Are You Missing?

    Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

    Join & Write a Comment

    Can you find a fax from a vendor you saved a decade ago in seconds? Have you ever cursed your PC under your breath during an audit because you couldn’t find the requested statement or driver history?  If you answered no to the first question or yes …
    Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
    This video discusses moving either the default database or any database to a new volume.
    This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor ( If you're looking for how to monitor bandwidth using netflow or packet s…

    733 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now