[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 6510
  • Last Modified:

Veritas BackUp Exec 9.1 install dies at MSDE portion of setup - LONG STORY

Here's one that has been giving me trouble, and I REFUSE to pay Veritas Support $250 (weekend rate)  or $89 (Weekday Rate) for them to help me with something that SHOULD work after spending $3k on Software and Options. I have 6+ years experience with Veritas, and have never encountered a problem like this, let me be specific as to how I arrove at this question/point in time.

Roughly 1 month ago, I went to a client who uses Veritas BackUp Exec 9.1, with Exchange Option, 2 Remote Server Options,  2 Advanced Open File Options, and 1 Disaster Recovery Option. I was FIXING the Backup <hadn't worked for months> and doing requested maintenance (which was to make sure EVERY Application/Bios was 100% current on update), so I ran into the Veritas BackUp Exec Service Pack 2, and Installed it. After RESTARTING after the update, My AD was CAPUT! Nothing, Nada, Zilch. I almost had a heart attack. I called Microsoft at 7:00am on a Saturday asking them for help, because i was lost. Fast forward to 7:30 PM <almost 13 hours later>, when Microsoft told me they had exhausted EVERYTHING (including myself), and my only choice was to reload. That was our ONLY DC, and we had exchange and three other member servers looking for their Daddy DC. Long Story Short at this point everything was reloaded, and is 100%, I am now almost permanently scarred from my experience. Putting in 30 Straight hours, so that Monday Morning 50 Users don't notice anything, is NO easy task.


We do Daily backup's with NTBackup, but just got a DAT72 6 Tape Autoloader, and I have pushed them into using Veritas again. When I went to install it today, it kept getting stuck at the MSDE portion of the install, and would fail. I researched Veritas Support, and this site and others, tried everything, but came up short. HELP! How do I manually install MSDE? I have tried all the line commands, with no luck. Can someone write the command line for me, I must be doing something wrong.

I've tried :

Setup.exe INSTANCENAME=BKUPEXEC DISABLENETWORKPROTOCOLS=0 SAPWD=mypassword TARGETDIR="C:\PROGRAM FILES\VERITAS\MSDE"

Since backups are the heart of sole of the network, this is a 500 pointer, I'd love it fixed by Monday Morning.

Thanks ahead of time,
D
0
devruiz
Asked:
devruiz
3 Solutions
 
gpriceeeCommented:
Whoa!  Does not sound like a good experience!

Here's a link that will probably get you going for the MSDE install.  The resolution looks good and EASY.
http://seer.support.veritas.com/docs/257874.htm
0
 
devruizAuthor Commented:
Actually this is more like what I'm getting

http://seer.support.veritas.com/docs/265152.htm

D
0
 
devruizAuthor Commented:
and this one too

http://seer.support.veritas.com/docs/263147.htm

....am I doing something wrong? It was not a system wipe, I just reloaded on top of the old system, so there is still resident files from the previous install. Although the registry is new, could some old sql/msde files be hindering the install of the new msde? Where would those files be located if this is the case?

D
0
Transaction-level recovery for Oracle database

Veeam Explore for Oracle delivers low RTOs and RPOs with agentless transaction log backup and transaction-level recovery of Oracle databases. You can restore the database to a precise point in time, even to a specific transaction.

 
huntersvcsCommented:
OK.  Big problem!  I started going through my database and (of course) googling around and came up with the following:

http://seer.support.veritas.com/docs/265152.htm

VERITAS Backup Exec (tm) 9.x or later uses a Microsoft Desktop Engine (MSDE 2000) instance to store information related to devices and media. MSDE 2000 comprises of core Microsoft SQL components. As part of the installation procedure of MSDE 2000, values are written to the respective Windows performance counter.  The corresponding registry key is:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\Current Version\Perflib\009*

During the installation of Backup Exec, due to the corruption of the performance counter library values, the Backup Exec installation is unable to install the MSDE instance (Figure 1). This causes the Backup Exec installation to end prematurely, writing the MSDE error into the installation log.  Bkupinst.log

To resolve this issue, rebuild the performance counter library values manually by following the steps provided in the Microsoft Web site given below:

 http://support.microsoft.com/default.aspx?scid=kb;en-us;300956

After rebuilding the performance counter library values, restart with the installation of Backup Exec software.

http://seer.support.veritas.com/docs/272371.htm

Particularly:

7.  Download the Microsoft Installer (MSI) Cleanup utility, and install it. The MSI Installer Cleanup utility can be currently obtained from Microsoft at this location:  http://support.microsoft.com/default.aspx?kbid=290301 .

8.  Open a command prompt

9.  At command prompt, switch to C:\program files\windows installer clean up>

10.  Use the MSI Cleanup utility to remove the previous MSDE install attempts by using msizap.exe which comes with the utility.
Type:  msizap.exe TWA {E09B48B5-E141-427A-AB0C-D3605127224A}
*Note:  to verify the product code, open the msde_bkupexec.log and search for "SourcedirProduct" without the quotes.  The number listed above is used with Backup Exec 9.1.
**Note:  The TWA must be capitalized. Also, the {} are required around the product code.

And I came across this link Googling through Veritas Japan.  They basically talk about the same thing, but the MSDE part is spelled out, so it's hard to find:

http://seer.support.veritas.com/docs/253790.htm

This popped up when another company's software failed to install because of the same issue:

http://support.microsoft.com/default.aspx?scid=kb;en-us;317268

I don't know if you're running Terminal Services or not.  If not, disregard this link.

And I take it the following is a non-issue:

http://support.microsoft.com/default.aspx?scid=kb;en-us;813440

According to everything I've read, it appears the previous installation (MSDE) is causing the problem.  Not only the installation itself, but the "Named Instance" of the previous BackupExec is still in place and causing problems.  Obvious places to look would be:

Registry
ODBC
SQL Server

Don't know if any of this helps.  You've spend over 30 hours on it, had direct support from MS, and I've only spent 2 hours.  Wish you luck!

Rick
0
 
devruizAuthor Commented:
30 Hours rebulding the entire network which was probably 100+ hours to other tech's I've seen....I have just now started tapping the BackUpExec portion since I was bitten so hard, I had them go to NTBackUp until now....The Registry would be replaced with the new install, so I wouldn' t think that would be an issue, I looked for references to sql (file/folderwise) and renamed them, still no luck.....ODBC, I don't know crap about Databases, so I suppose that's the next place I should look....any other suggestions? I'll be in there tomorrow morning at 6:00am sharp <it's now 4:51pm>

D
0
 
huntersvcsCommented:
In the meantime, take a look at these comments from a guy with similar problems back in Feburary:

http://www.mcse.ms/archive91-2004-2-351344.html

Specifically:

Setup.exe INSTANCENAME=instance_name SECURITYMODE=SQL
DISABLENETWORKPROTOCOLS=1 SAPWD=sa_pwd l*v c:\MSDESTP.LOG

If setup fails again, you want to look at the C:\MSDESTP.LOG in notepad
(notice I had to specify L*V <filename> to have setup create a log). In
MSDESTP.LOG do a find for "return value 3". A "return value 3" is the
fatal error value that returns for an action. Based on the failed action,
you can continue to determine the reason why your MSDE 2000 setup failed.
0
 
huntersvcsCommented:
And this one blew my mind!  You just gotta read some of the comments here!

http://forums.veritas.com/discussions/thread.jspa?forumID=18&threadID=37429&messageID=4331533

Right now it's a little after 2:00 AM here (Germany) so I'll be signing off till tomorrow.

Best of luck!
0
 
Ron MalmsteadInformation Services ManagerCommented:
I feel your pain....Try doing that for about three hundred users....
I made the exact same mistake you did...I re-installed over top of the current installation...and consequently...I had the exact same problem with the SQL MSDE....

When restoring you MUST wipe the system clean and install a fresh copy of win2k..then install veritas into a different directory or volume other than the default c:\program files\veritas if you plan to use veritas to do a restore.....you also have to boot into directory services repair mode if your restoring active directory for either veritas or ntbak...or that section of the registry will not be overwritable during your restore and the job will fail around 80-90 percent....(ouch).

Trust me..I've gone through this process several times now, and I did pay for Veritas support.....It was worth $250 to get me through the restore process.....

Don't feel bad though...no one sits around breaking servers so they can practice restoring them....it's sometimes tricky.......but now if your successfull you'll be an expert so good luck.
0
 
devruizAuthor Commented:
After messing with the MSDE again, and again; and arriving at the same result, FAILURE,  I threw in the towel, and told the client we had no other choice but to contact Veritas. After about 1 hour, of attempted installs, and looking at the MSDE install log, the return value 3 error was focused on (like I did as well prior to calling them). I was told to go to a command line, and type this, the $250 command line which fixed everything:

lodctr /r:perfstringbackup.ini

after that, it installed without incident....UNF*****BELIEVEABLE, he told me to reference Microsoft Article ID: 315083 , I haven't had a chance yet

Thank you to all of you who contributed in trying to help with this pain in the butt task. I hope this helps ANYONE else running into this problem and saves them a few bucks and HOURS.  I definitely feel like it was a scam, being there was NO reference to this in Veritas's OWN knowledgebase on MSDE install problems.....Kind of Microsoftish in a way....  ;)

D
0
 
huntersvcsCommented:
Glad you got it worked out!
0
 
huntersvcsCommented:
I followed that link you mentioned, and guess what I found:

To resolve a corrupted registry problem, run the following at the command prompt:

lodctr /r:PerfStringBackup.ini

Wonder why Microsoft didn't or couldn't find one of their own listings in the first place!
0
 
huntersvcsCommented:
Hi D!  You'll either have to award some points or just close this one out.  Hope everything is back up and running :-)

Rick
0
 
devruizAuthor Commented:
Points were awarded on this based on Participation/Support not correct answers. This was a PAQ which cost $250 from Veritas. Hopefully someone else will need this, and save time and money. Thanks especially to huntersvcs who was extremely helpful in trying to help!

D
0
 
devruizAuthor Commented:
I still think it's unbelieveable that this solution wasn't readily available in Veritas' Knowledgebase. What a load.....
0
 
jasgotCommented:
We just went through this whole process, we were able to get it installed by downloading the latest MDAC (vesion 2.8) from MS and installing it.  After the MDAC was re-installed, Veritas installed lickity split!
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now