Unable to promote member W2K Server to role of Domain Controller

I have a server that I need to promote to the role of domain controller, but 3 attempts have all failed. The error I get is that the account I am using doesn't appear to have sufficient rights or permissions (it doesn't say this exactly, but it rejects the account that I am using an prompts me for a different one). I have used the defatul administrator account as well as my secondary domain admin account with the same results.

Both accounts are memebers of the Enterprise Admins, Domain Admins, and Schema Admins groups. I thought there might be a value that needed to be set in a GPO but can't find any. Appreciate any help.
LVL 1
habanagoldAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
moduloConnect With a Mentor Commented:
Closed, 150 points refunded.

modulo
Community Support Moderator
0
 
kierilfCommented:
try typing the username in format  domainname\administratorname

Also make sure that you have your server's DNS pointing at a current DC of the domain.
0
 
habanagoldAuthor Commented:
Well I did and that didn't seem to work. However, I did make some changes and finally got the problem resolved. I am going to post them tomorrow. Thanks for making the attempt.
0
 
habanagoldAuthor Commented:
I was going to respond the other night but got into something else. I have solved this but I feel bad because I can't find my notes that helped. If memory serves, I did at least 2 things.

First, the DNS info on the server I was trying to promote was all wrong which I corrected. Second, I had a custom domain policy and a custom domain controllers policy that I was employing and I disabled them in lieu of the default policies.

I seem to remember doing something else but I can't recall it at the moment. I don't know if the above activities led to the resolution or not. However, I have successfully promoted the server in question. If I think of anything else I will post it before requesting refund of points.
0
 
habanagoldAuthor Commented:
The same issue arose the other day and I found that adding the Everyone Group to the root with full permissions solved the problem. I had earlier removed the Everyone group in lieu of the Authenticated users group for better security. Adding the Everyone group back allowed the server to become a domain controller. Not sure if this is correct solution, but it worked.
0
All Courses

From novice to tech pro — start learning today.