Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 340
  • Last Modified:

kfm under newer X desktops.

On desktops (terminals) running gnome I have been using KFM to pullup the icons from servers ont to the desktops. Note this is different from executing the kde or kdesktop command which pulls up a really slow complet desktop. By just starting kfm after a ssh login to the server, only the icons for that servver appears. Worked like a dream for the past 5 years but not anymore with hewer Linux distributions.

What I usually do, is to have gnome running or Afterstep on the clients.
I then telnet or ssh into the servers and execute
kfm at the prompt after which the icons appear.
Note: I do give xhost access by adding the servers there.

Well, Fedora2, SuSE 9 Slack10 and later refuses to allow kfm to load   into X.

Please help to get this working .
Thanks




0
dryzone
Asked:
dryzone
  • 6
  • 5
1 Solution
 
wesly_chenCommented:
Could you post the exact error message show on the screen or in /var/log/messages?

> Fedora2, SuSE 9 Slack10 and later refuses to allow kfm to load into X
It could be the latest KDE is incompatible with old KFM (KDE File Manager).
Those Linux are using Xorg and kernel 2.6.x. But key factor should be the version of KDE.
0
 
dryzoneAuthor Commented:
I think It has little to do with KDE.
In fact it happens on ANY OS with any KDE version running the newer X distributions.
Itis clearly an X-windoes problem.
There is some new X  authentication configuration that is facist in nature.

I have used Linux now for 8 years and is seriously considering just moving over to windows again. The latest versions are just horrible. My opinion is that if Linux continue on this trend it is dead.

In any case,
The exact error is after I telnet or ssh to the server and logged in then e.g. start  kfm is

cannot connect to host A20:0.0   where A20 is my terminal.
Sometimes also xlib errors saying connection refused by server.

These messages were usually solved by just xhost 'ing the clients loop and server ip's onthe terminal. Worked for 5 years why not anymore?



0
 
wesly_chenCommented:
Could you check if the clients have firewall running?
/etc/init.d/iptables stop
to turn it off.

For ssh, try
ssh -X hostname
to forward the X11 traffic.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
dryzoneAuthor Commented:
No firewalls.
I also did ipchains -F  for good measure.
It was the first thing I check and I prefer to have unsecured machines on internal networks as if you do not allow promisquity internally very little will ever work. If someone want to compromise you from the inside there is nothing you can do about it in any case. It works for me.

ssh -X  seems to be a step forward as I do not get the error messages anymore but it just hangs at the prompt, seemingly not getting anything through to display  A20:0.0
I will dig into this and come back to you, never new what the X switch is for.

QUESTION:
Is there any way you know of that I can completely switch off all authentication on a client. That is xauthentication,  telnet (SSL)  SSH you name it.   I want full promisquity on the desktops, whic can be recoved with a  dd of an image back onto the disk. The servers acan be hardened no problem.

If there is any batch tool you know of just to set up absolute minimum authentication please let me know. In particular regarding X. I cannot find anything in the man pages


 



0
 
wesly_chenCommented:
Check /etc/pam.d/login, /etc/pam.d/ssh,  /etc/pam.d/system-auth.

> not getting anything through to display  A20:0.0
When you do "ssh -X remote-host" and type "xterm", did you get xterm pop-up?
0
 
dryzoneAuthor Commented:
Thanks Wesly,
When I fiddlesd with Pam I could strike down all the security properly.
I dont know how far linux is going to get like this.
The should give you an option to run a completely insecure system without authentication.
I prefer to start from there and add security as I see fit.
The newe distributions is really damagingthegood name of Linux as far as I am concerned.

In any case, I think you solved the problem sufficiently. Is still do not understand exactly why this happens but I now get my icons from desktops of all servers on a single terminal again, so the problem is solved.
I wonder why ever KDE decided to drop the ability to send only the icons of a desktop of a server? The kdesktop really sucks. One screen per server. Really not on.

I give youthe points. Well done.
0
 
dryzoneAuthor Commented:
Wesly.
If you do not mind helping me with a final hurdle.
The -X switch works fine with all windowmanagers on SuSE9.2 except KDE.
On KDE the icons dont display for some reason.
Fvwm windowmaker etc all works fine.
Any knowledge how to get round this?

Thanks
0
 
wesly_chenCommented:
Well, that's why I suspect it has something to do with new version of KDE or the KDE setting on SuSE9.2.
How about the KDE on Fedora or Slackware?
0
 
dryzoneAuthor Commented:
Well, strange thing is it worked for a while and then suddenly not.
It would be nice to know why it doesnt work.
I do not like KDE. I usually only work in afterstep, and if I must gnome.
Most other people however prefer KDE, which is the problem.

In any case thanks.
0
 
wesly_chenCommented:
> it worked for a while and then suddenly not.
Then you have check the log file for the clues.
Support for multiple desktop manager is tough.
I convinced my boss to support only Gnome.......
0
 
dryzoneAuthor Commented:
Gnome is about the only sane bellls & whistles Wm.
Pity Redhat abolished it.

in any case thanks a lot for your help.
till next time.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 6
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now