• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3531
  • Last Modified:

The Instruction at "..." referenced memory at "...". The memory could not be read/written, problem.

Hi,

This error has recently kept appearing on my system crashing whatever program it happens to. The application varies, so far it has happened to
-rundll
-WUSB54G (Linksys Wireless Adapter software)
-Winamp
-Half-Life 2

Sometimes it says "cannot be read", and sometimes "cannot be written", and also gives different memory locations. It happens at different times too, sometimes after the system has been on for ages, today it happened to WUSB54G as windows was booting. And WinXP has locked at couple of times also (I presume the same problem but happening to something critical and then can't report the error).

I presume this is hardware problems, so I'll give as brief an explanation of my setup and other problems I've been having, incase they are related.

*********** Setup ************

Windows XP Home Edition - Fully Updated.
Abit NF7 Mothboard with latest BIOS.
Athlon 2800+ XP with ThermalTake TR2 M8 (sometimes OC'd to 3200+)
512MB Geil DDR400 RAM ( + 2x256MB Geil DDR400 RAM previously, explain later). (Running @ 333Mhz - 400Mhz)
Galaxy GeForce 6800 GT
80GB Maxtor HDD PATA IDE Primary Master - Windows XP Installed here on C:\
200GB Seagate HDD PATA IDE Secondary Master
Teac CDRW IDE Secondary Slave
Freecom External DVDRW USB2.0
Linksys Wireless G Adapter
Creative Soundblaster Live
Tagan 480W PSU

******* The Story *******

ok. here goes.

I bought a webcam, and it wouldn't work, kept showing a blank screen 90% of the time (worked 10% of the time), I tried another one (different manf) and it didn't work right either (very flickery). Both worked fine on another system.
So after fiddling I discovered that if I
a)disabled USB Enhanced Host Controller in Device Manager or
b)disabled USB2.0 from the BIOS
the webcams started working.

But also, sometimes when I connect a device to the USB, all other devices would occassionally "disconnect" and "reconnect", often asking me to reinstall them. So if I plugged in the webcam, the Wireless USB adapter would disconnect and reconnect and ask bring up the "driver install screen", also incrementing the device number. (ie: if it was called "Wireless G Adapter" in the network connections, after this it would be called "Wireless G Adapter 1", this happened so many times that it was eventually called "Wireless G Adapter 14".

Also, occassionally the DVDRW would "die" (as if the signal from windows to it stopped, and if the DVDRW isn't connected to the system it shuts up, even though its got its own power lead.) If I take it out and plug it back in it starts up again, and would be reconnected.
BUT sometimes windows would throw up an error saying "this device has malfunctioned, and cannot be installed" error. Reboots didn't even work. The ONLY was to fix it was to remove ALL USB devices, reboot with none in, and THEN reconnect the DVDRW, followed by the rest of the devices. Strange or what ! ! (Also the DVDRW works fine in another system).

First I though that maybe I should stick in a PCI USB1.1 card and try it. Very strange thing was it did EXACTLY the same thing as the USB2.0 ports when USB2.0 was enabled. I worked when USB2.0 was disabled. Why this would be considering it was (a)in a PCI slot, and (b) a USB1.1 hub, I have absolutely no clue.

Then I thought that maybe the 6800GT was sucking too much power so I replaced the then 400W Mercury PSU with the 480W Tagan. It actually helped alittle with the USB disconnects, but not much with the webcam not working.
The reason I'm mentioning the webcam is that it seems as though a steady flow of data through the USB such as a webcam was causing a problem maybe? Although the DVDRW worked reasonable well.

The main webcam still was buggy, but the secondary one I tested earlier started to work much much better with no flicker since.
So I presumed that the first one was just rubbish, but the second one working meant that something in the system had changed for the better. Maybe the old PSU was the problem.
The CPU disconnects still happened sometimes though (just much less frequently) so I tested the RAM too.

I had 1x512 ram in Dimm1 at this stage and 2x256 in Dimm2+3, so 1024MB in total running in Dual Channel Mode (which the NF7 supports, 3 chips in Dual mode).
I found out that one of the 2x256 chips had errors in it.
At this stage my CPU was running at stock FSB of 333 and the RAM in sync at 333 (therefore the RAM was underclocked to do this). I changed the CPU setup to 200Mhz * 11 Multiplier (3200+ setup) so the RAM was running as it should, and the error disappeared !!!, but the CPU temps were alittle high (55C compared to 48C) so I just removed the 2x256 sticks and set it back down to stock (166Mhz * 12.5 Mulitplier).
(But I still have the worry it was my mobo not liking 3 RAM chips in it, as there is currently only 1x512 in it now).

At this stage there was no 200GB drive. Shortly after I added the 200GB drive to the setup, these memory errors started appearing (I don't know whether this was coincidence or not). So I worried that it was the drive's fault, but it is working great itself. I've loads of data on it now, and it's not giving me any problems (unless its related to the errors).

It sounds really really like memory trouble, but I've ran DocMemory on the 512 stick for about 24hours and memtest86 for about 24 hours with not a single error. I also ran Spinrite which I had on the 80GB drive which passed fine (although Spinrite said it couldn't get access to the 200GB one, though it said the BIOS may be blocking it if there was some sort of gap on it somewhere. I used Partition Magic 8 to set it up.)

Finally, I changed the CPU setup to 400 * 10.5 (my CPU seems unlocked, I can changed the Multiplier to anything I want, up or down) to see if it was a memory problem and setting the FSB back to 400 would help the RAM incase it was a problem not showing up in the tests (as 400 helped the other bad sticks). It didn't help, you'll notice that the Multiplier is lower than the first OC I did (now running in between 3200+ and 2800+ at 2100Mhz), funny enough this CPU setup runs COOLER than the stock setup.

******** Conclusions ********

So in total I've had Bad RAM, USB2.0 problems with webcams not working and devices dying and disconnecting, and now "mem cannot be read/written errors".

So something is needing replaced, and I'm hoping if you guys understood everything above (sorry if it sounds a mess, it is) someone will have some suggestions.

To me I think one of the following :

a)The RAM is bad, no matter what the tests say

b)The new HDD is somehow causing the errors, either because its bad or because the motherboard doesn't like 2 HDDs connected.

c)The CPU is intermittantly faulty

**I'm thinking this one (d) might be the problem**
d)The motherboard is faulty, a combination of the USB problems, the disconnects, the RAM, and maybe even 2HDDs on 2 IDE channels, all could be the mobo possibly.

Problem is that the other system I have here is older (SDRAM etc) so I can't switch and changed parts to find the problem (which by trial and error would be the best way to process, but I don't have the components to do so.)

So if anyone could help it'd be so much appreciated. I bought this machine and built it to get a good performance machine, and its given me soooo much more hassle than lowend machines I've built.

If anyone doesn't understand anything above please ask,

Thanks in advance.
0
KOTOR
Asked:
KOTOR
  • 23
  • 19
  • 5
2 Solutions
 
nobusCommented:
I agree with you on your conclusion, it certainly looks that way, but :

i would start testing first :
since you tested the ram, we'll leave that for now, but test with only 1 Ram stick installed, and disconnect as much devices as you can for the test : only one disk, no cd drives, no add-on boards. After you get an insight in the problems, you can add those back on.
disc : you can try running a scandisc for errors, or the manufacturers utility :

http://www.maxtor.com/en/support/products/index.htm
http://www.seagate.com/support/seatools/index.html

and try running BurninTest, it can give you some indications too :

http://www.seagate.com/support/seatools/index.html
0
 
KOTORAuthor Commented:
ok, I'll try this Seagate tester now.

 But with respect to the RAM tests, if the worst case is all this stuff connected, if its passing when everything is connected should I still retry it with everything disconnected ?

The other confusing thing, if the mobo is faulty shouldn't be it faulty in DOS also?, thereby giving errors. Same if the CPU was faulty ?
I've ran all sorts of virus scans/spyware etc in windows to rule that out, as well as windows file protection.

Though since its in DOS most of the USB devices are inactive (although they still get power, due to the USB power on feature) because they seem to be "started" in windows, even though they are receiving the power.

Thanks
0
 
nobusCommented:
my opinion is that when you have problems, you can not predisct where the problems originate; you can only guess as good as you can, eventually backed up with years of experience.
So, to exclude other possibilities, it is wise to start the test with a minimum, and if satisfied, add devices.
But if you are willing to walk another path, that is up to you...
0
Transaction-level recovery for Oracle database

Veeam Explore for Oracle delivers low RTOs and RPOs with agentless transaction log backup and transaction-level recovery of Oracle databases. You can restore the database to a precise point in time, even to a specific transaction.

 
KOTORAuthor Commented:
no no, I trust you ;-)

I'll remove all the devices and leave the RAM testing for a few days.

I just ran a quick test of the Seagate tools, and it said it passed the "physical test", but failed the "File Structure Test", I'm not sure how significant this is because it also said that many things windows does could cause such errors (even such as using chkdsk somehow ?). I'll also mention that the 200GB is NTFS, and the Seagate tool supports NTFS. Though as I said in the original post I set it up with Partition Magic 8, not windows itself.

Plus windows is recognising the file system fine. So I'm not sure whether this could cause the problem, or even how to fix it other than back the drive up, and format it.

Thanks
0
 
nobusCommented:
i suggest a scan disc for errors, if there were file structure errors
0
 
mysticaldanCommented:
A little suggestion.

Write down ur current BIOS settings down. Enter BIOS and set them to OPTIMAL level. DOnt worry abt anythin else yet. Set the USB to be compatible with 1.1 and not 2.0 from the BIOS. Dont change settings from both windows and the BIOS. Let the BIOS handle it and windows will stay in line itself. While ur at it I suggest that you also disable Power Management and ACPi from the BIOS. A lot of USB problems occur due to power or power management so give it a shot. This itself might sort it for you.

After u have done this I reccomend a reload of windows with the primary partition being of 32 GB FAT32. You can always have the rest of the disk as a NTFS disk. I have seen that errors tend to be more with NTFS and so unless ur really using the enhanced security features of NTFS dont make ur primary partition a NTFS partition.

A BIOS update if availabel will help just in case this is a primary hardware bug which might have been sorted out in subsequent BIOS updates.

USB disconnects can be due to mostly motherboard related problems and not due to memory problems. The RAM seems good to me and this seems like a compounding of errors cause of a basic problem. Its more like a cascade effect. Your games will hang, usb wont work, even notepad might give funny problems. You feel the system is doomed.

Chekck the hard disk. It shud be fine even on a surface test although i reccomend changing the cable. A bad cable can cause the same errors u say.

CPU is fine. If it was bad u'ed know instantly. Its something that just doesnt even let a system boot properly.

This is more like a mobo problem where some settings are causing problems or compatibility issues with windows We just need to sort this out. You can try BIOS settings at FAIL SAFE also and see if that changes anything. However with ur file system corrupted i am not confident that u can resolve this problem without a reload of windows. Just dont know which file has been corrupted in which way.


Dan
0
 
KOTORAuthor Commented:
Thanks for the response Dan.

nobus:
DocMemory is on about 24hours now, passed all. I'll do memtest next now I think.

Dan:
I've done the optimum level thing before in my "journey" to fix this problem, to be honest I've fiddled so much fixing so many problems I can't remember if it helped, and if so what etc. So I'll try it again.
I do however remember that I have tinkered with the RAM timings, now at the Geil recommendations. And its passing anyway.
As above, the CPU seems to run better on the 200*10.5 setup that the default, cooler etc. And the main reason I switched to this is because of trying to fix the problem, so the problem is still there at stock settings anyway.
Is there any other things Optimal will change?
I'll set it up that way incase, just to eliminate as many things as possible.

Not sure I've ever checked the power management thing, I'll change it if I can find it, sounds like a plan :-D

I've the latest BIOS, as recommened by Abit. I explained the problem to them and they said, in a very short email "update your BIOS and set it to "USB2.0" compatibility mode as only the newest BIOS has this feature".
I did, and it made no difference, upon replying they haven't responded twice. Great tech support.
The only 2 things in there are "USB Mode 1.1"/ "USB Mode 1.1/2.0" and the compatibilty setting above. The compatibilty didn't help, and the former turns off v2.0 (which does help the stability of the system for some reason.

I ran a chkdsk on both HDDs before I started this RAM test, everything checked out. And as above, Spinrite says the 80GB Maxtor is fine, but can't get access to the 200GB Seagate. And the Seagate tool says the file system is buggered on the 200GB drive, even though it works fine in windows and checks out fine in chkdsk ?!? Confusing.

Oh, and I changed both IDE cables, although the one connecting the 200GB HDD and the CDRW is alittle tight because of the distance between them. I can't get them any closer due to the case/mobo layout, but its tight, but in firmly.

Finally, Fail Safe mode reports a CPU error and won't boot, its as if the settings it loads are too low for the CPU to operate (I got a similar error by lowering the FSB too low manually once).

Also I'll note the 80GB drive was making a few funny noises a while ago, and I put a HDD temp monitor on and it was rated at 58C :-\ I've since installed a Coolermaster HDD Cooler, and its fallen to 45C, and the noises have since stopped. They were like the noise it makes when you reboot, only it was happening while XP was running.

Soooooooooooooooooo, my list of things to do are :
*Load memtest86 for 24h
*Save to DVD or any space left on the 80GB drive from the 200GB drive, and reformat it incase.
*Try the Optimal settings in BIOS
*Have a look at the power management settings

I'm tempted to lob the mobo in the bin. Its put me off Abit, maybe MSI next time. Problem is this Abit NF7 was really cheap considering its a nForce2.

Thanks again.
0
 
nobusCommented:
i suggest ASUS, they have served me well up to now, but they are not the cheapest.
0
 
mysticaldanCommented:
Optimal makes sure that all settings are optimised for RAM states to boot options etc. The point is to restore the settings to factory defaults. Reseting the BIOS is a good idea and then just set the time and date. Set ur USB to the compatibility mode. I am also led to believe on what you say that the 200 GB HD might be having some file system errors. These might not be related to just a file system error but the way the HDD is read by the BIOS and how the cylinders are being processed by the BIOS.

A file system/BIOS problem similar to the obe above can cause the same issues ur facing. I would still reccomend that you try a FAT32 partition and then check.

I am sure there will be at aleast 1 stick of RAM on which FAIL SAFE mode wont give this error. I suggest u try each stick one by one adn see. This is definately a hardware thingie but can be anything from RAM to hard disk to BIOS settings. Do not decrease the FSB. Its not meant to work that way. A better thing wud be to try a different RAM meant and known to work with ur board.

Another thing to try is to remove extra compoenets from ur board like the SB Live+Galaxy GeForce 6800 GT
Freecom External DVDRW USB2.0
Linksys Wireless G Adapter

and then try. Also disable anything u dont need from the BIOS like SATA controller in case ur not using it or using it or LPT Port etc.

One last thing i would like to mention is Maxtor compatibility with other hard disks. Seagate WD etc all have problems aligning themselves with other hard disks. Its abt each one likes the 48 bit thing and all (not going into details) I have seen controller problems with different manufacturer hard disks even though they detect fine. Try whatever solution u wud like  with just ur Maxtor in place. Once all is well try to attach the seagate.

Under the dire case that this is a mobo related error then u can and shud get urself an ASUS for sure.

Dan
0
 
KOTORAuthor Commented:
Yea, if all else fails I'll get an ASUS on your recommendation. Only worry with them is that an old one I had started to make a funny high pitched noise when I moved the mouse, and I read around the net that alot of ASUS boards tend to make a squeak do to loose capacitiors or something.

You mean a FAT32 partition on the 200GB?, or a FAT32 partition on the windows XP parition? WinXP is installed on the 80GB Maxtor.

Fail Safe mode drops the FSB right the way down to my knowledge on this board at least. It wasn't a RAM error I was getting, the BIOS after boot would say the CPU was unable to operate or something to that effect. I had to do a jumper reset to get it working again.

If I disable the GeForce6800GT, you think I should replace it with another lower-end card ? I have a MatroxG400 lying about but I don't know if its the same spec as the current AGP boards.

Hope the HDD compatibility ain't the problem. If that were the case I think I'd scrap the Maxtor and install XP on the 200GB, and then get another small 80GB Seagate. Or would getting an 80GB Seagate and "Norton Ghosting" the maxtor onto it work?

Thanks again guys, memtest86 still passing.
0
 
mysticaldanCommented:
Try just with one hard disk. Let it be the Maxtor attached to the system. Let the BIOS default be at OPTIMAL. DO a clean install of windows. Transfer all data to the 200 Gb b4 u do that so that u can always copy it back and burning backups is always a pain.

Change the Graphics card after the above thing still gives u trbl. Memtest will come up fine. Its not a RAM error from what i say. Ohh and since we discussed boards I like the stability and quality of MSI boards. They are also super. Asus now tends to be a little laggy in deleviring stability like they used too.

Dan
0
 
KOTORAuthor Commented:
The thought of the Graphics card being a problem is scary, last time I had a graphics card problem it took 6 weeks to get it replaced, with no computer in between :-\
Though I did get a full refund, and since I bought it 7 months previously I was able to upgrade with no extra cost :-D

I'll try your advice and let you know, though a new mobo could be on it's way as this is really starting to peave me off.

Cheers
0
 
KOTORAuthor Commented:
Sorry, also. I forgot, I once did replace the GeForfce 6800GT I have with a GeForce 440 MX I used to have (no longer), and the USB2.0 stability improved quite alot.  But I thought that it could well be the motherboard and not the card, because the card is such a general resource beast that if the mobo was acting up the card would only make it worse, even though it isn't the card behaving abnormally ?
0
 
mysticaldanCommented:
The graphics change seems to have cleared up the issue as suggested. If the problem is persisting then we canhelp further.

Dan
0
 
KOTORAuthor Commented:
Sorry, I haven't abandoned the question, I've had a severe ammount of work and exams on. A new Seagate 80GB HDD is on its way which I'm goin' to ghost the 80GB Maxtor onto and see how that goes.  Although an asus mobo is probably on the way to replace this one anyways.
I should have an update in a week or so.
Thanks.
0
 
KOTORAuthor Commented:
Hi again,
Thought I'd add one more thing that I've found brings up the problem 100% of the time.

I have a .avi file I took on a digital camera, ~250MBs in size.  Its on the newer 200GB Seagate drive.  When I play it in Winamp, at a specific set of points in the movie Winamp crashes with "Winamp - The instruction at xxx could not be read". There are exact times in the clip that crash it, if I skip over them it doesn't.  The fact its this specific clip worried me that the HDD had corrupted it, but Winamp would just crash with a normal message or refuse to play more rather than this exact problem I've been having wouldn't it ??

And so I tried the clip in both RealPlayer v10 and Windows Media Player v9 and it crashes out in the exact same way at the exact same times. "RealPlayer - Instruction at xxx could not be read", "MediaPlayer - Instruction at xxx could not be read". Strange....

So I thought it was wierd that this movie clip was giving identical errors in multiple programs, I copied it to the 80GB Maxtor drive, it does the exact same thing there. I then copied it to another computer in the network, and it works perfect !!??!! If it works perfect on another machine it can't be the clip.

Any ideas why this clip is 100% consistantly showing the main problem, and in multiple programs ?

Thanks guys.
0
 
nobusCommented:
>>   I then copied it to another computer in the network, and it works perfect !!??!!    <<< and if you copy this one back to the failing computer to another location? does it still crash?
you can also run a disk scan for errors, to be sure there is no "problem location" on your drive
0
 
KOTORAuthor Commented:
I took out the graphics card and reseated it, installed the latest nForce drivers for the mobo and latest graphics card drivers, the latest codec pack and that seems to have fixed it :-D
But this problem was occuring before consistant media content errors were occuring so I'm not positive that this is the cause of the initial errors.
For example how would this cause the continuous errors in :
-rundll
-WUSB54G (Linksys Wireless Adapter software)
which are two of the initial problems I stated.
I'll just leave things the way they are out of curiousity for a few days and see if more errors occur, but I can't give HL2 another good bash as I've another exam on Wednesday (last one thanks goodness :-)
But this 80GB Maxtor makes an annoying high pitched squeal which is doing my head in so its going no matter what at some stage. I was going to just install XP onto the 200GB one, but I'd really prefer to Norton Ghost to another 80GB Seagate to preserve the OS.
0
 
nobusCommented:
you can make a 80 Gb partition on the 200 Gb, and ghost to it; so you'll have another 120 Gb left.
0
 
KOTORAuthor Commented:
My Wireless USB Adapter Software gave the error on shutdown last night so it seems the problem is still there, just not as severe.

 But I am extremely curious as to why its this piece of software that is the piece that keeps crashing with the error.  And it only happens on bootup or shutdown, which is when its being (a) told to start (b) told to finish. It really seems like a ram problem if it weren't for the fact the ram passes all tests. Maybe it could be sitting on the swap file, and the 80GB maxtor is giving up ?
But there is a bunch of other software starts on boot too, duno why this one is being singled out, and its also an updated version of the original that was crashing :-|

I can kinda understand the winamp thing if the graphics card was having driver problems etc, because as far as I know alot of the decoding is done on the graphics card instead of the CPU these days for video playback, hence why when I reinstalled drivers, reseated etc it fixed it.  But I can't see the link from the graphics card to the WirelessUSB software. Do you think it's related ?
My warrently on the card is in it's last month, so if I want to send it back and claim it as being faulty I needa do it soon because I can't afford a £300 dodgy card outa warranty :-\

Cheers Guys.
0
 
nobusCommented:
did you check if the "optimise for quick removal" is set for the usb device?
go to device management, select the drive properties, management options tab
0
 
KOTORAuthor Commented:
Isn't that only for storage volumes, whereas this device the software relates to is a Wireless Adapter? I found that option under an external storage drive I have, but not under the adapter.

However, I did find something very interesting....
In Device Manager --> IDE ATA/ATAPI controllers --> NVidia nForce2 ATA Controller (v2.6) --> Properties

-->Secondary Channel (which is the 200GB Seagate)
The options are :
Transfer Mode is greyed out, but the greyed out value is --> "Ultra DMA 5 - Ultra100"
Let Bios Select Transfer Mode -> CHECKED
Enable Write Caching -> CHECKED

But..... under
-->Primary Channel (which is the 80GB Maxtor)
Transfer Mode -> PIO Mode
Let Bios Select Transfer Mode -> UN-CHECKED
Enable Write Caching -> CHECKED

So the bios modes are different, not sure if this is correct, but the main thing is underneath these options in "Primary Channel" there is an exclamation mark that says --> "Transfer Mode Downgraded".
When I click it, it says

"The transfer mode for this device is set to a value lower than what it is capable of because of excessive transfer errors to the device.  This will cause a loss of system performance.  Please check the cabling to the device and verify an 80 conductor flat ribbon cable is used for Ultra-66 and higher transfer modes."

But when I put the 200GB Seagate in I used 2 new ribbon cables, both are Ultra-100 on the Maxtor, and Ultra-133 on the Seagate.  Is this a sign of the HDD going belly up ?
0
 
nobusCommented:
normally yes. I would suggest first a backup of your data, then run a disk scan on them; the transfer mode in the channels should be set to DMA, not PIO.
here a way to enable DMA :

http://sniptools.com/vault/getting-back-to-dma-mode-in-windows-xp.htm
http://www.short-media.com/forum/archive/index.php/t-6598.html

Look here for info :

http://www.real-knowledge.com/dma.htm
0
 
KOTORAuthor Commented:
Thanks,
I've managed to get the 200Gig cleared, most is sitting on the 80GB Maxtor. I'm gonna install WinXP on the 200GB afresh, and then load the stuff from the 80GB. Problem is the 80GB obviously has XP still on it.  When I put XP on the 200GB, and put it on the primary IDE, after XP is on it, what would happen if I just put the 80GB on the secondary slave say?, will the BIOS boot the primary HDD?
Its just I want to get the 80GB drive running alongside the 200GB one so I can get the stuff off it onto the 200GB. I know 2 HDDs both with an OS on can cause problems, but you think there is anychance that XP will just boot off the 200GB and load the 80GB as standard storage or will the BIOS kick up a fuss, or will the 80GB drive just not be visible ?
I have partition magic 8, can I use the DOS disks to wipe the 'boot record' from the 80gig keeping all the data and partitions intact ?
Suggestions generally are appreciated,
Thanks.
0
 
nobusCommented:
>>  will the BIOS boot the primary HDD  <<  with a proper OS and boot record, yes.
>>  but you think there is anychance that XP will just boot off the 200GB and load the 80GB as standard storage  << yes, it should do that; it can only boot from 1 partition (or HDD) and will see the others as storage, even is they are bootable.
if you want to boot from both, you should need a multiboot setup.
>>  can I use the DOS disks to wipe the 'boot record' from the 80gig   << you can do that, but it would not be necessary; you can also delete the windows folder if you like.

Be aware, that you may not be able to use the installed programs on the 80 Gb.
if you just want it for storage, just delete all files and folders, once it booted up from the other drive.
0
 
KOTORAuthor Commented:
Thanks again,
I am beginning to hate computers.... alot.

I set the 200Gig as Primary Master, and the CDRW is Secondary Slave (I'll change the jumper at some point but as there is nothing on the Secondary Master I wouldn't have thought it would be a problem.) The 80Gig is disconnected.

I booted up with Partition Magic 8.0 diskettes. The first diskette reported a warning saying "HIMEM.SYS !Warning : Address Line A20 already enabled".
It continues on though without any keyboard response needed. Then the second disk starts loading up the logo etc, and it goes back to dos giving

CauseWay Error 09 : Unrecoverable internal exception, program terminated.
along with something similar to

EAX=0000 240 EBX=00000107 ECX=00000040 EDX=00000002 ESI=00000000
EDI=000000C4 EBP=00000780 ESP=0000074   EIP=00001A89 EFL00013200
CS=00    DS=00 7 ES=00B# FS=0063 GS=0063 SS=008B
CR0=80000011  CR2=00000000  CR3=0023A000  TR=0023
SystemFlags=80000000.

Some guys on google said bad ram was the fault for them, and replacing it fixed it.  But as the long history of this post shows. My  mem stick passes all memtest and docmem tests, I did however switch it to another dimm slot incase but it made no difference.

oh man...
0
 
nobusCommented:
well, at this point i would suggest to restart from scratch; test as much components as you can on another system, like ram, disk, cd drives, pci cards, etc...
i hope you have not a bad  motherboard on your hands...
but, if you can, swap the memory first, give it one more shot...thumbs up!
0
 
nobusCommented:
maybe fingers crossed is better ? !
0
 
KOTORAuthor Commented:
Thanks :-)
I switched it for one of the good 256's I had, error was identical.

I put the XP disk in, made it format the disk (it thought it was 131GB not 200GB, I read this was because the older XP disks cannot understand ~135+ and so it will understand when I install SP1.)

So it formats fine, puts all the files on ok, then says its going to reboot. When it does it loads the CD again as if nothing had happened, and trys to start over. I checked the order of booting in the BIOS is
1)Floppy
2)HDD
3)CDRom
So the HDD should have loaded not the CD. If I reboot again and remove the CD it says "boot failure insert system disk".

I have no idea what to do.
0
 
KOTORAuthor Commented:
I put the 80Gig back in (its just as Primary Slave to the 200Gig), and XP booted, I turned on Partition Magic 8.0 which works in windows ok and it shows the 200Gig as healthy and fine ?!? It even has a Windows folder, how come its not booting on its own ? Is there anyway I can use boot magic or any other software to look at its MBR and check its set to boot from the Windows folder ?
0
 
nobusCommented:
look here what WD says about the 137 Gb limit :

http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/std_adp.php?p_faqid=928&p_created=1049320914&p_sid=u9Tm6mHh&p_lva=&p_sp=cF9zcmNoPSZwX3NvcnRfYnk9JnBfZ3JpZHNvcnQ9JnBfcm93X2NudD03OTAmcF9wcm9kcz0mcF9jYXRzPSZwX3B2PSZwX2N2PSZwX3BhZ2U9MQ**&p_li=&p_topview=1

as i understand, your "boot failure insert system disk" error comes mostly from a bios that is not able to handle this big disk; so maybe a bios upgrade is needed.
0
 
KOTORAuthor Commented:
I'll ring the guys I bought both the mobo from and the HDD and ask them. I think my MBR has been damaged
from I got it because its only 2 months or so old and this is the first time its been used as a bootable drive.

Funny thing is,
FDisk
BootMagic
Active@Uneraser
Spinrite v6.0

none can read the mbr or the partition table ?!?

If the mbr was damaged then this would make sense, they all say
"cannot read mbr"
or in the case of Active@Uneraser
"cannot read sector 0 on 80h".

But obviously the partition table is fine because I can change the partitions, resize, and reformat all I want when I use the drive as a
storage drive alongside the 80Gig Maxtor. So obviously its ok, so why can none of these DOS apps read it ??

Particularly Active@Uneraser says, when I click "view sectors in hex", that it cannot read any sector that I cycle to, and I've cycled up
to sector 10 ??

I'm going to put it in another system and see if I can read/write the mbr from there otherwise I think its busted. So if I buy another smaller Seagate
I can boot from it and simply use the 200Gig as storage (games and such). But I don't know that I want another Seagate after this...

Any other suggestions welcome,
Thanks again for all the help through this knightmare system.
0
 
KOTORAuthor Commented:
Also,

Do you know any windows software to view the mbr ?

I'd like to see out of curioiusity if the mbr were accessible from XP on the Maxtor.
0
 
nobusCommented:
0
 
KOTORAuthor Commented:
Cheers again,
MBR wouldn't work in Windows, I got a popup box saying that a program tried to access the HDD directly and couldn't be supported,
close or ignore. Ignore started the prog but it wouldn't access anything. So I stuck it on a Win98 boot floppy and started it.

It dumped the Maxtor mbr to the screen fine, and when I tried to dump the Seagate I got "mbr could not be read written."

I think I'll have to accept I have received yet ANOTHER duff component, unless my mobo is faulty and buggering everything :-\

I'll stick the HDD in another motherboard (though its slightly older which ain't good) and see if I get anywhere, but I think the HDD mbr
is a goner. And since the partition table seems intact for Windows to use it I don't know why all these apps cant access it.

Do you think the drive should be safe enough for data storage?, or do you think the fact the mbr is gone means the drive should be
considered not safe even for that? Though its been working fine for storage thus far.

Thanks for everything.
0
 
nobusCommented:
it is not a certainty, but i think you can use it that way.
here some more utils to test and play with : ultimate boot cd

http://ubcd.sourceforge.net/
0
 
KOTORAuthor Commented:
ok guess what !?!
I did the following...

Took the HDD out and put it in a 2 year old Jetway mobo with GeForce2GTS,512RAM, standard stuff.
Put the mbrtool DOS disk in.
Turned it on
Ran mbrtool
Successfully dumped mbr to screen first try.

Took HDD back out and put it in current System, NF7, GF6800GT etc.
Put mbrtool DOS disk in
Turned it on
Ran mbrtool
Successfully dumped mbr to screen first try.

Put XP disk in, DOS install and reboot
Rebooted to HDD.

Now I cannot find the freakin' logic in what happened here.

Either

a)Me taking out the HDD and the slight movement of me carrying it to another room fixed it, ie intermittant problem.
Lets freakin' hope not....

b)The NF7 for some reason wasn't letting any access to the mbr (I checked, there was no mbr virus protection enabled btw)
or the HDD was preventing that particular mobo from initialising its mbr.
The other mobo then initialised it, and when placed back in other system the mbr was accessable.

c)Some wierd stuff I can't think of.

I don't like it when stuff happens I can't learn from. Unless the lesson is, if it don't work try it in another computer and screw
the logic.

I've so far got bare bones XP on. I'll put SP2 on, then nForce drivers, then Sound/Graphic card drivers, network drivers.
Then I can let you know whether the original problem still exists.

Also, how come the points is limited to 500, was that introduced recently ?

Thanks.
0
 
nobusCommented:
no, but connecting it to another mobo may have corrected the issue.
yesterday, i had a disk that would not boot up, it went into the windows XP screen for some time and rebooted.
When runningERD commander, it did NOT find any OS, to log onto.
i installed xp on another drive, put that as master, and the bad one as slave, and during bootup, it started dskchk.
Guess what : all boot problems were over !

so maybe the fact that it was connected to the other  mobo started it somewhat different,
fixed some bytes here and there, enough for you to get it working.
0
 
KOTORAuthor Commented:
Most things have been going smooth since. No Memory access errors yet at least.  

One thing was though, when playing Half-Life 2 the monitor went into Standby, and the sound "hung" if you know what I mean (so the system obviously hung when the
monitor went into standby).  Sounds like the Graphic card shut down. I pressed reset and it came back on again normally immediately though, which made me think
it could've been a power fluctuation .  I was wondering was it the PSUs fault, but its a 480W Tagan which I wouldn't have expected it from.

The CPU was heatin' up to around 60C+ though, so maybe the system generally just didn't like it.  

I've since turned the CPU fan well up, alittle noisey but the CPU temps are lower.
CPU hit 55C and GPU core 65C when I've tested the CPU and graphic card using "The Project", Cytek new Tech demo running at max detail for about an hour.
Highish for the CPU but ok for the graphic card. Still decent bit cooler for the CPU than 60C, so I'm wondering could the CPU have caused this? Anyways, I've told the supplier
about it and if it happens again the card will go back as the warranty is up in September.

And I hope hope hope (fingers crossed) I'll have a new job soon,
so that ASUS mobo will be on its way if I do, as I have no confidence in this one at all.
I'll leave this open a short while longer incase anything arises, but fingers crossed things have "calmed down" :-D
Cheers.
0
 
KOTORAuthor Commented:
Again, I'm still here.

The error has started appearing again, duno what to do bout it. Is there any chance its the graphics card or will a mobo replacement sort me? I've asked the supplier for advice,
wait and see what he says in the next few days.

Thanks.
0
 
nobusCommented:
Kotor, are you still trying to repair the old system? IMHO it is time for a fresh install. If you did, forgive me, but this thread is becoming very long, and starts on 4/17, so i don'treally follow it anymore.
I still want to help you out, but rereading the whole thread is becoming too time consuming
0
 
KOTORAuthor Commented:
Thanks,

Yes there was a fresh install on the new Seagate HDD, error went away for a while, but came back, more and more frequent :-(

It all started when I chained this Seagate in as storage, thats when this error began. Now its the only drive and its still happening, one would imagine its the
Seagate but its performing flawlessly otherwise. Maybe the mobo just doesn't like it (as the previous mbr showed).

Anyways, thanks for all the help.
0
 
nobusCommented:
no problem ! and thanks for the grade !
0
 
mysticaldanCommented:
Have u tried partitioning the disk to FAT32 or NTFS instead of what u have as current. If possible install Windows on a FAT32 partitiona nd then see if that helps. I have had similar problems that went away in this manner.

Dan
0
 
KOTORAuthor Commented:
Dan:
The 200GB Seagate is partitioned into 2 drives (92.7 and 93.5 = 186.2, meaning 14Gigs have disappeared in formatting) as NTFS.  Do you think formatting the 92.7GB 'C' as FAT32
would help? It seems to have helped you, but how? WinXP has been designed to use as a preference NTFS (hence its asking upon installation), is it the HDD's fault or what?
Is it completely impossible to do a NTFS->FAT32 without a format ?

nobus:
No problem.

My Athlon 2800+ is running ~53C idle, so I was going to detach the CPU fan, rub off the thermal pad that came on the ThermalTake TTM2 HSF and apply some thermal grease to try and
lower the temps incase that was causing problems. There is also ocassionally a irritating vibrating noise that comes from it, almost sounding like a vibrating screw, though I can't find one.
It goes away if I tilt the case up at about 20degrees for 15minutes.
0
 
nobusCommented:
Can it be a fan?
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 23
  • 19
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now