• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 530
  • Last Modified:

CD drive (2) set up as D: & E: in error. How do I delete them?

In a setup of WIN95 I encountered in My Computer after install two CD drives appeared along with a Drive F: which I can access to play audio CD'S, install programs, etc. I have tried to delete them but they are not mapped drives. I tried to delete them in Explorer but when I select them I get an error message "ACCESS DENIED". How do I delete them?
0
cgack
Asked:
cgack
  • 2
1 Solution
 
☠ MASQ ☠Commented:
Try removing them from device manager in Windows
(right click my computer, properties,device manager, expand the drives and then hit the remove button)
The see what happens when you reboot, if they return then something in your hardware is being seen as additional removable drives before Windows finds your real CD unit.
0
 
cgackAuthor Commented:
Tried what you suggested MASQUERAID but Win95 device manager dosen't show drives just controllers. Any more thoughts?
0
 
☠ MASQ ☠Commented:
Any CD emulation installed?
What does the BIOS report as being attached before Windows in launched?
If you're happy opening the box what happens if you disconnect the CD drive?
How are the Hard drive and CD Drive physically attached to the motherboard?
0
 
nedvisCommented:
      Remove Duplicate Drives --->   http://support.microsoft.com/kb/q218617/
Remove any duplicate CD-ROM or DVD drives being loaded by Windows. To do this:
1.      Click Start, point to Settings, and then click Control Panel.
2.      Double-click System.
3.      On the Device Manager tab, click View Devices By Type.
4.      Double-click the CDROM or DVD branch to expand it.
5.      Note the properties for each device listed in the branch. To do this:
a.       Click a device, and then click Properties.
b.       Click each tab in the device properties dialog box, and then record the device information and settings.
c.       Click OK.
6.      Click OK, and then close Control Panel.
7.      Restart Windows in Safe mode. To do this, use the appropriate method for your version of Microsoft Windows.
Windows 95
Restart the computer. When you see the "Starting Windows 95" message, press the F8 key, and then select Safe Mode on the Startup menu.
Windows 98 and Windows Millennium Edition
Restart your computer, press and hold down the CTRL key when your computer completes the Power On Self Test (POST), and then select Safe Mode on the Startup menu.
8.      When Windows starts in Safe mode, click OK.
9.      Click Start, point to Settings, and then click Control Panel.
10.      Double-click System.
11.      On the Device Manager tab, click View Devices By Type.
12.      Double-click the CDROM branch to expand it.
13.      Verify that there are no changes in the list of devices in the branch. If you see a device that is not in the list of devices you noted in step 5, click the new device, and then click Remove. Repeat this step for each device in the branch that is not in the list of devices you noted in step 5.

NOTE: If you see new copies of a device that is in the list of devices you noted in step 5, check the properties of each copy of the device. If the properties for the device match the properties you recorded, keep the device. If the properties for the device do not match the properties you recorded, remove the device.
14.      Click OK.
15.      When you are prompted to restart the computer, click OK
*************************************************************************************
Make Sure You Are Using Protected Mode Drivers -->  http://support.microsoft.com/kb/151634/EN-US/
           If you have Windows 95 or Windows 98, ensure that you are using protected mode (32-bit) drivers for your CD-ROM or DVD drive. To do this, follow these steps:
1.      Click Start, point to Settings, and then click Control Panel.
2.      Double-click System.
3.      On the Performance tab, confirm that the File System entry is 32-bit. If the File System entry is Some drives are using MS-DOS compatibility you are using MS-DOS disc drivers (real mode or 16-bit drivers). If this is the case, you may not be able to read certain files on the CD-ROM as some programs only work correctly with protected-mode drivers.
*************************************************************************************
      You can also rename your current Autoexec.bat file to autoexec.old or autoexec.test youst to preven MS-DOS ( real mode) CD-ROM driver from loading before Windows95 (protected mode) starts as well as config.sys .
    It might be that real mode ( MS-DOS ) drivers for your CD-ROM drive  are configured and loaded from those two files.
    If that helps : you can just uncomment  lines in config.sys and autoexec.bat files pertaining to CD-ROM device driver.
   
 good luck
  nedvis
     
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now