Lynksys Router WRK54G cannot connect to internet wirelessly

Posted on 2005-04-17
Last Modified: 2013-11-29
Hey guys I have what will probably be a simple qusetoin but since I am not familiar with wireless networking I need some assistance.

I have one computer wired to a router, the router is connected to the cable modem, and I have full internet function on this connection.  

However I also have three wireless devices that if I set the ip address' manually I can connect to the network but I still have no internet.

Everything worked fine until I needed to open a port for a game and couldnt remember the password to the Lynksys WRK54G.  I had to reset it to access the setup menu and now I am having these issues.

I am sure it is a setting with the router but I just dont know what it is.  When any of the three wireless adapters try to connect they stop at aquiring ip address.

Thanks in advance,

Question by:ypjoe777
    LVL 15

    Expert Comment

    Go to one of your wireless PCs and go to the command prompt.

    Start -> Run -> Type the word "cmd" (without the quotes) -> Click OK

    Now you're at the DOS prompt.  Type: IPCONFIG /ALL [press enter]

    Do you have an IP address in the 192.168.1.X range ?
    If your PC is not seeing the wireless device your IP address will be 169.254.x.x

    On the wireless router make sure:

    1. You have DHCP turned on.
    2. If you configured wireless encryption with a WEP key then you have to set that on the laptops network config.
    3. If you configured the wireless router to accept on certain MAC addresses then you need to enter the MAC addresses from your wireless laptops network cards.

    um....I see you said you're manually inputting the IP. Why?

    It's MUCH EASIER to configure the router for DHCP and the laptop/wireless device for DHCP.

    If you do it manually, then you have to have the IP address, Subnet Mask, Router and DNS server correctly entered.

    LVL 15

    Expert Comment

    If you insist on manually configuring wireless laptops/devices......

    Obtain the IP address of your router, which is *often*
    The default subnet is

    On your laptops/wireless devices you'd configure these IP settings:

    IP address : 192.168.1.x  (where x=2 to 254)
    Def. Gateway : (the router's IP address, ok)
    DNS server: (router's IP address again)
    LVL 3

    Author Comment

    Thanks for the quick responses...

    I do no insist on assigning them manually...the problem is that if I try to do it automatically nothing ever happens.  Xp Home trys to make the connection and then says that it can't...something like network wont respond.

    When I entered it manually I could connect to the network but could not connect to the internet...Seems strange to me but that is the problem I am having.

    I have already tried everything you have suggested.

    Thanks and hopeully this helps you guys pinpoint my problem.

    LVL 7

    Assisted Solution


    It seems that you have reset the Linksys device, but not the wireless PCs.
    Perhaps it is the PCs thqat are set up to require encryption.
    I'm guessing that the Linksys is not using encrytion at this point in time.
    If that is so then pick one wireless PC.
    Check if the wireless PC is trying to use encryption - and either turn it off (not good in the long run)
    or set a new security key on the Linksys and enter it into the PC.

    Then set the PC to use DHCP - hopefully this time it will work.
    LVL 3

    Author Comment

    Alright I now have some of the issues fixed but I still have a problem...

    As I said earlier everything has worked beautifully until I reset the router.  Well now I have two of the three wireless connections running what seems to be flawlessly.  However the third has become a nightmare.  After trying every setting I thought were pertinent I came to the conclusion that I was missing something small that I probably wouldnt ever find so I took what might seem as a drastic measure.  I did a fresh install of XP Home on it.  Really it isnt that big of deal becasue it is a fairly new build and I have everything backed up.

    But there still lies the problem that I cannot connect to the network with this PC.  I have all securities turned off, both router and PC.  The frustrating part is that it sees the network but just wont connect to it correctly.  Everything is set to assign automatic ip but I still cant get anything out of this PC.

    I have a little but of time on my hands today so hopefully we can figure this out.

    Thanks again,

    LVL 3

    Author Comment

    A couple more notes.....

    It shouldnt matter because all of my hardware has worked fine for a while be just in the case that it does help I thought I would tell you that my Wireless card is a D-Link dwl-g520 AirplusExtremeG.

    I did notice that my automatically set ip address is  not sure if that helps but I want you guys to have all the information possible.

    Also I am pretty sure that by telling me to enable DHCP on the PC you are telling me to enable automatic ip address' but I am not certian.  I didnt see any settings other that in the router for DHCP.

    Thanks once again,

    LVL 15

    Accepted Solution

    Right, on your PC you pick obtain IP address automatically & obtain dns automatically......and on the router you set it to lease ip addresses.....usually it hands out something like and up....depends on the make/model.

    Pictures of the config for your linksys are here:

    See the part where it says "Local DHCP Server   * Enable    Disable"   ?
    (under that it reads: start ip address, number of addresses, dhcp address range....."

    You should select ENABLE for DHCP - you could config just like in the picture.
    Let me know if that makes sense.  But your D-link is getting ??? Weird.
    Does the wireless card come with a wireless management program (may appear as a D in the bottom right corner of your screen).  Sometimes the Windows Wireless Zero service conflicts with the wireless utility provided by d-link.

    Do you have any icon at the bottom right, where you right-click on it and can choose what wireless network you want to join?
    You either pick "status" or "view available wireless networks".  You should be able to "see" your wireless network from here.
    Can you?

    LVL 3

    Author Comment

    Well guys I have good news~

    After my last posts I began experiencing strange problems with all of wireless connections so I reset the router again via the setup menu(not the reset button).  I then disabled the DHCP and then Enabled it and everything is working great.

    Seems that maybe the reset was corrupt somehow or that turning the DHCP on and then off corrected all of the issues.  I will split the points as both of you helped out.

    Thanks alot guys,


    Featured Post

    Give your grad a cloud of their own!

    With up to 8TB of storage, give your favorite graduate their own personal cloud to centralize all their photos, videos and music in one safe place. They can save, sync and share all their stuff, and automatic photo backup helps free up space on their smartphone and tablet.

    Join & Write a Comment

    Don’t let your business fall victim to the coming apocalypse – use our Survival Guide for the Fax Apocalypse to identify the risks and signs of zombie fax activities at your business.
    PRTG Network Monitor lets you monitor your bandwidth usage, so you know who is using up your bandwidth, and what they're using it for.
    Viewers will learn how to properly install and use Secure Shell (SSH) to work on projects or homework remotely. Download Secure Shell: Follow basic installation instructions: Open Secure Shell and use "Quick Connect" to enter credentials includi…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

    754 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now