[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 260
  • Last Modified:

Network Shares are Read Only.......

Server single domain controller running Windows 2003 and has replaced a Windows NT server.

7 x XP clients (SP2 I think, currently unable to check)
1 x w2k client (SP4)
1 x 98 client. (All OK)

New server in place, data copied across and all clients setup with roaming profiles. User profiles are currently setup to Connect Z: as \\server\share\user. The drive gets mapped Ok, but is set to read only. The same is true of the w2k client. However I did get the 98 machine to read correctly. No matter what I do to the shares on the server they still go read only for users.
0
Manchester_Ronnie
Asked:
Manchester_Ronnie
1 Solution
 
Pete LongConsultantCommented:
All Folders Are Read only?

The square (or greyed out check mark) for a folder means NOTHING, NO CHANGE, WAITING
FOR YOU TO USE ME.  This is because the read-only box in a folder's properties is
only used to apply or remove the read-only setting from all of the folder's files
at once. If you clear the box and click Apply, then the files in the folder will
be cleared of any read-only attributes they have. Like wise for checking the box
to apply the attribute to all files.  The square reappears the next time because,
once again, you haven't used it.

FOLDERS do NOT have a functional read-only attribute in Windows.  The read-only attribute
is only for files.  The read-only check-box for folder properties is a bad and confusing
design.  If you want to avoid read-only confusion, check individual files, ignore
folders.

Windows file systems actually use the read-only attribute for a folder to make it
customisable, but the checkbox in a folder's properties has nothing to do with that.
 You cannot prevent a folder's contents from being changed using the read-only attribute.
 You can read more about that here:    

http://support.microsoft.com/default.aspx?scid=kb;en-us;326549

From http://www.annoyances.org/exec/forum/winxp/1065399208
0
 
oBdACommented:
Have a look at the *share* permissions (right-click the shared folder, Properties, tab "Share", button "Permissions"). Unlike NT4/W2k, shares you create will have a default security setting of only Read permissions for the Everyone group; NT4/W2k set it to Full automatically (yes, I've fallen for this, too, when W2k3 came out).
0
 
Manchester_RonnieAuthor Commented:
Cheers for that an easy 500 points!
0

Featured Post

Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now