[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 659
  • Last Modified:

WU-FTP slow in connecting up

I am running WU-FTP on a linux box( rmstreamer) RedHat 7.1 with 2 network cards.
One ATM-25 card connection to the external network via a XYLAN switch.
A ethernet nic card connection the internal network.

When connecting to the FTP server via the internal networkting there is no issue.
Connection can be established immediately. I have checked the /etc/resolve.conf and it
appears to work fine. So the problem is not with resolving.

When connecting via the ATM card from the exterior the connection takes
a long time to establish.
This is what I get
               [atma@oldguard atma]$ ftp 165.21.7.3
                Connected to 165.21.7.3 (165.21.7.3).

The username and password appear after approximatley 30 seconds
I have capture the tcpdump for the ATM and ethernet connections

Tcpdump - Ehternet Connection

13:47:51.045689 < 172.17.2.207.1602 > 172.17.2.202.ftp: S 2435518111:2435518111(0) win 16384 <mss 1460,nop,nop,nop,nop>(DF)
13:47:51.046087 < 172.17.2.207.1602 > 172.17.2.202.ftp: . 2435518112:2435518112(0) ack 762101979 win 17520 (DF)
13:47:51.049171 < 172.17.2.207.auth > 172.17.2.202.1278: R 0:0(0) ack 761689318 win
13:47:51.272011 < 172.17.2.207.1602 > 172.17.2.202.ftp: . 0:0(0) ack 69 win 17452 (DF)


tcpdump for the ATM card:

13:52:04.995831 < 202.42.99.56.58735 > 165.21.7.3.ftp: S 2346538258:2346538258(0) win 5840 <mss 1460,nop,nop,timestamp 1564373402 0,nop,wscale 0> (DF)
13:52:05.015831 < 202.42.99.56.58735 > 165.21.7.3.ftp: . 2346538259:2346538259(0) ack 1042881203 win 5840 < nop,nop,timestamp 1564373403 1680488> (DF)
13:52:35.115831 < 202.42.99.56.58735 > 165.21.7.3.ftp: . 0:0(0) ack 69 win 5840 <nop,nop,timestamp 15643764 08 1683492> (DF) [tos 0x10]

Once the connection has been established, the speed of upload and download is OK.
I have also removed the firewall rules on the linux box with out any success.

Could any one suggestsome pointers how to solve the problem

Thank you in advance.

asidu.
0
asidu
Asked:
asidu
2 Solutions
 
RobsonCommented:
I guess there are two possible causes:

1) DNS -- wf-ftpd probably wants to log client's FQDN (fully qualified domain name)
2) ident -- it may also try to check (via auth protocol) which user uses FTP.

Look for configuration options and try to disable that features in wu-ftpd (I'm not familar with it so I cannot give you any hint).

Good luck!

Robson.
0
 
wesly_chenCommented:
Hi,

  DNS resolving is the key factor to slow down the connection. Add
dns resolveroptions -dnsrch
   --- turns off the dnsrch option (search the domain path).

into /etc/ftpaccess
and restart the wu-ftp (or xinetd).
0
 
asiduAuthor Commented:
Thanks guys.
Could not resolve the issue by putting the  line
dns resolveroptions -dnsrch
in the /etc/ftpaccess

Instead the problem has been resolved by editing the
/etc/xinetd.d/wu-ftpd

From:
             log_on_failure   +=DURATION USERID
             log_on_failure    +=USERID

removed the USERID from the two lines
To:
             log_on_failure   +=DURATION
             log_on_failure    +=

Restarted the xinetd service.

Now able to log in with out the delay.

Thank you for the pointers.

Asidu
0

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now