• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3924
  • Last Modified:

NFS problems

i get the following error when i try to mount my share:

root@23# mkdir /export/home/test_nfs
root@23# mount 19:/export/home/test_nfs /export/home/test_nfs
nfs mount:19: : RPC: Rpcbind failure - RPC: Unable to receive
nfs mount: retrying: /export/home/test_nfs
nfs mount:19: : RPC: Rpcbind failure - RPC: Unable to receive

root@23# ps -ef | grep nfs
 daemon   502     1  0   Mar 09 ?        0:00 /usr/lib/nfs/statd
root   501     1  0   Mar 09 ?        0:00 /usr/lib/nfs/lockd
 root  1659  1629  0 09:57:25 pts/1    0:00 grep nfs


NFS Server config:
root@19# ./nfs.server start
root@c19# share
-               /export/home/test_nfs   ro   "" 
root@19# ps -ef | grep nfs
    root  2288  2174  0 09:56:59 pts/1    0:00 grep nfs
    root  2284     1  0 09:56:14 ?        0:00 /usr/lib/nfs/nfsd
root@19# share
-               /export/home/test_nfs   ro   "" 
root@19# more /etc/dfs/dfstab

#       Place share(1M) commands here for automatic execution
#       on entering init state 3.
#
#       Issue the command '/etc/init.d/nfs.server start' to run the NFS
#       daemon processes and the share commands, after adding the very
#       first entry to this file.
#
#       share [-F fstype] [ -o options] [-d "<text>"] <pathname> [resource]
#       .e.g,
#       share  -F nfs  -o rw=engineering  -d "home dirs"  /export/home2
share -F nfs -o ro /export/home/test_nfs

0
Traverse-61
Asked:
Traverse-61
  • 3
  • 2
1 Solution
 
neteducationCommented:
Is your server really only called 19 ?

I could imagine mount is trying to access a machine at 0.0.0.19

try mounting with the ip-address to see if it's about that

mount 192.168.0.10:/export/home/test_nfs /export/home/test_nfs
0
 
Traverse-61Author Commented:
No the actuall hostname is much longer.  I figured out the problem.  NFS needs RPC.

Kill all NFS services.  Start RPC.  Re-enable NFS. Works just fine.

Thanks,

Trav.
0
 
neteducationCommented:
just verified and mount 19:/export/home/test_nfs /export/home/test_nfs is contacting 0.0.0.19 even if there is an entry for 19 in /etc/hosts

so eigther mount it over the ip, or add an alias let's say h19 to /etc/hosts and mount h19:/expo......

0
 
Traverse-61Author Commented:
Thanks neteducation, for trying to help out, but I found the solution,  See my comments above regarding NFS and RPC.  You get the points for responding.
0
 
neteducationCommented:
I was thinking about the RPC thing too, but the error message was more like the ip-problem.

Funny thing aside: I'm teaching a course this week... and this afternoon I was telling my students about how RPC works, and tomorrow I'll tell them how NFS works. So good timing for your question :-)

Thanks for the point anyway. maybe this "solution" will help somebody else :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now