[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 264
  • Last Modified:

Password change Error

While logged as root , I tried to change the password of one user, I got the following message :
-----------------------
RPC: Can't encode arguments
The password has not been changed on sebulba.mksi.com.
passwd: Failed preliminary check by password service
--------------------------
However, I am able to change the password of other users.
What could be the possible reason ?
0
mn210
Asked:
mn210
  • 3
  • 2
1 Solution
 
wesly_chenCommented:
Do you use LDAP or NIS?
Check /etc/nsswitch.conf  (passwd:  files nis ldap ....)
The user's password you want to change is in NIS or LDAP then you.

You need to change the user password on NIS/LDAP server.
0
 
mn210Author Commented:
Can you please elaborate as what I am supposed to do to change password ?

Actually, I am also getting this message on ypclient:
YPBINDPROC_DOMAIN: Domain not bound
YPBINDPROC_DOMAIN: Domain not bound
_______________________________________________________
I have the following snapshot in /etc/nsswitch.conf on NIS server.

[sharmam@sebulba sbin]$ ./rpcinfo -p localhost
   program vers proto   port
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper
    100004    2   udp    799  ypserv
    100004    1   udp    799  ypserv
    100004    2   tcp    802  ypserv
    100004    1   tcp    802  ypserv
    100007    2   udp    945  ypbind
    100007    1   udp    945  ypbind
    100007    2   tcp    948  ypbind
    100007    1   tcp    948  ypbind
    391002    2   tcp  32768  sgi_fam
    100009    1   udp    703  yppasswdd
[sharmam@sebulba yp]$ more securenets
#
# securenets    This file defines the access rights to your NIS server
#               for NIS clients. This file contains netmask/network
#               pairs. A clients IP address needs to match with at least
#               one of those.
#
#               One can use the word "host" instead of a netmask of
#               255.255.255.255. Only IP addresses are allowed in this
#               file, not hostnames.
#
# Always allow access for localhost
255.0.0.0       127.0.0.0

# This line gives access to everybody. PLEASE ADJUST!
0.0.0.0         0.0.0.0
----

YPCLIENT
sharmam@enterprise sbin]$ ./rpcinfo -p localhost
   program vers proto   port
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper
    100024    1   udp  32768  status
    100024    1   tcp  32768  status
    100004    2   udp   1016  ypserv
    100004    1   udp   1016  ypserv
    100004    2   tcp   1019  ypserv
    100004    1   tcp   1019  ypserv
    100007    2   udp    612  ypbind
    100007    1   udp    612  ypbind
    100007    2   tcp    615  ypbind
    100007    1   tcp    615  ypbind
 600100069    1   udp    640  fypxfrd
 600100069    1   tcp    642  fypxfrd
    391002    2   tcp  32769  sgi_fam
    100009    1   udp    776  yppasswdd

[sharmam@enterprise /etc]$ more host.conf
order hosts,bind

[sharmam@enterprise /etc]$ more nisswitch.conf

passwd:     nis nisplus files
shadow:     nis nisplus files
group:      nis nisplus files

#hosts:     db files nisplus nis dns
hosts:      files nis nisplus  dns

# Example - obey only what nisplus tells us...
#services:   nisplus [NOTFOUND=return] files
#networks:   nisplus [NOTFOUND=return] files
#protocols:  nisplus [NOTFOUND=return] files
#rpc:        nisplus [NOTFOUND=return] files
#ethers:     nisplus [NOTFOUND=return] files
#netmasks:   nisplus [NOTFOUND=return] files    

bootparams: nisplus [NOTFOUND=return] files

ethers:     files
netmasks:   files
networks:   files
protocols:  files nisplus nis
rpc:        files
services:   files nisplus nis

netgroup:   files nisplus nis

publickey:  nisplus

automount:  files nisplus nis
aliases:    files nisplus
________________________________________________

Can you please help find as what went wrong ?

Thanks for your cooperation
0
 
wesly_chenCommented:
1. If the Linux box is the NIS client, then as root,
/usr/sbin/authconfig
to configure your NIS setting (NIS IP address and NIS domain).
For NIS information, please ask your sys admin or find out from the NIS server.

2. If the Linux box is NOT NIS client (standalone box), then as root), edit /etc/nsswitch.conf
passwd:     files nis nisplus
shadow:     files nis nisplus
group:      files nis nisplus
0
 
mn210Author Commented:
Thanks ... It worked.
I do have database of user accounts on NIS server.Now, when I add new users, how can I ensure that they are added to the existing database ?
Actually, I added useraccounts on both NIS server and NIS client and their passwords can be changed using passwd command presumeably because they are stord in local files and are not part of NIS database .
Thanks for your coperation ...
0
 
wesly_chenCommented:
> NIS client and their passwords can be changed using passwd command presumeably
You need to run yppasswdd on NIS server.
So the "passwd" command from NIS client will talk to NIS server to sync the NIS database.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now