• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 684
  • Last Modified:

Exchange server, Outlook 2003 keeps asking my password on rpc over http connection

I am connecting to an exchange server with Outlook 2003 with rpc over http.  The problem is that with this connection the Oullok program keeps asking me for my exchange logon password to connect to the exchange server.  Is there a way to have it remember the password?
0
murryc
Asked:
murryc
1 Solution
 
san_swaCommented:
Hi,

You need to set anonymous access for the users to get access to the Mailbox, and it would also not ask for password.

Configure the RPC virtual directory in Internet Information Services
After you configure the Exchange computer to use RPC over HTTP, you must configure the RPC virtual directory in Internet Information Services. To do this, follow these steps: 1. Click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
2. Expand servername (local computer), expand Web Sites, expand Default Web Site, right-click Rpc, and then click Properties.
3. Click the Directory Security tab, and then click Edit under Authentication and access control.
4. Click to clear the Enable anonymous access check box.
5. Click to select the Basic authentication (password is sent in clear text) check box.

You receive the following message:
The authentication option you have selected results in passwords being transmitted over the network without data encryption. Someone attempting to compromise your system security could use a protocol analyzer to examine user passwords during the authentication process. For more detail on user authentication, consult the online help. This warning does not apply to HTTPS(orSSL) connections.

Are you sure you want to continue?
Note In this error message, the word "HTTPS(orSSL)" is a misspelling for the words "HTTPS (or SSL)."  
6. Click Yes, and then click OK.
7. Click Apply, and then click OK.
The RPC virtual directory is configured to use basic authentication.

Above information is taken from KB Article http://support.microsoft.com/?id=833401
0
 
SembeeCommented:
If the setting change above doesn't fix the problem, then take a look at http://support.microsoft.com/?kbid=820281 as you need to change the RPC settings.

Simon.
Exchange MVP.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now