SBS 2003 - Server Management - Performance Report - "Page cannot be found"

Posted on 2005-04-18
Last Modified: 2013-12-03
I am running SBS 2003 and within the 'Server Management' console, when I navigate to "Monitoring & Reporting", I get a message "The page cannot be found".   This occurs with both the performance and usage reports.

In addition, when the scheduled time comes for the reports to be emailed, the same error message is emailed to the receiptient(s).

Anyone have a clue how to resolve this issue?

Question by:KAdkisson
    LVL 16

    Expert Comment

    1) If you only just installed the system, then there's nothing to display in that page until the system has been up for a few hours and has accumulated some data to report upon.

    2) If it's been up longer than this, check that the two relevant Services are running. There's an MSSQL one at the very least. Sorry I'm not by my SBS box so I can't look up the actual names, but the service descriptions are pretty detailed and should help you find them.

    I had one server where the services kept dying. Re-running the Monitoring and Reporting setup script and accepting the defaults to each answer would get it going again but it'd re-die. I eventually had to re-run the setup script and *replace* the existing config with a new one (identical, but new) and that, touch wood, seems to have fixed it proper.


    Author Comment

    Thanks for the reply...

    I should have plenty of data in the log files.   The system has been up and running for several days.   Also I found that the necessary services were running and I tried replacing the configuration as suggested.  All this with no change in results.

    After some additional digging (with some trial and error), I found that if I went into IIS Manager and changed the 'Host Header Value' for the 'Default Web Site' to the word "Default" then everything appears to work properly.   This makes no sense to me but maybe it does to somebody else.

    LVL 74

    Accepted Solution

    Actually, that DOESN'T seem like the appropriate resolution... if you have SBS standard you DON'T want anything in the default website host header field because it can cause issues later.  If SBS Premium, then the proper resolution is to fix your loopback entry.

    This quote is from (

    When you click on the Monitoring and Reporting or Backup snap-in, you
    receive the following error:
    The page cannot be found
    HTTP 400 - Bad Request

    If "Show friendly HTTP error messages" is uncheck in IE, the error become:
    Bad Request (Invalid Hostname)

    SBS2003 Premium: (loopback) is missing from the Default Web Site.
    SBS2003 Standard: A host header is assinged to All Unassigned (Default)

    SBS2003 Premium:
    <Typically ISA is installed and thus Default Website is bounded to the
    internal IP only.>
    Go to IIS, Default Web Site, Web Site tab, Advanced. Server should have the
    internal IP on port 80 and on port 80. If the loopback is
    missing, click Add, and type for the IP, 80 for the port, and do
    NOT assign any host header to

    SBS2003 Standard:
    <ISA is not installed and thus Default Website is bounded to All
    Go to IIS, Default Web Site, Web Site tab, Advanced. Verify the IP address
    Default does not have a host header. Removed any host header assiged to
    If you have to assign a host header to the default website, please add with port 80 and NO host header to the default website.

    NOTE: Monitoring and Reporting, and Backup snapin in Server Management
    communicate with the IIS Default Website using Make sure port 80 is available and no host header is assigned to


    Author Comment

    You are correct.   Correcting the IP address ( and removing the Host Header resolved the issue.


    Expert Comment

    Hi everyone!

    I had the same problem with SBS standard, but the solution you put here does not work...

    any other cue to help me find a solution please?



    Expert Comment

    I found the solution....

    I go to web service extension and notice that ASP.NET v 2.0xxxx was prohibited!  i activated it and everything was working!

    Expert Comment

    TechSoEasy, your solution for SBS2003 Standard worked perfectly for me!!  Thanks!

    Expert Comment

    I had the probelm also but it was error 404
    Fled's answer helped me and solved the issue.

    Featured Post

    Highfive Gives IT Their Time Back

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Join & Write a Comment

    by Batuhan Cetin In this article I will be guiding through the process of removing a failed DC metadata from Active Directory (hereafter, AD) using the ntdsutil tool in a Windows Server 2003 environment. These steps are not necessary in a Win…
    I've always wanted to allow a user to have a printer no matter where they login. The steps below will show you how to achieve just that. In this Article I'll show how to deploy printers automatically with group policy and then using security fil…
    Hi everyone! This is Experts Exchange customer support.  This quick video will show you how to change your primary email address.  If you have any questions, then please Write a Comment below!
    Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…

    755 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now