Want to reformat, but get Data error (cyclic redundancy check) on drive

Hi there,

I have a Windows XP machine.  I bought a Maxtor 120 GB external drive and have been using it to do backups with Retrospect.  Recently, Retrospect has been failing and I went to investigate and am now stuck.  I need your help!

Retrospect backups failed and when investigating, I realized there are problems with the Maxtor drive.  I tried to reformat using the XP Disk Management tool, but it always fails in the middle.  So I tried running chkdsk e: /r /f /v and that also hung in stage 3 of 5.  

I have deleted/copied to my "normal" drive everything I care about -- I just want to clear off whatever space is usable on this drive and get it set back up for backing up my "real" drive every night.  However, I can't seem to reformat it or get rid of the bad sectors.  If I try to delete things via a cmd window I get this:

E:\Retrospect\Backup Set C\1-Backup Set C>del *
E:\Retrospect\Backup Set C\1-Backup Set C\*, Are you sure (Y/N)? y
E:\Retrospect\Backup Set C\1-Backup Set C\AA000059.rdb
Data error (cyclic redundancy check).
E:\Retrospect\Backup Set C\1-Backup Set C\AA000062.rdb
The file or directory is corrupted and unreadable.
(it repeats like this)

Can anyone provide advice for what to do?  Do I need to throw away this drive?  Can I fix bad sectors and keep using it?  Googling led me to using Norton Disk Doctor, but it doesn't seem to be a product any more -- but that suggests there IS some way of fixing this.

Bonus questions:
1) Could there be something wrong on my "normal" C: drive that is also a problem, so that when it gets backed up, I end up with the problem on E:, too?  
2) What is a bad sector, anyway?  I primarily want a practical solution here: "what do I do to fix this" but I'm also curious and would love an explanation of what happened here and what this all means from an abstract point of view (what IS a bad sector, anyway, and why can't I just reformat).

Thanks,
-Dave
JediBeckerAsked:
Who is Participating?
 
rindiCommented:
Check the maxtor site. You can download the powermax utility from there with which you can test the drive. If you get errors, you can fill in a form on the site with that error and send the disk for warranty repairs (the site also lets you check the state of your warranty. You could also use the utility to lowlevel format the drive, but I'd first check about the warranty.
0
 
Duncan MeyersCommented:
Sounds like a crook drive - chuck it (unless its under warranty, of course).
0
 
JediBeckerAuthor Commented:
Thanks for the comments, meyersd and rindi.  I'll try what you suggested, rindi, and let you know how it goes.
0
 
JediBeckerAuthor Commented:
Update: Powermax does not work with external drives, apparently (mine is external).  So that didn't help.

HOWEVER, it did point me to Maxtor's site and I eventually spoke to someone who (gasp!) had a good idea.  Turns out it was the Firewire hardware in the external drive that was the problem (using USB worked fine).

Since you helped point me to Maxtor's site, rindi, which led to my answer, I'm going to mark your answer as the solution.

Thanks,
-Dave
0
 
rindiCommented:
thanx too.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.