Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Stop pesky PDFs

Posted on 2005-04-19
11
Medium Priority
?
1,898 Views
Last Modified: 2013-11-18
Hi,

I've had a problem with PDFs now for wuite a long time, but put up with it..... till now.

Most users of Adobe reader know that if you're surfing the net and click a link to a PDF, it loads and opens directly in the browser window.

This is precicely the problem i'm experiencing.

*How do I stop PDFs loading in any and all browser windows automatically, short of uninstalling Adobe reader.* A prompt to save the file (download) would be perfect.

 I have a DSL 1Meg connection, but even then PDFs can take a very long time to load and end up pretty much halting the system completely.

I'm using Adobe Acrobat Reader 6.

There is an option in Reader to turn off display in browsers (the option is ambiguously titled, but it just doesnt seem to be working properly, and definitely not in Firefox.

It's an ugly feature of Adobe reader that should be removed asap.

Any ideas?......

Many Thanks,

Alsheron.
0
Comment
Question by:alsheron
  • 3
  • 2
  • 2
  • +3
11 Comments
 
LVL 26

Expert Comment

by:Leon Fester
ID: 13814588
Opening of .pdf files is configured by the settings in the registry. I don't think that you can control it from within Adobe. You can however right-click the .pdf file and select "Save Target As" instead of left-clicking and opening the file.

It is because there is a file association on your PC that the system tries to open the file instead of asking you to download it.
0
 

Author Comment

by:alsheron
ID: 13814719
Thanks for the suggestion dvt_localboy, but unfortunately its not what i'm looking for. I know you can right click and choose "Save Target As", but sometimes it's not clear that the link is going to open a PDF. In these cases, sudden dread sets in when i've clicked the link and realise it's going to take a good while for it to load the whole PDF into the browser (or sometimes in Acrobat Reader).

There must be some way to stop these files auto-loading at all when clicked in a browser (removing the association in "File Types" would stop the files opening in Acrobat reader when double clicked on the computer.) A simple Save As dialogue is all that should happen, nothing else.

Adobe have made a pretty *major* oversight in this area, especially considering those users still on dial-up 56k connections. The hold up and system slow-down is simply unforgivable.

Are there some settings or a registry tweak somewhere that addresses this problem exactly? Googling this problem, surprisingly, doesn't bring up any answers.

Thanks,

Alsheron
0
 
LVL 26

Expert Comment

by:Leon Fester
ID: 13814926
Have you checked for support on the Adobe site? You're right, it is a pesky problem!

I haven't tried this yet, but here is a link to some tools that allow you to enable/disable the Adobe api's.
http://www.snapfiles.com/freeware/system/fwpdftools.html

This could be helpful, you can try disabling the Adobe api's that load when you start Adobe. Essentially it is the plugin that allows Adobe and IE to communicate. In Adobe click Help.

May have an answer here.

Another potential solution is to disable Adobe Acrobat's "browser integration" feature. Follow these steps which may vary slightly depending on the version of Adobe Acrobat the user has installed:
 
Exit from all applications including all Web Browsers and AOL if the provider uses AOL.
 
Start Acrobat Reader. There should be an icon for the Acrobat Reader in the Start Menu's Program folder.
 
Click the Edit menu at the top of the Acrobat Reader screen then selection the "Preferences..." option.
 
In the window that opens choose either "General" or "Options" depending on the version of Acrobat.
 
Find the checkbox that says either "Display PDF in Browser" or "Web browser integration" and uncheck it.
 
Click OK.
 
Exit the Adobe Acrobat Reader application.
 
Restart Internet Explorer and try viewing and printing a report. When the report is generated the provider should be asked if they want to Open or Save the report. Have them click the Open button.
 
The Acrobat Reader software will now open with the report displayed. The provider can print the report by selecting the Print option from the File menu.
 
Using this solution the internal report viewer in Web KIDS will not work. After they close the Acrobat Reader window they will see the window saying that their report is being generated. Have them click the Close button on this window.
 
This solution is a work around for incompatibilities with Adobe Acrobat Reader and certain versions of Netscape, Internet Explorer, and America Online.

Here's the link where I found it...LOL, it's aimed at kids....Guess I'm a kid 2 LMAO.
http://www.skyhill.com/kids/faq.html
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 12

Expert Comment

by:kneH
ID: 13815265
Tell your puter it does not know .pdf files (in the file association)
Tell it it should open .pdk files (or whatever) with adobe acrobat reader.
Rename the ones on your hdd which you want to open. That way you won't get bugged when clicking one on the internet.

Sloppy workaround... but a workable one.
0
 
LVL 10

Expert Comment

by:snerkel
ID: 13819477
pdf don't open in my IE but do in Firefox (haven't found a way to stop them in Firefox).

In IE tools, Internet Options, Advanced I unticked "Enable third party browser extensions"
0
 
LVL 10

Expert Comment

by:snerkel
ID: 13819507
Just found in Firefox

Tools, Options, Downloads

Click Plugins and deselect pdf, Firefox will then download the pdf instead of opening it.
0
 
LVL 20

Accepted Solution

by:
nedvis earned 1500 total points
ID: 13819880
This is how browser understans so called MIME ( What is mime? MIME is a standard for describing different types of information This was originally meant to be used to specify encoding for different types of information into text)
You have to disable Adobe Reader's integration with your browser(s).
* For Adobe Acrobat 6.x
Close Internet Explorer.
Click START, click PROGRAMS, and open Adobe Acrobat Reader.
Click EDIT, click PREFERENCES, and then click INTERNET.
DESELECT Display PDF in Browser, and then click OK.
_________________________________________________
If that fails -as you stated before- you' probably want to install this small (312 Kb) Adobe reader tweak utility :
PDF SpeedUp:
Features:

Free PDF Tweak Utility for Adobe Acrobat v3.0 to v5.5, Adobe Reader v6.0, v6.01, v6.02
Enable or disable the plug-ins as needed
Turn off all Updates features
Disable the splash screen during program startup
Remove the My eBooks folder created in My Documents
Turn off the advertisements for Adobe products in the upper-right corner of the toolbar
Remove PrintMe and Adobe Reader icons
        Disable Browser Integration !!!!!!!!!!!!!!!!!!!!!
Disable confirmation dialog when closing Adobe Reader
Better speed for LAN and Cable connection
Clear Adobe Reader Recent Files History
Restore to original settings at any time

good luck
nedvis
0
 
LVL 20

Expert Comment

by:nedvis
ID: 13820132
 http://franksworld.com/blog/archive/2004/12/03/541.aspx
--------------------------------------------------------------------------
               Background information ( fro Reader authors ADOBE ):

       "...The Acrobat Display PDF in Browser option displays any PDF document opened from the web inside the browser window. If this option isn't selected, PDF documents open in a separate Acrobat window. A corrupt registry setting causes the error to occur each time you start Acrobat.
           When you start Acrobat, it checks your default web browser preferences for compatibility with Acrobat and this preference setting may become corrupt. A corrupt preference file causes the error to occur each time you start Acrobat. Turning off, then back on, "View PDF in browser" forces Acrobat to remove and re-create the applicable registry setting. When "View PDF in browser" is re-enabled, the corrupt registry key is written correctly."
 They diskuss the topic but NO MENTION OF RELATED WINDOWS REGISTRY KEY !!!
____________________________________________________________________________________________
SOLUTION ???? ( found in following WEBLOG) :
"As I just mentioned, there is a way to make Office documents open in their respective apps rather than IE. Since PDFs are quite common on the net I am always getting annoyed when they load in the browser..."
It seems that the following regkey controls the browser setting (...)

[HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\6.0\Originals]
"bBrowserIntegration"=dword:00000000
___________________________________________________________________________________________
Manage browser add-ons using "Add-on Configurator for Windows XP SP2"
http://support.microsoft.com/kb/883256

Adobe Acrobat Control for ActiveX add-on filename is: C:\PROGRA~1\Adobe\ACROBA~1.0\Reader\ActiveX\pdf.ocx
___________________________________________________________________________________________

Add-on Class Id : {CA8A9780-280D-11CF-A24D-444553540000}
Add-on Description : Adobe Acrobat Control for ActiveX
Add-on FileName : C:\PROGRA~1\Adobe\ACROBA~1.0\Reader\ActiveX\pdf.ocx
____________________________________________________________________________________________

 nedvis
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 13820507
Uninstall Reader 6.0 and install this version of Reader 7.0  http://ardownload.adobe.com/pub/adobe/reader/win/7x/7.0/enu/AdbeRdr70_enu.exe

You'll find that it works MUCH better than 6.0 and doesn't use nearly as many resources.

Jeff
TechSoEasy
0
 

Author Comment

by:alsheron
ID: 13822168
What can I say? All of your suggestions have been excellent. I've managed to stop PDFs in both IE and Firefox using the suggestions from nedvis and snerkel. Thank you very much for all of your help. Hopefully now, people will be able to get this info when they type into google (which is how i found the site a while back). Acrobat 7 is indeed much better.... Thanks Jeff. dvt_localboy.... thanks for your suggestions, but i'm afraid i got lost in them somewhere......

Thanks again!..... Mission accomplished!

Alsheron.
0
 
LVL 10

Expert Comment

by:snerkel
ID: 13825833
No problem, at least I got a mention in dispatches
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Mailbox Corruption is a nightmare every Exchange DBA wishes he never has. Recovering from it can be super-hectic if not entirely futile. And though techniques like the New-MailboxRepairRequest cmdlet have been designed to help with fixing minor corr…
This applies to Dell but may also apply to other manufacturers as well. We ran across a few machines that just dropped recently it trust relationship with the server. After doing the basic removing and joining the domain again, it changed to No logo…
Using Adobe Premiere Pro, the viewer will learn how to set up a sequence with proper settings, importing pictures, rendering, and exporting the finished product.
With the power of JIRA, there's an unlimited number of ways you can customize it, use it and benefit from it. With that in mind, there's bound to be things that I wasn't able to cover in this course. With this summary we'll look at some places to go…

580 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question