Cannot query from enterprise manager

Hi Folks,

I am having some bother with Enterprise manager. Our SQL Server is Windows 2000 Server running SQL Server 2000 Sp 3a. I keep getting error messages when i try to execute a query from enterprise manager on my PC.

Everything was working fine up until yesterday. I could connect and query any of the tables within each database. Now when i try to view rows from a table it displays the following error:

'The query cannot be executed because some files are either missing or not registered. Run seetup again to make sure the required files are registered.'

I looked this up on the web and eventually came across Microsoft KB 315868:

'PRB: Query Can Not Be Executed in SQL Enterprise Manager Query Designer on Windows XP'

I followed this and re-registered the stated files but now when i try to view tables i get the following:

'Unknown Error 800401F9'

I have tried unistalling and re-installing but with no joy. I can query tables no problem from the Query Analyzer.

I am using a Windows XP SP1 to connect to the SQL Server with the latest MDAC version.

I don't understand why this would suddenly begin to happen when everything was working fine before.

Any ideas??
BaikieAsked:
Who is Participating?
 
Kevin3NFConnect With a Mentor Commented:
Can you re-apply MDAC 2.8?

Also, check the version of this dll on your drive:
C:\Program files\Common Files\System\Ole Db\Oledb32.dll

0
 
Kevin3NFCommented:
Have you applied SP3 to your client machine?
0
 
BaikieAuthor Commented:
Yeah, sorry forgot to mention that.
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
BaikieAuthor Commented:
Hi,

Cheers for the response.

Ok, i re-applied MDAC 2.8. (still no joy)

I checked out the oledb32.dll file:

File version - 2.80.1022.0 ((Webdata).030220-1508)

Anything else i need to check with this file? This is one of the files that Microsoft asks to register from the KB article.
0
 
Kevin3NFCommented:
No...I've seen weird circumstances where that file was 2.7.xxxx even on a 2.8 box.

Have a look at this hotfix/security patch for MDAC 2.8:
http://www.microsoft.com/technet/security/Bulletin/MS04-003.mspx
0
 
BaikieAuthor Commented:
I have installed the security patch but to no avail.

It is such a pain as i have to go onto the actual server in the server room to work with the enterprise manager.

Not sure what to do next as an uninstall/reinstall plus all the latest patches and upgrades did not help. There must still be something sitting on my computer that is causing this problem.

0
 
Kevin3NFCommented:
My best gugess at this point is that a Windows Update has messed something up.  Were any of those applied around the time it quit working?
0
 
Jim P.Connect With a Mentor Commented:
I have the same problem -- I started having problems once my boss fired SUS onto the network. I just use the query analyzer for the queries now.

Can you install Terminal Services for Remote Administratio on the SQL Server?  That way you can use Remote Desktop Connection.
Start -> Programs -> Accessories -> Communications -> Remote Desktop Connection

It's almost like being there.  And I even share out my local C: and CD drive and then connect to the share to get things onto the server.

Just a thought. :)
0
 
Kevin3NFCommented:
Yes, I would assume you can.  Or look at the SQL WebData Administrator

http://www.microsoft.com/downloads/details.aspx?FamilyID=C039A798-C57A-419E-ACBC-2A332CB7F959&displaylang=en
0
 
BaikieAuthor Commented:
Hi folks,

Out of desperation i re-tried the Microsoft solution (KB 315868) and re-registered the stated files, and to my suprise everything has started working again. I don't know why this would be as i had already tried this. Anyway, everything back to normal.

Kevin3NF: I had never heard of the SQL WebData Administrator tool before. Sounds interesting

jimpen: As for the Terminal Services solution that would work as i use this already on my other servers and would have been a work-a-round (although not fixing the problem).

Thanks for the responses guys, good to know there are folk willing to help!

Baikie

Although no real solution was reached, i will split the points as follows:

90 points for Kevin3NF as you responded to the question and stuck with it.

10 points for jimpen for responding

Cheers Folks!
0
 
BaikieAuthor Commented:
Just realised the minimum split is 20 points!

80 to Kevin3NF

20 to jimpen
0
 
Jim P.Commented:
Thank you. Just wanted to give my viewpoint on it.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.