• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1208
  • Last Modified:

"Another version of Notes" error message

We are a mixed shop, with most people being on some variant of R5 (5.0.8, 5.0.10, 5.0.12) and a few being on some variant of 6 (I don't know precisely which releases).

A coworker on 5.0.8 just tried to open a doc in a database that she uses all the time and got a pop-up with the following message:
Warning: Ignoring portion of document that uses a feature from another version of Notes.

Then the document doesn't open.

I'm also on 5.0.8, and getting the same message.

This database has had some work done on it over the years, but it began its life in 4.6 or earlier. However it has been stable since we moved to R5 in 2000. So I don't think the problem comes from a 4.6/R5 compatibility issue.

At the same time, I've never had R6 running, so I have no idea at all what kinds of things the document's creator might have done to the document that would cause that error.

The form in question has some QueryOpen code that takes contents from a rich-text field and moves it to an archive field, if there is any text. (This prevents users from changing comments made by previous users.) It's handled pre-open to avoid problems with rendering rich-text fields.

The code in question is:
Dim item as NotesItem   ' Note that this is NOT a rich-text item
Set item = doc.GetFirstItem("Comments")
If item.Text = "" Then Exit Sub
' code continues

When I look at the variables in the debugger, I can see item and I can see that item.Text is blank. But the error happens when it gets to that conditional.

Any idea what's going on here? What may have been done to this field by the other user (who is on an R6 flavor of Notes) that would cause these problems?

Thanks!

-- b.r.t.
0
BarryTice
Asked:
BarryTice
1 Solution
 
HemanthaKumarCommented:
Check this .. and find the case that applies to your situation http://www-1.ibm.com/support/docview.wss?rs=899&uid=swg21097112

~Hemanth
0
 
Sjef BosmanGroupware ConsultantCommented:
Interesting document! Reason #3 might apply?

Else, what is the type number of the Comments field?
0
 
BarryTiceAuthor Commented:
Actually, it appears No. 1 is the problem. I'm told someone pasted a screenshot into the field. Though, on further reading it could be some mixture between 1 and 2.

In any case, it seems HemanthaKumar has come up with the answer to my question.

Thanks, as always, Hemanth!

-- b.r.t.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now