[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Cannot remote admin Arcserve 2000

Posted on 2005-04-19
19
Medium Priority
?
1,447 Views
Last Modified: 2008-01-09
Windows 2000 Advanced Server - clustered - has Arcserve 2000 SP 4 installed.

On my Windows XP I have Arcserver 2000 manager installed with SP4.  I cannot connect to the server to remotely manage it.  I can connect to it with Server Admin.

I checked the permissions on the Arcserve$ share and they are ok.  What am I missing?

The error I get when I try to connect is:
Server XXX failed to authenticate the user admimistrator (EC=14)
and
Server XXX failed to authenticate the user admimistrator (EC=1722)


I've tried the administrator account and my user account.  I've also tried mapping the drive manually first but it didn't work.
0
Comment
Question by:robrandon
  • 10
  • 9
19 Comments
 
LVL 22

Accepted Solution

by:
dovidmichel earned 1500 total points
ID: 13820122
Well I'm figuring the two errors are from the OS.
so 14 = not enough storage is available to complete this operation
1722 = the RPC server is unavailable

The second got me thinking. This is XP and past the date when MS is forcing SP2 to all clients, so perhaps it is a XP SP2 issue.

Here is a doc on the CA site. It was written for ARCserve 11.1 so some things might be different but it might be a the root cause of this failure. Another possiblity is that you are running into the bick wall of ARCserve 2000's life cycle, or in other words the last version of Windows it correctly works with is Windows 2000.

Document ID:  TEC341621  
 Technical Document  
 
Title:  ARCserve/Enterprise Backup Host Server Configuration with Windows XP SP2
 
If you are running a BrightStor ARCserve/Enterprise Backup Host server installation on a Windows XP system and upgrade to Windows XP Service Pack 2, then the host server installation may not work in the same way after the service pack is applied.

The upgrade to Windows XP Service Pack 2 enables the firewall and blocks all ports by default. You must perform one of the following procedures to use BrightStor ARCserve/Enterprise Backup with Windows XP Service Pack 2.

Method 1 (recommended)

In the Start menu, click Run, enter gpedit.msc, and press Enter.
The Group Policy configuration GUI will appear.

In the Group Policy Configuration GUI, select Local Computer Policy, Computer Configuration, Windows Setting, Security Setting, Local Policy, Security Option.

Change the setting Network access:Sharing and security model for local accounts to :

Classic - local users authenticate as themselves.



By default, the key RPC and the value RestrictRemoteClients must be created manually. Set the following registry value to 0:

[DWORD] HKEY_LOCAL_MACHINE\Software\Polices\Microsoft\Windows
NT\RPC\RestrictRemoteClients


Access the Security Center and enable the firewall.
Add the following executables (if applicable) to the Security Center exception list (these can be found in the BrightStor ARCserve/Enterprise home directory):

caauthd.exe
cadiscovd.exe
caloggerd.exe
casdscsvc.exe
caserved.exe
casmrtbk.exe
catirpc.exe
dbeng.exe
jobeng.exe
ldbserver.exe
lqserver.exe
mediasvr.exe
msgeng.exe
tapeeng.exe
univagent.exe
Restart the Windows XP Service Pack 2 machine and start BrightStor ARCserve Backup services.

Method 2

In the Start menu, click Run, enter gpedit.msc, and press Enter.
The Group Policy configuration GUI appears. In the Group Policy Configuration GUI, select Local Computer Policy, Computer Configuration, Windows Setting, Security Setting, Local Policy, Security Option.

Change the setting Network access:Sharing and security model for local accounts to

Classic - local users authenticate as themselves.



By default, the key RPC and the value RestrictRemoteClients must be created manually. Set the following registry value to 0:
HKEY_LOCAL_MACHINE\Software\Polices\Microsoft\Windows NT\RPC\ RestrictRemoteClients

Access the Security Center and turn the firewall off.
Restart the Windows XP Service Pack 2 machine and start the BrightStor ARCserve Backup services.
 
 
 
0
 
LVL 16

Author Comment

by:robrandon
ID: 13823625
SP2 has been installed since MS released it.

I can connect to our other Arcserve server which is installed on a Windows 2000 Server Standard.  Same Arcserve SP.  An obvious difference is that one is on a cluster.  I think this is a server side issue - something with the configuration there.  Any other ideas?
0
 
LVL 22

Expert Comment

by:dovidmichel
ID: 13824199
Can the other non-cluster ARCserve server remotely manage the clustered one?
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 16

Author Comment

by:robrandon
ID: 13834458
Nope.  
0
 
LVL 22

Expert Comment

by:dovidmichel
ID: 13837557
So what ever it is, it is only a problem with that system.

Reset the ARCserve System Account over there. It is done from within the ARCserve Server Account. Also make sure the Job Engine service is configured to logon as System.
0
 
LVL 16

Author Comment

by:robrandon
ID: 13837666
Can you explain "Reset the ARCserve System Account over there. It is done from within the ARCserve Server Account." please?  Thanks.  Already setup to logon as System.
0
 
LVL 16

Author Comment

by:robrandon
ID: 13837691
btw, I think the error 14 had to do with something else.  Just need to focus on the 1722.
0
 
LVL 22

Expert Comment

by:dovidmichel
ID: 13839077
1722 = the RPC server is unavailable

ARCserve components communicate via RPC, so it looks like something at the target end is blocking RPC.

http://support.microsoft.com/default.aspx?scid=kb;en-us;Q167260

XCLN: How to Use RPCPing to Test RPC Communication
0
 
LVL 22

Expert Comment

by:dovidmichel
ID: 13878681
Sorry I missed you request.

To reset the ARCserve System Account.
Open the ARCserve Server Admin
From the menu bar select Admin, ARCserve Backup System Account.
Then re-enter the name and password.
0
 
LVL 16

Author Comment

by:robrandon
ID: 13888571
Hmmm, still not working.  It was set to our domain admin account.  I re-entered the password and attempted to connect but it failed.  I tried restaring the services and that didn't help.  I then tried the same with the local servers administrator account, but got the same results.

Any other ideas?
0
 
LVL 22

Expert Comment

by:dovidmichel
ID: 13888970
Was RPC connectivity verified?

Server XXX failed to authenticate the user admimistrator (EC=1722)
The error code is from the OS,  1722 = the RPC server is unavailable
The different parts of ARCserve communicate via RPC so this might be at the root of the problem.
0
 
LVL 16

Author Comment

by:robrandon
ID: 13889684
I should have followed your link earlier about the RPC test but I didn't.  I have now.  On the server I ran:
RPINGS -p TCP/IP

On my workstation I ran:
rpingdos -p tcpip -n 10.0.0.49 -c 4

It returned this back:
Binding failed with return code 0x6,
        The Protocol sequence is not supported
RPC Binding returned (0x21)
The RPC Call failed
Could not bind using these parameters:
    protocol sequence = ncacn_ip_tcp
    network address   = 10.0.0.49
    endpoint          = 2256
    UUID              = fe993211-13ec-101b-9932-00805f500621

Did I use the utility wrong?  What now?
0
 
LVL 22

Expert Comment

by:dovidmichel
ID: 13889936
Looks like the usage is correct.
Try testing it by using the network address of the other ARCserve server that you can manage remotely.

Is there any filtering being done at a firewall or switch for RPC?
If there is another system in the same network segment see if the utility will work or give the same failure with that.
0
 
LVL 16

Author Comment

by:robrandon
ID: 13893824
I tried this on a server I can manage and I got the same results.  I don't think this is a valid test.  I also tried with Named Pipes but got the similar results.

I know that the cluster services uses RPC to communicate.  It is configured to do it over a private network. Can that be the problem?

0
 
LVL 22

Expert Comment

by:dovidmichel
ID: 13894284
Private network probably does mean that RPC is not going through.

Speak with your network guys about the problem. Perhaps they can open it up for this or maybe they already have some kind of remote control program setup. Something like terminal services or remote desktop that will let you remotely manage the system instead of using a remove ARCserve Manager.

Because it is on a private network that probably means it is a high security system and so what ever method you use should not comprimise that security. So bring up the problem with the Network Admin  to first confirm that the private network would be preventing this comunication, and then what he suggests to work around the problem.
0
 
LVL 16

Author Comment

by:robrandon
ID: 13894527
I probably wasn't clear enough when I said private network.  The server is setup as a node in a 2 node cluster.  Each node has 2 network cards.  One is for the regular network traffic.  The secondary cards simply plug one server right into the other.  The internal Cluster communications use that network card specifically.  The cluster communication uses RPC.

I was just brainstorming out loud, more or less.  Is it possible that the RPC traffic isn't reaching the public network at all?  Or does regular file server activity included RPC traffic, so we know that it is passing that on the public network.

Incidentally, I have an Arcserve r11.1 installed on a separate cluster that I can remote admin fine.

0
 
LVL 22

Expert Comment

by:dovidmichel
ID: 13895467
By default RPC communication is open.

When it fails is it asking for security info?

If so have you tried using an admin user that is local to the cluster system?
0
 
LVL 16

Author Comment

by:robrandon
ID: 13896414
I've tried the local administrator account as well as the domain administrator account.  I also tried setting up the arcserve account through arcserve manager as both of them and then trying again.  It always comes back with the
Server XXX failed to authenticate the user admimistrator (EC=1722)
error.


0
 
LVL 22

Expert Comment

by:dovidmichel
ID: 13897676
I could be wrong about the RPC but all I can think of at this point is to verify RPC connectivity.

If that utility does not work for you perhaps one of the others will.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article we will learn how to backup a VMware farm using Nakivo Backup & Replication. In this tutorial we will install the software on a Windows 2012 R2 Server.
How much do you know about the future of data centers? If you're like 50% of organizations, then it's probably not enough. Read on to get up to speed on this emerging field.
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…
Suggested Courses

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question