Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 663
  • Last Modified:

CFMX 7: lc_id is undefined

I just upgraded to CFMX 7 and I am getting a javascript looking error that states lc_id is undefined.  I update the CFIDE directories that are part of the site, but I am still getting the error.  Let me know if anyone has any ideas.
0
jeffmace
Asked:
jeffmace
  • 4
  • 3
2 Solutions
 
mmc98dl1Commented:
make sure you have a virtual directory pointing to the cfide directory that CF installs in the web root.  Dont copy and paste the dir to your own site.

0
 
mmc98dl1Commented:
I also found putting a virtual directory called jrunscripts to c:\jrun4\lib\wsconfig\1\ can solve problems relating to the flash version of cfform
0
 
jeffmaceAuthor Commented:
I took a look and both of these suggestions are done, but I still get the error about lc_id.  Also I am trying a very simpl CFGRID in flash and the form shows up and the headers are fine, but no data fills out the grid.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
jeffmaceAuthor Commented:
Here is a link to the test page for anyone to see whats going on

http://www.jhasim.com/cf7_grid.cfm

0
 
mmc98dl1Commented:
well something isnt right, http://www.jhasim.com/CFIDE/scripts/cfform.js comes up with a 404 not found, you are missing the js files.
0
 
jeffmaceAuthor Commented:
its there, take a look

http://jhasim.com/scripts.jpg
0
 
cyberdevil67Commented:
document.write("  <param name='flashVars' value='historyUrl=%2FCFIDE%2Fscripts%2Fcfformhistory%2Ecfm%3F&lconid=" + lc_id +"&%5F%5FCFForm%5F1%5Fcacheid=62511196%2DF1F9%2DD365%2D888E52F3E94CF8B1&%5F%5Fvisitors%5Fcacheid=62511186%2DF1F9%2DD365%2D81AFFA6D01AFF9C2'/>");
document.write("</object>");

Is where the error message is being generated, this means that the files for /cfide/ are not being inlcuded. This can mean that there is no mapping setup in the administrator for cfide
0
 
jeffmaceAuthor Commented:
Reinstalling CFMX7 Fixed the problem, but all of your clues/ideas confirmed that it needed to be done.   Everything was mapped and files were present, but after reinstalling and not touching anything else helped fix the problems.  Thank you for your time.
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now