[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 266
  • Last Modified:

Some computers don't like 100/Full

We just upgraded our cisco 5500 switch to a cisco 4006 switch. Our bandwidth is increasing from 10 to 100 as well. With the 5500 we hardcoded all speeds and duplexes. With the 4006 we are setting everything to auto. We have about 100 IBM computers connected to the switch running WinNT. We are setting the clients to 100/full and the switch side to auto. All but 10 computers liked the speed change. With the remaining 10 we had to hard code the switch side to 100/full. Does anyone know why i have 10 that needed to be hard coded but the rest took auto fine? Thanks
0
djsuperz
Asked:
djsuperz
  • 4
  • 3
  • 2
  • +1
1 Solution
 
purplepomegraniteCommented:
When using Auto, both the client and the switch must be set to Auto.

If you set the switch to Auto, but the client to 100/full, this will cause problems.  Auto actually negotiates the connection by sending pulses down the line - if the switch doesn't sense this negotiation it will default to 10/half - which will obviously cause problems.
0
 
djsuperzAuthor Commented:
When we set both switch and client to auto it usually negotiates at 100/half. Why is that?
0
 
sr1xxonCommented:
with our Cisco switches we found that hardcoding 100/full on all ports prevented these types of problems.
it's a pain in the neck, but at least it only needs to be done once.

autonegotiation was just too problematic overall and of no benefit on switches..

at least with the switch, you won't have the contention issues which invariably occur with hubs.

If you were using hubs (eg in a DMZ), I would recommend using the AUTO setting.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
sr1xxonCommented:
oh..
in relation to hubs - auto both on the hub and the NIC

for switches, hardcoded 100/full on the switch - auto will work on the client (with a good quality NIC), however I prefer setting the NIC to 100/full also.

just to be sure.


If you are using 3c920 NICs, we found that this type of problem was avoided by setting the following

Flow Control=Enable
Media Type=100FullDuplex
LinkChk=Enable
0
 
sr1xxonCommented:
in relation to your second comment,

from the Citrix docco..
--clip--
Beginning with Cisco IOS Release 12.1, you can configure the duplex setting when the speed is set to auto.

If both the speed and duplex are set to specific values, autonegotiation is disabled.

For Fast Ethernet ports, setting the port to auto has the same effect as specifying half if the attached device does not autonegotiate the duplex parameter.
--end clip--

this would indicate that your NIC's aren't sending a full duplex param to the switch..
therefore, use 100/full!
0
 
purplepomegraniteCommented:
Auto will not work if only enabled on one end.  Here is supporting documenation: http://www.cisco.com/en/US/products/hw/switches/ps700/products_tech_note09186a00800a7af0.shtml

To get straight to the interesting bit of the article: http://www.cisco.com/en/US/products/hw/switches/ps700/products_tech_note09186a00800a7af0.shtml#why_do_auto

0
 
purplepomegraniteCommented:
The advice to hardcode both switch and NIC to 100/full is spot on - annoying, but as said, only needs to be done once.
0
 
tonyteriCommented:
set them to auto
0
 
djsuperzAuthor Commented:
I tested the pc 100/full, switch auto theory again against another 100 devices. 40 Devices ended up comming up 100/half leading to a duplex mismatch and slow speeds. We also tested the auto auto settings and everything worked great. Our destop techs brought up that incase of a renegotiation, speed and duplex the pc must be set at 100/full or they might connect at undesireable speed or duplex. How often do pc network cards renegotiate?
0
 
purplepomegraniteCommented:
The link is negotiated when the conneciton is made... once negotiated, it should remain as is until it is disconnected and reconnected.  As far as I'm aware, there isn't a renegotiation interval - it doesn't happen except on connection.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 4
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now