• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 711
  • Last Modified:

ORA-12535 time out

I'm keep on getting ORA-12535 when I try to connect to a database.
And what I do not understand is, it works on another machine.

I tried "tnsping" and the same thing happens.
I get a response time for one machine but not for the other.
Both computers use WinXP and TOAD.

What's wrong with one of the machines?
0
nagunpyo
Asked:
nagunpyo
  • 7
  • 6
1 Solution
 
nagunpyoAuthor Commented:
BTW, the machine that returns a ping was set up by another staff some time ago.
So, I guess he has done something on that machine but too bad that he has retired and I can't contact him. :-(
0
 
paquicubaCommented:
Sounds like a firewall issue. If tnsping doesn't work, ask your network administrator to open the firewall on port 1521
0
 
nagunpyoAuthor Commented:
how to open the firewall?
cuz, there's no tech staff left to take care of it
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
paquicubaCommented:
Is Windows' firewall enabled in your PC or you're using another vendor's firewall?
0
 
nagunpyoAuthor Commented:
how to check that?
0
 
nagunpyoAuthor Commented:
BTW, I can connect to other databases using port 1521.
Would it eliminate the possibility of the firewall blocking the port 1521?
0
 
jrb1Commented:
You should have a SQLNET.LOG file with more error details. Is more info available there?

Also, in your SQLNET.ORA file, what is sqlnet.expire_time set to?  It may be as simple as setting this to a value like 10.

If you don't get enough info in SQLNET.LOG, you can set these values to get BIG trace files:

TRACE_LEVEL_CLIENT=16
TRACE_DIRECTORY_CLIENT= <Directory where trace is written>
0
 
paquicubaCommented:
Go to your registry and under [HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE]
look for the following key: USE_SHARED_SOCKET=TRUE
If the above key doesn't exists then create it.
0
 
paquicubaCommented:
If you have more than one Oracle HOME, then use HOME0 which is by default the home of the server.
0
 
nagunpyoAuthor Commented:
I've set the TRACE_LEVEL_CLIENT to 16 but I must be doing something wrong with TRACE_DIRECTORY_CLIENT becauze I don't see any trace file being created.
I have my oracle isntalled at
C:\oracle\ora92
And I want the trace file to be created at
C:\oracle\ora92\network\trace
So, I tried
$ORACLE_HOME/ora92/network/trace
$ORACLE_HOME/network/trace
/oracle/ora92/network/trace
And then, just / to see if I could create the trace at root but still no luck.
BTW, when does the trace file gets created?
I've done tnsping and tried to connect to the DB using TOAD after everytime I change the setting.
0
 
nagunpyoAuthor Commented:
I have the writting permission to all the directory and changing the sqlnet.expire_time value didn't solve the problem.
And I also tried adding USE_SHARED_SOCKET=TRUE, but still not working...
0
 
paquicubaCommented:
Have you tried to connect using SQL*Plus?
0
 
nagunpyoAuthor Commented:
I've fixed the problem...
OK, the problem is fixed... it turned out that my IP was not on the DB server's allowed list
0
 
paquicubaCommented:
Good for you!!
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

  • 7
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now