Network login box popping up when accessing a server website - shouldn't happen.

Hi,

     This may be the wrong forum, but here's my problem.  I'm beginning work on a VB.NET web app.  The app is stored on the server.  Usually we use the inetpubs/wwwroot from c drive, but now my boss wants me to use the E drive to store web sites.  The problem is, when I set up the directory and use IIS to set the website and virtual directory, whenever I put the URL into my browser, it requires a network login before proceeding to the webpage.  I've given security permissions to Guest and to Internet Guest Account (IUSR) but still the same thing.  Does anyone know what I need to do to make this server-located virtual directory open up a webpage from a browser without requesting network login?

JP
gleznovAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JammyPakCommented:
you don't need to give access to guest, but you do need to give access to whoever the anonymous user for your site is set to be (probably IUSR, but you should check). Did you check the authentication settings on the virtual site? Make sure it's set to use Anonymous only...check this for the site and directory also in IIS...

sorry, these are basic things, but it's a start
0
gleznovAuthor Commented:
Sorry it's taken me so long to get back.  

I have:

Enable anonymous access - checked
User Name: IUSR_servername
password: ******* <---- nobody here knows what this is for some reason, but are scared to reset it in case something's using it on the server

Integrated Windows Authentication - checked
all else - unchecked

What do I need to do to this?  Also, IUSR is not listed under permissions for this site, or any I've programmed.  But the ones under inetpub\wwwroot don't try to authenticate with network login, but ones placed elsewhere on the server do.  (My boss said not to keep putting them in there - isn't this where all websites should go?)

JP
0
JammyPakCommented:
well, yes, wwwroot is there to be the 'root' of the default website. Inetpub is intended to be the location of websites on the server. I don't know exactly why he wants to move them, but it should work either way.

- I would uncheck the Integrated Windows Authentication for this website. you don't want that, you only want anonymous
- I would also grant the IUSR account read access to the new webroot, and all the files in there
- I would also check the box to allow IIS to manage the password of the IUSR account - otherwise it could get out of sync. If you're concerned about that, try enabling account auditing and see if the IUSR account is getting failed login attempts - or you could just create a new user account and use that as the anonymous account for this one website (as a test, anyway...)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
OS Security

From novice to tech pro — start learning today.