FTP: Control connection closed - firewall sp2 problem

This should be very simple, but its not...

This just started happening today, no idea why because nothing has been changed.  Trying to connect to any ftp site using CuteFTP 6, I get
Socket connected. Waiting for welcome message...
ERROR: Control connection closed

I connected to fine yesterday.  When I turn off Windows Firewall, everything works fine.  Turn it back on, can't connect anywhere.  I opened ports 21 and 20, File and Printer sharing is also on and now I'm all out of ideas...
grzegorczykAsked:
Who is Participating?
 
tmyoungbloodCommented:
your problem lies in that you use windows firewall. i have NEVER had it work properly on any of the computers that i service.  for this reason every single xp computer gets ZoneAlarm basic which is free.  ( www.zonelabs.com ) .  i wouls sugest using that over windows firewall any day.  and as for the pasv mode problem, normally firewalls block incoming connections not outgoing, and being that pasv doesnt have an incoming connection to you, this shouldnt be a problem.  i would highly recommend zonealarm.
0
 
JBlondCommented:
Perhaps this help:

http://support.microsoft.com/?scid=kb%3Ben-us%3B842242&x=9&y=4

Another possible solution: Add CuteFTP to the Exception-List. (This is described in the article behind the link, too)
0
 
grzegorczykAuthor Commented:
I've added cute ftp into exception-list, still no go...
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
mjhatcherCommented:
Are you using passive mode FTP?

Check in Settings > Connection > Firewall for "PASV mode". Is that switched on?

Your firewall could be complaining because in active mode the FTP server has to be able to make connections to your client. With passive mode the client makes the connection to the server. If you don't have PASV turned on, then try it. If it is turned on, try turning it off. FTP can be a troublesome protocol with some firewalls.

By the way, you don't need file and printer sharing on for FTP. Best to block it at your firewall unless your PC is on a LAN.
0
 
KenneniahCommented:
Haven't used CuteFTP in awhile, but does it have an setting in options for using passive FTP? If it does try changing it and see if it then works.
0
 
KenneniahCommented:
Oops, sat at the post screen too long, so please ignore my duplicate :)
0
 
mjhatcherCommented:
No worries. Glad we're thinking along the same lines....! ;-)
0
 
grzegorczykAuthor Commented:
Not sure where "settings > connection Firewall for PASV mode" supposed to be ??? In windows or CuteFTP?  I set Cute FTP to pasv mode (it was on auto-detect) and nothing.  In internet options I clicked PASV mode off for firewall and dsl... nothing, clicked it back on... still can't connect...

I have no idea. Everything was working yesterday fine....
0
 
JohnnyITCommented:
I know this question is an old closed question, but for future viewers, I strongly disagree with tmyoungblood's comment.  I find zonealarm a resource hog, and over 12 years of IT consulting have never had any issues with Windows Firewall.  

The problem is occuring for some other reason that should be explored.  Simply stopping to use windows firewall is not a solution.  

In a previous case I experienced with this exact issue, the user had acquired a virus from pirated software about the same time the "Control Connection Closed" issue began.  I can't remember what the solution was, but it was definitely virus related.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.