[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 678
  • Last Modified:

Cisco 800 router config fails to dial?

this is my router config. i was hoping for the router to dial when the ipaddress 23.45.29.10 is required (pinged) but at present the router only dials when a spurious command is entered at the console. (only came across this be accident) and the router tries to resolve to a dns server?

I have a system on the same subnet 192.168.0.4 and the router ip is my gateway 192.168.0.2. do I need a DNS server even though I was only wishing to contact by ipaddress. My client is a  stand aloneXP system?

????????????



Using 1311 out of 8062 bytes
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router
!
enable password password123
!
username jpacker password 0 passrrrd
!
!
!
!
ip subnet-zero
!
isdn switch-type basic-net3
!
!
!
interface Ethernet0
 ip address 192.168.0.2 255.255.255.0
 no ip directed-broadcast
 ip nat inside
 no cdp enable
!
interface BRI0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-net3
 ppp authentication chap callin
!
interface Dialer0
 ip address negotiated
 no ip directed-broadcast
 ip nat outside
 encapsulation ppp
 dialer remote-name 23.45.29.10
 dialer idle-timeout 300
 dialer string 0208xxxxxxx
 dialer hold-queue 10
 dialer load-threshold 10 either
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname JPACKER
 ppp chap password 7 095F4B1B4E5D44471E04
!
ip nat inside source list 2 interface Dialer0 overload
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
access-list 2 permit 192.168.0.2 0.0.0.25
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
line con 0
 transport input none
 stopbits 1
line vty 0 4
 password PASSWORD2
 login
!
end
0
rbauckham
Asked:
rbauckham
1 Solution
 
magicommincCommented:
"no ip domain lookup" will stop your router from doing that DNS name reslove for any spurious command.
I don't believe you need a DNS server if you intend to contact by IP. Your stand alone XP may need a DNS server to browse web, but not necessary for you router.
0
 
piersonmCommented:
> access-list 2 permit 192.168.0.2 0.0.0.25

I would modify this access list to the following:
     access-list 2 permit 192.168.0.0 0.0.0.255 (this will now include your standalone XP workstation and router)

I also agree with the no ip domain-lookup statement
0
 
rbauckhamAuthor Commented:
Thanks
I have added that line but could you tell me how to remove the existing line?

0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
rbauckhamAuthor Commented:
Also
should the "no ip domain lookup" go under an interface section? if so which one.

thnaks again
0
 
piersonmCommented:
> no access-list 2
> access-list 2 permit 192.168.0.0 0.0.0.255

MP
0
 
piersonmCommented:
The "no ip domain-lookup" command is a global command not interface specific

MP
0
 
j3ggsCommented:
Hi rbauckham,

Are you pinging from the router or your PC? I have had issues where you need to initiate the ping from the PC to get the router to actually do anything. This is normally due to other configuration parts on the router (for instance you may need to ping from a source address from one of your interfaces for it to pass an acl or something).

Also, it might be an idea to do a "debug dialer" and a "debug isdn q931" which may show up some issues?

One last thing, and I dont think this is an issue as you say the router dials out to do DNS lookups, is your dialer remote-name.... I am not sure if it is a problem that it contains dots (i.e. ".") not sure on that one.

Anyhow, if you put the debugs on, try a ping and then paste the output it might be help.

PS Check your nat is working by doing a "show ip nat translation"

regards

j3ggs
0
 
rbauckhamAuthor Commented:
Thanks for everyones help all sorted and dialing at will
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now