• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 988
  • Last Modified:

Remote desktop connection hell!

Please someone help me with this issue. I have been connecting to a computer on my network using remote desktop connection in XP Professional but am now receiving this error "Error- The client could not connect. You are already connected to the console of this computer. A new console session cannot be established." I have tried shutting down the computers and even removing access to myself and then allowing access again but to no avail. Please help. Thank you.

Michael
0
MichaelBurks
Asked:
MichaelBurks
  • 16
  • 12
  • 3
  • +3
1 Solution
 
ViRoyCommented:

sounds like windows thinks theres still a port open with an active connection.
heres an interesting document well written to deal with multiple problems like yours.

http://www.geek.com/news/geeknews/2003Aug/fea20030828021469.htm
0
 
purplepomegraniteCommented:
Windows XP only supports one session (Windows Server in admin mode supports 2).

It sounds like what has happened is that you got disconnected for some reason in the session, but the session hasn't been properly closed on the client computer.  The only way to reset this (unless you have set a timeout on sessions using group policy, or the local policy on that machine) is to physically go to the machine and log in at the console.  This will clear the session and allow remote again.
0
 
MichaelBurksAuthor Commented:
I did log into the console manualy but the issue remains.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
MichaelBurksAuthor Commented:
ViRoy, the link did not contain any helpful info for this issue.
0
 
Tim HolmanCommented:
Does 'netstat -an' and 'net use' say you have any other connection to that same machine ?  
It may be as simple as you having an open drive mapping on the remote machine.
0
 
MichaelBurksAuthor Commented:
How do I check net-stat and net use?
0
 
MichaelBurksAuthor Commented:
netstat-an has shown that there are current sessions open to the machine but I do not know what to do next
0
 
MichaelBurksAuthor Commented:
tim holman, please tell me what to do
0
 
purplepomegraniteCommented:
Have you restarted the machine from which you are trying to connect?
0
 
MichaelBurksAuthor Commented:
Yes, restarted both machines.
0
 
purplepomegraniteCommented:
Ok, on the computer that you want to remote control, log in, open a command prompt and type:

qwinsta

This will return the session details for all current sessions. e.g.

C:\Documents and Settings\User>qwinsta
 SESSIONNAME       USERNAME                 ID  STATE   TYPE        DEVICE
>console          User             0  Active  wdcon
 rdp-tcp                                 65536  Listen  rdpwd

You should see the above - the console is what you are logged in with, the the other is the listener for remote sessions.

Please paste your results here.
0
 
purplepomegraniteCommented:
In fact, while you are there the next step is:

There is likely to be another session other than console - we need to reset this.  This is done by:

rwinsta RESET SESSION 65536

(this is assuming the session id is 65536, as it is in my screen print above - replace this with whatever is the session id on your machine)
0
 
MichaelBurksAuthor Commented:
I have used rwinsta to reset the session and restrted both machines but nothing has changed. Can or should I just close the seesion?
0
 
purplepomegraniteCommented:
Well, the console session will always be there when you are logged in.  If the other session was listed as above in my post, then it is just a listening session so you should be able to remote in.  If the listening session isn't listed then RDC isn't in fact available.

I'll continue thinking and post back later if I come up with anything else...
0
 
purplepomegraniteCommented:
Have you tried disabling RDP on the client (via System Properties... Remote), restarting the machine, then re-enabling them?

Is remote desktop controlled by group policy at all on your set-up?
0
 
MichaelBurksAuthor Commented:
Do not think it is group policy. Have not tried disabling RDP and would like to try it if it is not too complicated. Please advise. I am a beginner.
0
 
purplepomegraniteCommented:
At the computer you are trying to connect to:

- Open Control Panel
- Double-click System
- Click the Remote tab
- Untick "Allow users to connect remotely to this computer"
- Ok (Apply)

If you restart (not entirely necessary, but best to make sure), then once restarted go back into System Properties and tick the box again.
0
 
MichaelBurksAuthor Commented:
Yep, tried this before with no success purplepomegranite.
0
 
MichaelBurksAuthor Commented:
So that's it? Noone is able to help me end the session? Help.
0
 
purplepomegraniteCommented:
It must be said, you have me stumped... I don't think it's a session issue.

The only reference to this problem I can find is when using RDP over SSH... the fix for this is:

- create a directory, c:\rdp on your machine and copy these files to that directory.
mstsc.exe and mstscax.dll (both located in c:\windows\system32)
- from windows explorer, navigate to c:\rdp
- right-click on mstsc.exe and choose properties
- Select compatibility
- click Run this program in compatibility mode for Windows 98/Windows ME
- apply and then ok
- go to c:\rdp and run the mstsc.exe program

I really don't think it will work... but hey, it's worth a shot!  The above needs to be done on the machine from which you are connecting, by the way.
0
 
MichaelBurksAuthor Commented:
Thank you. I will try this later today. Please tell me that in following these directions, I will not be doing premanent harm to my system.
0
 
purplepomegraniteCommented:
Just to outline what the above does...

You are copying the RDP client to a seperate folder (so as not to mess with the standard client), you are then asking Windows to treat this program as if it were running on a Windows 98 computer.  You are then running the modified client from the new location.  If it works (which really is a long shot!), you know you simply need to run the modified client when connecting to the problem machine.  If it doesn't, you just need to delete c:\rdp and it will be as if nothing ever changed.

So in short, no permanent harm - in fact no harm at all!

The reason for the above and why it works for SSH is that the terminal services in Windows XP does not allow connections from the localhost (127.0.0.1) and displays the error that you have reported.  Windows 98 does not have this limitation (for some bizarre reason), so if the client thinks it is running on Windows 98 it will not halt with that error in the same situation.
0
 
Tim HolmanCommented:
After resetting connections, 'netstat -an' from a command prompt, on the server AND client, should NOT show any connections to the TS server.
0
 
Tim HolmanCommented:
+just an idea, but is the installation correctly licensed ?
0
 
purplepomegraniteCommented:
The netstat won't show a connection, but will show a listening port.

Just to clarify... I have assumed that you are trying to connect to a Windows XP machine remotely, not a terminal server?  Please confirm this!!
0
 
MichaelBurksAuthor Commented:
Yes XP is the machine I am conne3cting to. It is leagle and is working fine with all of the other machines. I will be attempting to follow these instructions today as I was tied up on Fri. Thanks.
0
 
MichaelBurksAuthor Commented:
I have done as instructed using the mstsc.exe. When using this exe, I receive the same message that the remote user in the off site office receives at this time which is that there is already someone using the machine or that there is problems with the network and to try later.  There has got to be a way around this. I have been checking with microsoft and nothing is listed about this. My machine thinks it is connected to the damn thing and I cant get it to stop.
0
 
purplepomegraniteCommented:
Ok, I am unfortunately out of suggestions with regard to solving the problem - my next step would be to phone Microsoft.

The alternative would be to use another remote control software.  RealVNC is particularly good (and was what I used before RDP and WinXP Pro came out).  While it is a workaround and not a solution to your problem, it does mean you can do what you need to do.  RealVNC is available here: http://www.realvnc.com/

Sorry I can't be of more help, but if/when you do find the solution, please do post it back here as I would be very interested.
0
 
MichaelBurksAuthor Commented:
Thanks for the effort. I will definately post the solution for you if I find it. Thanks again.
0
 
MichaelBurksAuthor Commented:
One thing I forgot to follow up on is that when I try to reset the session using the command rwinsta I get a return of "Incvalid perameter(s)". Maybe the command is incorrect? Please advise.
0
 
purplepomegraniteCommented:
You'd have got that error if the state of the session was "Listen".  This isn't actually a session, so can't be reset, and will generate that error.  This can be demonstrated by running the commands on a computer to which you are connected remotely - it will return an active session, and you will be able to reset this session using the rwinsta command.

I was hoping when suggesting qwinsta that an active session would come to light that could be reset - unfortunately this wasn't the case!
0
 
MichaelBurksAuthor Commented:
The issue has been resolved. The IP ADDR of the machine that I was attempting to connect to had been transposed with my machines IP ADDR. Both mchines sit on the network at the main office and I would like to know hw this happened and if it could happen again in the future. I am giving the points to purplepomegranit as the advice given by this member was what led me to figure this out. Thanks to all who replied.

Michael
0
 
nimra9Commented:
had the same problem, was the VMWare virtuell adapter.
0
 
visionmn2Commented:
rwinsta 65536  and then answer yes worked for me.

I had tried to uninstall the patches (from 2/10/10) and .net 3.0 as there were threads that could cause it, put in firewall exceptions, uninstalled and re-installed (well checked the box restart, recheck for remote in XP) and none of it worked.

rwinsta 65536 is magic.
0

Featured Post

Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

  • 16
  • 12
  • 3
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now