Remote connection error 1130/2003

I have a Mysql server running on a fedora 3 box. I want to use a winxp client to remotely administer the databases.

On both machines  i am using the "mysql control center"as the admin client.

I have used webmin to set up the hosts allowed

On the win machine i get the following error
                      [Server] ERROR 2003: Can't connect to MySQL server on '10.1.1.30' (10065)
10.1.1.30 being the ip address of the mysql server

However if i run the admin client on the linux machine, if i use anything but "localhost", i get the following error
          ERROR 1130: Host'10.1.1.30' is not allowed to connect to this mysql server

Regards Phill
PhillOAsked:
Who is Participating?
 
JesterTooConnect With a Mentor Commented:
It sounds like MySQL is configured to only allow the admin tool to connect from localhost... this is a common security setting.  Please read the sections 5.5.x (specifically 5.5.5, but be aware of the info in the others, too) of the MySQL manual.  Here's a shortcut to a couple of the relevant sections...

    http://dev.mysql.com/doc/mysql/en/connection-access.html 
    http://dev.mysql.com/doc/mysql/en/privilege-system.html

HTH,
Lynn
0
 
PhillOAuthor Commented:
Lynn

It would seem that this works out for the localhost in that from this info i figured out how to access mysql using 10.1.1.30 instead of local host. this was just a test anyway toctry and find where the problem was.

However i have fiddled with the ip addresses and usernames for the xp machine and still get

                             [Server] ERROR 2003: Can't connect to MySQL server on '10.1.1.30' (10065)
Any ideas

I agree that it seems to be a permissions problem though

Phill
0
 
PhillOAuthor Commented:
I forgot to mention that the client and server are on different subnets for security

Phill
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
JesterTooCommented:
Check the configuration file (my.cnf) to ensure that it doesn't contain "skip-networking".  If this is present you can only have local connections.  Alternatively you could issue the "mysql show variables;" command from the server to see the configuration options in effect.

Lynn
0
 
PhillOAuthor Commented:
lynn

"skip-networking" does not appear
0
 
PhillOAuthor Commented:
AHHHHHH!!!!

Damn Firewall!!!!!!!!!!!!!!

Phill
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.