[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2815
  • Last Modified:

Unable to access or ping Cisco interface

Hi, I'm working on a 3640 and am trying to configure one of the interfaces with an IP address so I can upload my configuration to it. After I configure the interface, i connected it to a little 4 port switch and connected my computer to the switch as well. However, when I try to ping the interface, it times out and I can't do any thing. Can anyone tell me what's wrong with this configuration so far? thanks

!
version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 (took out)
enable password (took out)
!
no aaa new-model
ip subnet-zero
no ip routing
ip finger
!
!
ip name-server 204.117.214.10
!
ip dhcp pool 1
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server 204.117.241.10
!
no ip cef
ip audit po max-events 100
no ftp-server write-enable
!
!
interface Ethernet0/0
ip address 10.10.10.1 255.255.255.0
no ip route-cache
half-duplex
no mop enabled
!
interface Serial0/0
no ip address
no ip route-cache
shutdown
!
interface Ethernet0/1
no ip address
no ip route-cache
shutdown
half-duplex
!
interface Serial0/1
no ip address
no ip route-cache
shutdown
!
interface FastEthernet2/0
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
ip http server
no ip http secure-server
ip classless
!
snmp-server community private RW
snmp-server community public RO
!
dial-peer cor custom
!
!
line con 0
line aux 0
line vty 0 4
password (took out)
login
!
!
end
0
jumper4000
Asked:
jumper4000
  • 9
  • 9
  • 3
  • +4
1 Solution
 
minmeiCommented:
jumper4000,

Add this:

ip dhcp excluded-address 10.10.10.1 10.10.10.10

You probably gave out 10.10.10.1 again?

Do a sh ip dhcp binding and see what you get.

Good luck!
0
 
jumper4000Author Commented:
I tried your suggestion, but it didn't make a difference. This is what I get when I issue that command:

Router#sh ip dhcp binding
Bindings from all pools not associated with VRF:
IP address          Client-ID/              Lease expiration        Type
                         Hardware address/
                         User name

The router doesn't distribute IPs or anything. I have also changed the cables and tried activating other interfaces with the same result. I have also set the computer up with a static ip (10.10.10.20), and still nothing. is it possible that since there's no access-list present right now, every bit of traffic is being denied? Also, if I try to ping the interface from the console it succeeds, but if I try to ping the computer it  fails.
0
 
ruddgCommented:
Can you post the output of a 'show int e0/0' here?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
jumper4000Author Commented:
sure. here you go:

Router#show int e0/0
Ethernet0/0 is up, line protocol is up
  Hardware is AmdP2, address is 00d0.5873.fdc1 (bia 00d0.5873.fdc1)
  Internet address is 10.10.10.1/24
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 02:05:57, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     2509 packets output, 260716 bytes, 0 underruns
     0 output errors, 0 collisions, 39 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
0
 
ruddgCommented:
There are quite a few interface resets...

Try setting the link negotiation to auto on e0/0:

int e0/0
  duplex auto
  speed auto

Are you using a straight CAT5 patch cable to connect the router & switch?
0
 
ruddgCommented:
Sorry, nix the 'speed auto' -- I wasn't paying attention (e0/0 is 10 only)
0
 
jumper4000Author Commented:
yes right now I'm using a straight cat5e (but I have tried others). I will buy a crossover cable tomorrow and try that as well.
0
 
ruddgCommented:
Shouldn't need a crossover to connect the router to a switch.  Wouldn't hurt to try a crossover directly between the router & your PC though.  This shouldn't have anything to do with it, but you will want to issue an 'ip routing' command.

Can the router ping its own IP?  Is there any chance the PC is running a personal firewall (i.e. Windows XP SP2)?  If so, be sure to disable that...
0
 
jumper4000Author Commented:
yes the router can ping its own IP without a problem (100% success). Also, there's no firewall, but just to be sure, I configured another pc and gave it the same ip as the router, then disconnected the cable from the router and plugged it straight into the other PC. I was able to ping both ways without a problem. So something on the router must be blocking traffic.
0
 
ruddgCommented:
Nothing in the config appears to be awry...

Not likely, but have you tried power cycling the router and/or issuing a 'shut' and 'no shut' command on the e0/0 interface?
0
 
jumper4000Author Commented:
ever since yesterday, I rebooted the thing like 20 times, but I just did it again, and still nothing. Is there anyway delete every single setting, so on the next reboot it prompts you to run the setup again, and start fresh?
0
 
ruddgCommented:
write erase
reload
(don't save changes)
0
 
jjk16Commented:
when you connect the computer to the switch. Whats the ip of the computer? is it 169.xx.?
Is the led connection like on the ethernet lit up?

once you know ip of the computer(prob best to give it a static ip, say 10.10.10.101)
ping the computer's ip from the router. vice versa


" If no "Configuration File" is found in NVRAM,
the Cisco IOS will offer you the chance to use the "Initial Configuration Dialog".
This is a set of Questions for you to answer to do a basic configuration.
Since in our theoretical New Router there is no NVRAM configuration
This "Setup Dialog" will be one of the first things we see. "
0
 
Vladan_MOBTELCommented:
COuld you connect to the console and give us the output as it boots?
0
 
harbor235Commented:
Is there something wrong with the PC? Can you log into the switch and verify settings as well as checking
the ARP table to see which mac addresses are registered. Do you have a bad port on the switch?


harbor235
0
 
harbor235Commented:
>interface Ethernet0/0
ip address 10.10.10.1 255.255.255.0
no ip route-cache
half-duplex
no mop enabled


Is the switch in full duplex mode? Again, verift switch port settings are the same as the router settings. I would also enable CEF ( IP cef )

harbor235
0
 
harbor235Commented:
Verfiy duplex , speed , negoitation, etc ... on the switch port. The ethernet interface will support full duplex mode.

harbor235
0
 
piersonmCommented:
no aaa new-model
ip subnet-zero
no ip routing
ip finger

(1) Verify you have ip routing enabled
Router#: config t
Router(config)#: ip routing

(2) Is this a module of built-in port on the router, I know some Ethernet modules have both RJ-45 and AUI connectors.  Which is active.  Under your Ethernet interface see if the option to specify media-type is available.
Router#: config t
Router(config)#: interface ethernet0/0
Router(config-if)#: media-type 10-BaseT
Router(config-if)#: end

(3) Issue the show diag command and verify the ethernet0/0 interface passed testing during bootup.  Please post this information as well.

MP
0
 
jumper4000Author Commented:
I tried all the suggestions and still nothing. I then erased the config, started fresh with a crossover cable, and just gave an ip address to e0/0 (10.10.10.1), and a static ip (10.10.10.10) to the pc. Still nothing. I even took out the cable from the router, plugged it into another pc, gave the other pc the same ip as the router and that works just fine (i was able to ping both ways). Could this router be bad?
0
 
ruddgCommented:
Try using one of the other interfaces to test that theory... it is possible.
0
 
jumper4000Author Commented:
I've tried all of them already. same exact result.
0
 
piersonmCommented:
Try scenario again with:

     no console logging,
     logging on
     logging buffered 4096 debugging
     ip routing

     interface ethernet0/0
      media-type 10BaseT
      encapsulation arpa
      half-duplex
      no shutdown

-verify IP subnet mask is 255.255.255.0 on both interfaces
-verify your PC network adapter is set to auto or half duplex
-verify your router ethernet0/0 is still set for half duplex
-cross over cable between your PC and the router;
-enable debugging ip packet detail on the router
 
     debug ip packet detail

perform an extended ping from the router with the target address as the ip address of the PC -- enable extended commands and set the source interface as ethernet0/0 and continue all the way through.

After your pings have completed review the log on the router by issuing the show logging command and see what information has been left (post it) -- if you receive any messages relating to failed encapsulation the ethernet card on the router does not know how to interpret the encapsulation which you should verify if the encapsulation is set to arpa using the show interface ethernet0/0 command.  

Postings from this debug should help point in the right direction.

(2) If all else fails try looping an ethernet interface on the router to another ethernet interface on the router (since you have more than one) with the crossover cable you have and test and see what happens.

MP
0
 
jumper4000Author Commented:
I'm using Ethernet0/1 now, but here's the log info:

Router#show logging
Syslog logging: enabled (9 messages dropped, 1 messages rate-limited, 0 flushes, 0 overruns, xml disabled)
    Console logging: level debugging, 87 messages logged, xml disabled
    Monitor logging: level debugging, 0 messages logged, xml disabled
    Buffer logging: level debugging, 47 messages logged, xml disabled
    Logging Exception size (4096 bytes)
    Count and timestamp logging messages: disabled
    Trap logging: level informational, 52 message lines logged
         
Log Buffer (4096 bytes):

*Mar  1 00:24:00.207: %SYS-5-CONFIG_I: Configured from console by console
*Mar  1 00:27:58.967: %SYS-5-CONFIG_I: Configured from console by console
*Mar  1 00:33:14.271: IP: tableid=0, s=10.10.10.1 (local), d=10.10.10.10 (Ethernet0/1), routed via RIB
*Mar  1 00:33:14.271: IP: s=10.10.10.1 (local), d=10.10.10.10 (Ethernet0/1), len 100, sending
*Mar  1 00:33:14.271:     ICMP type=8, code=0
*Mar  1 00:33:14.271: IP: s=10.10.10.1 (local), d=10.10.10.10 (Ethernet0/1), len 100, encapsulation failed
*Mar  1 00:33:14.271:     ICMP type=8, code=0
*Mar  1 00:33:16.271: IP: tableid=0, s=10.10.10.1 (local), d=10.10.10.10 (Ethernet0/1), routed via RIB
*Mar  1 00:33:16.271: IP: s=10.10.10.1 (local), d=10.10.10.10 (Ethernet0/1), len 100, sending
*Mar  1 00:33:16.271:     ICMP type=8, code=0
*Mar  1 00:33:16.271: IP: s=10.10.10.1 (local), d=10.10.10.10 (Ethernet0/1), len 100, encapsulation failed
*Mar  1 00:33:16.271:     ICMP type=8, code=0
*Mar  1 00:33:18.271: IP: tableid=0, s=10.10.10.1 (local), d=10.10.10.10 (Ethernet0/1), routed via RIB
*Mar  1 00:33:18.271: IP: s=10.10.10.1 (local), d=10.10.10.10 (Ethernet0/1), len 100, sending
*Mar  1 00:33:18.271:     ICMP type=8, code=0
*Mar  1 00:33:18.271: IP: s=10.10.10.1 (local), d=10.10.10.10 (Ethernet0/1), len 100, encapsulation failed
*Mar  1 00:33:18.271:     ICMP type=8, code=0
*Mar  1 00:33:20.271: IP: tableid=0, s=10.10.10.1 (local), d=10.10.10.10 (Ethernet0/1), routed via RIB
*Mar  1 00:33:20.271: IP: s=10.10.10.1 (local), d=10.10.10.10 (Ethernet0/1), len 100, sending
*Mar  1 00:33:20.271:     ICMP type=8, code=0
*Mar  1 00:33:20.271: IP: s=10.10.10.1 (local), d=10.10.10.10 (Ethernet0/1), len 100, encapsulation failed
*Mar  1 00:33:20.271:     ICMP type=8, code=0
*Mar  1 00:33:22.271: IP: tableid=0, s=10.10.10.1 (local), d=10.10.10.10 (Ethernet0/1), routed via RIB
*Mar  1 00:33:22.271: IP: s=10.10.10.1 (local), d=10.10.10.10 (Ethernet0/1), len 100, sending
*Mar  1 00:33:22.271:     ICMP type=8, code=0
*Mar  1 00:33:22.271: IP: s=10.10.10.1 (local), d=10.10.10.10 (Ethernet0/1), len 100, encapsulation failed
*Mar  1 00:33:22.271:     ICMP type=8, code=0

Router#show interface ethernet0/1
Ethernet0/1 is up, line protocol is up
  Hardware is AmdP2, address is 00d0.5873.fdc2 (bia 00d0.5873.fdc2)
  Internet address is 10.10.10.1/24
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     390 packets output, 123273 bytes, 0 underruns
     0 output errors, 0 collisions, 6 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

Thanks
0
 
ruddgCommented:
I would give Cisco a call... looks like you've got a hardware problem.
0
 
piersonmCommented:
Basically what encapsulation failed means is that the router is having trouble mapping the layer 2 address (MAC) to the layer 3 address (IP)

This link below gives suggestions on how to correct the problem such as adding a static arp entry in the router.  Something is switched off that is normally on by default

     arp <ip-address> <hardware-address>

or

on the interface enter

     interface ethernet0/0
      arp arpa
      ip proxy-arp

http://www.cisco.com/en/US/customer/products/sw/iosswrel/ps1831/products_tech_note09186a00800a6057.shtml#backinfo 

MP
0
 
jumper4000Author Commented:
Apparantly there was a problem with my IOS version, 12.3. What I did was to kill it using, erase flash:, and installed a little older IOS, 12.2(7), and that fixed this issue. Thanks for all your help.
0
 
ruddgCommented:
Good job, jumper4000 -- I was on the brink of asking about the IOS, but didn't :-|
-- recommend you request a delete/refund on this question in the support area.
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

  • 9
  • 9
  • 3
  • +4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now