Configuration problem on cyrus-imap with postfix

I am new to fedora core 3 and I am configuring a postfix and cyrus-imap. I have a problem in pop3 and output the following log:

Apr 21 17:16:26 dev pop3[6846]: login: [192.168.60.118] acsanluis plaintext User logged in
Apr 21 17:16:29 dev pop3[6846]: Unable to locate maildrop for acsanluis
Apr 21 17:16:29 dev pop3[6846]: unable to tell master 1: Broken pipe

My SMTP is running ok..
asdad_uly21Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

 
asdad_uly21Author Commented:
Hi GURU out there.. Can some body help me? Thanks in advance for your help..
0
 
macker-Commented:
Run the command "which maildrop"; if it returns no results, try "locate maildrop | grep maildrop$".

Also, try the commands "rpm -V courier courier-imap"; it will probably indicate one of them is not installed.  It will only show output for files which have been modified in some way, e.g. newer timestamp, different permissions, etc.  Look for "missing", "5", "U", "G", etc. - especially on "maildrop"
0
 
asdad_uly21Author Commented:
this is the output when i run the command: which maildrop
/usr/bin/which: no maildrop in (/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin)

i dont have an idea what this output means....

i only installed cyrus-imap from the distro of fedora core 3, courier-imap is not available in distro of fedora...

0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
macker-Commented:
It sounds like it wants the maildrop delivery agent, from courier.  It may be possible to change the configuration to use 'deliver', procmail, or another delivery agent.  Please replace "courier" with "cyrus" in my previous comments.  You may be able to instal just the courier-maildrop.rpm package for Fedora.  This should be available thru Fedora download sources, Fedora Legacy, rpmfind.net, or built locally as described at http://www.courier-mta.org/rpm.html

As I mentioned before, you may also be able to modify Postfix's config to use something other than maildrop.
0
 
Darshan_JadavCommented:
u r missing maildrop http://www.courier-mta.org/maildrop/ , download the package and if u want to build the RPM from the same u can or install it from the soruce directly

./configure
make && make install-strip && make install-man

0
 
asdad_uly21Author Commented:
sorry for the delay......

I compiled the maildrop, problem is still the same..... should i change my pop and imap server from cyrus-imap to courier-imap.... I'am having hard time fixing it in cyrus-imap......

I'am asking for recommendation for this decision......
0
 
macker-Commented:
I'm not familiar with Cyrus IMAP, though I can say that Courier IMAP is a fine program.  However, assuming this is a relatively "out-of-the-box" configuration, it should be working to begin with, unless something was misconfigured.  Also, in re-reading the original log entries, it seems odd that the POP3 daemon would be looking for the maildrop delivery agent, so it's possible that it's referring to something else.

Does this error occur for other users?  Does e-mail work for any users?
0

Experts Exchange Solution brought to you by ConnectWise

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
 
asdad_uly21Author Commented:
all users have the same error log when it comes to cyrus-imap....well, any way i finished the courier-imap in a flash.....the only thing that i have encounter with courier-imap is the configuration in authdaemonrc.

thanks for the help... i will post again another problem.... i'am  having hard time configuring the LDAP server in my postfix.....   hoping you can help me with this problem....  LDAP, Postfix and Courier-imap.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.