FTP problem. Cannot upload more than 32K

Hi,
Actually a friend have this problem.
He is using WinXP, and when try to upload a file to any server, his system limits it to 32K

It is not a server side problem. Because he has a test account in one of my servers.
When I login with his name/pw I can upload anything I want.

you can see 2 files in here:
http://www.pogodo.com/cumhur

one is uploaded by him (32K) you can see the image is actually not complete.
the other is uploaded by me (80K+)

Any idea what can be done?
Thanks
LVL 1
BuraqueAsked:
Who is Participating?
 
JeavonConnect With a Mentor Commented:
This could be realted to a recent MS Update that causes some strange things to happen with FTP, see if hotfix KB890859 is installed, if so unistall it and test the FTP
0
 
_treySterCommented:
What is he using to upload?
0
 
fruhjCommented:
hey so this happens to any FTP server he tries?
including your personal one right?

Did you check his MTU setting?
Also is he behind any kind of firewall? FTP has two modes, Active and passive - and the port requirements are different for each - could it be that the first part of the tranmission makes it out, and the second one gets killed?

If he's running XP, and if you are familiar with IIS, spend 5 min and install an FTP server on his machine, then try and upload direct from his machine to his machine - should reveal if the problem is on his PC or elsewhere.

- Jack
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
BuraqueAuthor Commented:
He told me that when he was using win98, everything was fine. He has this problem since he installed winXP. He used like 7 different FTP clients, don't know exactly which ones though...
0
 
rburns50Commented:
As per fruhj above, you need to select passive mode FTP when passing through a firewall (sometimes shows up in FTP clients as PASV mode). Most FTP clients support this. The reason is that normal FTP was not created to pass through firewalls- a client connects to an FTP server on TCP port 21, and then the server drops that connection and initiates a connection back to the client. Most firewalls will block that return connection, as it is being initiated from outside the firewall (especially stateful inspection ones). Passive mode FTP sessions do not do the drop and reconnect backwards- they maintain the connection from the client to the server throughout the session (still on TCP port 21).
0
 
fruhjCommented:
Buraque, any update?
0
 
BuraqueAuthor Commented:
His MTU settings seems fine. Actually MTU is fixed to 1500 by his modem's control panel (he says).

Now he is going to try Jeavon's advice...
0
 
BuraqueAuthor Commented:
Points goes to Jeavon.
It was not the exact solution, but his idea lead my friend to the solution.

When he searched the current updates and fixes, hotfix KB890859 particularly, he realized that he didn't update windows at all. When he updated all components, problem fixed.
Thank you everyone..
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.