sendmail and fetchmail problem.

Hi experts,

we have our mailboxes hosted on an isp. we use fetchmail to fetch mails from isp to deliver locally. we use sendmail to forward mails to our isp.

we receive error query status = 10 error. On sendmail.cf "Deamonportoptions = 127.0.0.1" then the problem gets resolved. but now when we sending mails from outlook express cleint "no socket error"

if we change the entry to "192.168.1.1" then the mail sending is ok. again fetchmail query status = 10 error.

help me. urgent.


prathab
prathabAsked:
Who is Participating?
 
macker-Commented:
The no socket error is probably an indication that it was unable to connect to the server on the SMTP port.

127.0.0.1 is the loopback interface; if you connect to that IP, it will connect to the local system.  The loopback interface is _only_ available to the local system, it is not associated with any network card, and cannot be reached from any other system.  If a daemon or service (such as sendmail) is configured to listen specifically to that interface, then it's not going to be able to receive connections from other systems.

As bzImage8 indicated, you'll need to modify sendmail.mc; either modify it to listen to mulitple IP's (both local and network), modify it to listen to just the network interface, or modify it to not have any statement here, which should allow it to default to listening to all interfaces.

the m4 command is for the m4 preprocessor.  It takes a "simple" file, the .mc file, runs it against a template, and produces the "real" config file which is used by sendmail.  Because sendmail's options are so complex, and cryptic, the m4 config files are highly recommended.  Just make sure that you're in the same directory as the files when running the command, or that you're specifying the full paths, e.g. m4 /etc/mail/sendmail.mc > /etc/mail/sendmail.cf

Also, depending on your distribution, you may find the init scripts in a different place, e.g. /etc/rc.d/sendmail, /etc/rc.d/init.d/sendmail, or /sbin/init.d/sendmail.  You should be able to use either the "stop" and "start" syntax, or just a single command line of "restart" (/etc/rc.d/init.d/sendmail restart).
0
 
bzImage8Commented:
I guess that you have a redhat system, if i well remember, by default the sendmail shipped with redhat only listens on the local interface (127.0.0.1), you have to edit the sendmail.mc file (that file can be on /etc/ or /etc/mail) and remove the daemon options to listen only on the interface 127.0.0.1.

Next, re-create the sendmail config file using:

m4 sendmail.mc > sendmail.cf

stop and start sendmail again:

/etc/init.d/sendmail stop
/etc/init.d/sendmail start

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.