• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 311
  • Last Modified:

Home Directories and Profiles in Terminal Server 2003

Hi guys,

Please Help!!!


I have a Terminal Server 2003 with Licensing Server on the same box.

I have a problem.

All application settings (eg.ini file setttings) for the application are not being transferred into user's home folders.

I go to install a program, so I have done the following:

Firstly - put the Terminal Server into install mode.
I have tried:
- change user /install (then installed the program) then change user /execute
- Add Remove Programs (then install)

What am I doing wrong here????

I have setup local home directories for each user for Terminal Services.

When they logon, they get a local terminal service home directory in:

d:\tsusers\<username> (I set this through group policy)

I set up these users to use local terminal service profiles in:

C:\Documents and Settings\<terminal server username>

Should the termnal server home directory and terminal server profile be in the same path?????

How do I know if when publishing this application that the app will function properly?

Im a bit confused as to the best practice here.

Im going to be using Citrix to publish these applications on the same box, so do I have to go through all this anyway?

Does it make a difference if the the users dont have these ini file settings anyway per application?

These same users have Windows domain user home directories and user profiles.

I wanted to give each user a DIFFERENT home directory and profile just for terminal servers, so I defined these in group policy. This seems to work, but the ini file settings when I go through a change user /install are not copying the application data to each users home directory/profile (should they be in the ts profile or home directory???)

Any help on clearing this mess up would be greatly appreciated.

Thank you.

Simon

0
Simon336697
Asked:
Simon336697
1 Solution
 
jeroenlemaireCommented:
i hope you have all your users logged off your terminal server before you set your machine in install mode...
so you basically should make sure following steps are taken:

1. get all your users logged off, and log on your machine (preferably using the console or RDP in administration mode)
2. change user /install
3. install your application
4. change user /execute (this one sets all registry settings and other system files availble for your users)

Hope this hleps you out...
0
 
Simon336697Author Commented:
Thanks!!!
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now