How do I troubleshoot my printing prblem?

Posted on 2005-04-22
Last Modified: 2013-12-27
I posed this question a week or two back and I thought I had it licked.  I still can't get my Ultra 60 (Solaris 9) to print to my HP2500cm.

Here are the details(ip of printeris fictional):

I set up my printer like this:

bash-2.05# /usr/sbin/lpadmin -p 2500cm -v /dev/null -o protocol=bsd,dest= -T PS -I postscript -i /usr/lib/lp/model/netstandard
Print services started

bash-2.05# /usr/bin/enable 2500cm
UX:enable: WARNING: Destination "2500cm" was already enabled.

bash-2.05# /usr/sbin/accept 2500cm
UX:accept: WARNING: Destination "2500cm" was already accepting

bash-2.05# lp -d 2500cm test.txt
UX:lp: ERROR: There is no filter to convert the file content.
      TO FIX: Use the lpstat -p -l command to find a
              printer that can handle the file type
              directly, check your filters using lpfilter -f all -l, or
              consult with your system

.... I got the above error so I reconfigured the print services like this:

bash-2.05# lpstat -p -l
printer 2500cm is idle. enabled since Thu Apr 21 14:55:03 2005. available.
        Form mounted:
        Content types: postscript
        Printer types: PS
        Connection: direct
        Interface: /usr/lib/lp/model/netstandard
        PPD: none
        On fault: write to root once
        After fault: continue
        Users allowed:
        Forms allowed:
        Banner required
        Character sets:
        Default pitch:
        Default page size: 80 wide 66 long
        Default port settings:  
        Options: protocol=bsd, dest=, dest=, dest=hostname:raw, timeout=5

bash-2.05# /etc/init.d/lp stop
Print services stopped.
bash-2.05# /usr/sbin/lpadmin -p 2500cm -v /dev/null -o protocol=bsd,dest= -T unknown -I any -i /usr/lib/lp/model/netstandard
Print services started.
bash-2.05# lp -d 2500cm test.txt
request id is 2500cm-6 (1 file(s)

Nothing comes out of the printer

I have confirmed my ip is correct, and other folks can print to this printer.

Any help would be geatly appreciated.



Question by:Traverse-61

    Author Comment

    Oh yea one more thing.  I install HP Jetdirect with pkgadd but have noi idea how to use it. I don't really care how this gets done ... just as long as i can get this darn thing to work, and forget about printing for a while.

    Author Comment

    more status info:

    bash-2.05# lpstat -t
    scheduler is running
    no system default destination
    device for 2500cm: /dev/null
    2500cm accepting requests since Thu Apr 21 14:32:17 2005
    printer 2500cm waiting for auto-retry. available.
            exec exit fault
    2500cm-6                root                82   Apr 22 07:22

    Author Comment

    More info:

    I ran snoop between the ip of the host and the ip of the printer.  I try and print the test.txt document and I get zero traffic in my snoop output.
    LVL 10

    Expert Comment

    use dest= (for textfiles) and dest= for postscript or other documents that are being converted by solaris itself.

    When sending Textfiles directly to the :raw-Interface, you will get staircase printing.

    LVL 16

    Expert Comment

    by:Hanno Schröder
    Please, do NOT use HP JetDirect!

    a) Can you ping the printer's IP address?
    b) Can you telnet into the printer using it's IP address
    c) You have several "dest=..." options in your printer's configuration. Please
        delete the printer with
           lpadmin -x 2500cm
        first. Also, I am not sure if printer names starting with a number are allowed.
        Maybe you should name it hp2500cm or something the like.
    d) When installing a postscript printer, you will have to send postscript output to
        it -- or have filters installed to convert to postscript

    Good luck!

    Author Comment

    Why should I not use JetDirect?   Should I uninstall SOLe134.PKG?

    Thanks for your help so far.  Still trying to work this problem in my spare time .


    Author Comment

    More info...

    ping... ok  telnet .... no problem.  I edtited the /etc/printers.conf and replaced the printer name with the IP of the printer (no DNS or /etc/hosts entry for the printer name).

    I tried to print... but I got an error saying I needed a filter so i made one like this:

    bash-2.05# lpfilter -f u2d -F /etc/lp/fd/u2d.fd
    bash-2.05# lpadmin -p JetDirect -I u2d

    bash-2.05# lpfilter -f all -l
    (Filter "u2d")
    Input types: simple
    Output types: u2d
    Printer types: any
    Printers: any
    Filter type: slow
    Command: /bin/unix2dos -437

    Now I can print test files but if I try to print somthing like an HP openview graph .... I get a bunch of gobledygook.

    printing on solaris is admin HELL I tell you!  Please save me!!!! :)

    LVL 10

    Expert Comment

    most probably you have been just fine in your setting specified in the question.

    Just use


    for your "dest"-Parameter. That'll do.

    LVL 16

    Accepted Solution

    Printing on Solaris is pretty straight-forward *fg*

    - Add the printer as beforementioned (add printer's IP to /etc/hosts):
      # echo "   hp2500cm" >> /etc/hosts
      # lpadmin -p hp2500cm -v /dev/null -o protocol=bsd,dest=hp2500cm -T PS -I postscript -i /usr/lib/lp/model/netstandard
    - Having a postscript printer add the filters (easiest method, using sh or ksh syntax) this way:
      # cd /etc/lp/fd
      # for filt in download *post* ; do lpfilter -f `echo $filt | cut -d. -f1` -F $filt ; done

    Good luck!

    Expert Comment

    We were having problems with certain HP printers also and found using HP Jetdirect utility solved the problem.

    from command prompt type:
    # /usr/bin/hppi

    choose option "1 - Spooler Administration"
    then option "1 - add printer to local spooler"
    enter ip address of printer....
    at next menu choose "1 - lp destination queue name" if you want to taylor the name to suit
    You can choose option 5 (then option 1) if you want to change the model script to use to suit your model of printer although I would try default one first. (if in this menu choose "q" to get back to sub-menu)
    Then select 0 to configure.

    Might not work for you but could be worth a try!!

    Good Luck,

    Author Comment


    Got it working.  As always your technical assistance is much appreciated.  Grass-hopper,  Ill give your Jetdirect solution a try sometime... but for now... if it ain't broke... I'm not messin with it :)



    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Highfive + Dolby Voice = No More Audio Complaints!

    Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

    Attention: This article will no longer be maintained. If you have any questions, please feel free to mail me. Please see for the updated article. It is avail…
    When you do backups in the Solaris Operating System, the file system must be inactive. Otherwise, the output may be inconsistent. A file system is inactive when it's unmounted or it's write-locked by the operating system. Although the fssnap utility…
    Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
    Video by: Phil
    This video goes over how to configure and start a jail in FreeBSD.  This video is meant to supplement the article included with this course.

    759 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    11 Experts available now in Live!

    Get 1:1 Help Now