[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Why are Zip disks not recognized as formatted and containing data in a recently installed internal ide zip drive?

Posted on 2005-04-22
31
Medium Priority
?
788 Views
Last Modified: 2010-04-03
After recent assembly of a new computer, with the old internal ide zip drive from the previous computer, the zip drive appears to be fully recognized as functioning by the XP-pro operating system (assigned a drive letter and no problems in device manager).  However, any formatted zip disk that was used in the previous computer gets the response: "The disk in drive F is not formatted. Do you want to format it now?"  The disk formats are reported in properties as RAW.  The old computer used XP-home.  What is necessary for these disks to be recognized as formatted and containing data?
0
Comment
Question by:realvalue
  • 12
  • 10
  • 3
  • +4
31 Comments
 
LVL 13

Expert Comment

by:Watzman
ID: 13842617

Something is wrong.  I'd go to the Iomega site, download their latest software and install it.  Also, check their troubleshooting and "FAQ" and see if you can find anything.  Also, in device manager, make sure that the Zip drive is marked as "removeable".  I think that the problem is in how XP is classifying the drive, rather than anything in the disk itself.
0
 
LVL 88

Expert Comment

by:rindi
ID: 13842941
Also make sure you have installed all current motherboard drivers.
0
 

Author Comment

by:realvalue
ID: 13843095
I just discovered my zip drive is ATAPI not IDE.  Device driver indicates it is SCSI.

I am downloading the Iomega software now.  In previous contact with them they said the native xp drivers should be enough.

Where in device manager would I find the drive marked "removable".   It is now classified under disk drives.

All motherboard drivers were current as of two weeks ago.
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 

Author Comment

by:realvalue
ID: 13843234
The Iomega download is installed.  Iomega icons have been added to the properties dialog box for the drive but nothing has changed with regard to the problem of disk recognition.
0
 

Author Comment

by:realvalue
ID: 13843283
There are no new drivers for the ASUS P5GDC-V Deluxe motherboard to which the drive is connected PRI_RAID1.  RAID is not enabled in the BIOS so it is in IDE mode.
0
 
LVL 13

Assisted Solution

by:Watzman
Watzman earned 400 total points
ID: 13843548

Do you have a non-Raid IDE port?  (I understand that you are using the Raid port in IDE mode, but if there is an "IDE only" port, I'd use that).

Just for kicks, what happens if you do take a BLANK Zip disc and format it in the drive?  Is it then useable?  Can it then still be read on other systems with a Zip drive?
0
 

Author Comment

by:realvalue
ID: 13843559
A couple of weeks ago I did check Iomega's site.  I found nothing, so I started a chat session and ran through some things with them.  The text of that session follows.  That is where I had left the problem until today.

Rebecca: Thank you for contacting Iomega's Online Support Services. Please provide the serial number of your Iomega drive if you have not already provided this information. How may I assist you today?
me: I have moved my zip drive to a new computer. The disk on which I have files is not recognized as having files. Windows asks if it should format the drive. How do I get the files?
Rebecca: Does it recognise any disks correctly?
me: I have tried one blank and one with files, for each it indicates they are unformatted.
Rebecca: Can you format hte blank one?
me: No, windows said it was unable to format. Could htis have anything to do with file format?
Rebecca: Yes, that is what it is saying. That there is no file format.
Rebecca: Right click on it and choose properties.
Rebecca: What file system is listed?
me: Both indicate RAW
Rebecca: Alright, these disks have been corrupted. Do you have any diskks that work?
me: I have checked a couple more, one with and another without data, same response.
Rebecca: Okay, do you have access to another Zip drive?
me: No
Rebecca: One moment.
me: The one disk worked in the other XP computer yesterday before I switched.
Rebecca: So you have another Zip drive? Or you moved this one?
me: I moved this one.
Rebecca: Alright, was there a disk in it when you moved it?
me: No
Rebecca: ARE you sure you installed it correctly?
me: It spins up and recognizes there is a disk. I have not installed any drivers as I thought the native XP were all that was needed.
Rebecca: It does.
Rebecca: Is it connected correclty? How is it configured?
me: I cannot imagine the cable is reversed and I would be getting anything. What is needed for driver and configuration?
Rebecca: thedrive is native. What cable do you have it connedcted to?
Rebecca: the driver is native.
me: An IDE for Ultra ATA 133/100/66 signal cable
Rebecca: Where on the cable?
Rebecca: And primary or secondary?
me: The end
Rebecca: There are two cables, which one is it connected to?
me: There is no other device on the cable
Rebecca: Okay, connect it to the other connection.
me: Can I do that hot, or do I shut down? If I shut down how do I get back to you?
Rebecca: You will need to shut down. I will sendl you a link that tells you how to instlal it. You can respond to that e-mail with your results.
Rebecca: Is there anything else I can assist you with?
me: What is the reason for trying the other connection on the cable?
Rebecca: It may be a problem with the setup.
me: Do you mean a problem with the cable?
Rebecca: Could be.
Rebecca: Thank you and have a great day.
Please do not hesitate to contact us if you need further assistance.
0
 
LVL 3

Accepted Solution

by:
jwleonard1 earned 600 total points
ID: 13843622
Try connecting it to PRI_IDE1 instead of the RAID connection, it is the one up by the memory slots.  I don't know what kind of configuration you have for your other drives, so you may have to disconnect you optical drives if they are on this channel.  Really all you need are your hard drive and zip drive connected.  Don't forget to check your jumper settings when you reconfigure everything!  If it works there then your problem has to do with the onboard RAID controller setup!  Try this and post back to let us know how it went.
0
 

Author Comment

by:realvalue
ID: 13843837
Connecting to PRI_IDE1 is the solution to getting recognition of the files on the zip disk.  Thanks

But now what do I do if I want to keep the zip and my two dvd/cd drives?

Now that I can get the files off of the zip, I could do without it, but that would not be the preferred solution.  The dvd/cd drive performance is most important.
0
 
LVL 4

Expert Comment

by:marco_peereboom
ID: 13843884
I had an ATAPI ZIP-drive once as well. What I found was that it (seemingly) always started under PIO-0 mode. So to start off, does your MOBO understand any ancient PIO connection? And with that, does it understand PIO-0?

And I'd agree on the idea of using IDE only. RAID uses a different instructionset and I would say that running it in IDE mode would also use a different instructionset.
0
 
LVL 3

Assisted Solution

by:jwleonard1
jwleonard1 earned 600 total points
ID: 13844042
Try connecting the optical drives to the PRI_RAID1 connector and see if they work correctly, they might work with the current settings on that connector.  If not then hook everything back up the way it originally was, post back and we will go through some bios settings.
0
 

Author Comment

by:realvalue
ID: 13844047
Will I have better optical disk performance if I connect the dvd/cd cable that was connected to PRI_IDE1, which is Ultra DMA 100/66, to the PRI_RAID1 which is Ultra ATA 133/100/66?

I don't know about PIO.
0
 
LVL 3

Expert Comment

by:jwleonard1
ID: 13844169
No you won't get better performance, I'm just hoping it will work!
0
 

Author Comment

by:realvalue
ID: 13844260
They DO work, but on booting I get a message that the cable being used will cause a lower level of performance.  I will try to get the specifics on another boot if the message shows again.  If it does show again that would be undesirable at each boot.  I am going to reboot again.

There are BIOS settings for PIO mode, whatever that is.
0
 
LVL 3

Expert Comment

by:jwleonard1
ID: 13844508
It sounds like you are using one SATA hard drive, two optical drives, and a zip drive.  Please let me know if this is correct.  
I don't see a way to stop that message from showing up, please put the drives back to their original configuration and we will see if we can get the system to recognize the zip drive on PRI_RAID1.

Let me know about the drive config and I will post back how to set up your bios.
0
 

Author Comment

by:realvalue
ID: 13844583
This time the message went by very fast.  All I can add is that it has to do with the 40 pin cable which is connected to the drives not allowing the preformance available from the connection.  Both DVD/CD drives are now identified in device manager as SCSI.  I do not recall that as previously being the case.  I called the zip a scsi when when connected to this connector.

The motherboard manual, under BIOS setup, indicates the option of setting the type of ide device.  It speaks of selecting ARMD for zip drives.  Do we need to do some BIOS work?
0
 
LVL 3

Expert Comment

by:jwleonard1
ID: 13844593
Yes, like I said put the drive back to the way they were and we will set up your bios.  I still need to know your drive configuration.
0
 
LVL 13

Expert Comment

by:Watzman
ID: 13844597

Both the Zip disk and any optical disks are slow enough devices that the data transfer rate is irrelevant.  They are not hard drives, and ATA/33 is fast enough to keep up with the maximum possible rate and not slow you down.  Even taking as an example a DVD, it's about 5 gigaybes (5,000 megabytes) per hour at 1x, there are 3600 seconds in an hour, so reading even a DVD at 1X is less than ONE megabyte per second, whereas ata/33 -- the fastest you can do with a 40 conductor cable -- is 33 megabytes per second.  CD's and Zip disks are a LOT slower than that.  So speed isn't an issue.

However, if you want to install an 80-conductor cable just to get rid of the warning message, there's nothing wrong with that.

[Moving the zip drive off of the Raid port was what I suggested way back at 10:51am]

If you want everything installed, and you only have one [non-raid] IDE port, and the optical drives (CD/DVD) won't work on the raid port, you might need to get a PCI IDE controller card to give you more ports.  Note, some of those cards will not work unless there is a hard drive connected to them (I had a Promise card that could not be used ONLY for a CD-ROM, although it was fine with the CD-ROM as a 2nd device if there was a hard drive as the 1st device).

PIO is "programmed I/O", it's slower and less efficient than DMA (direct memory access).  There are multiple speeds of both PIO and DMA.

0
 

Author Comment

by:realvalue
ID: 13844606
I have one SATA hard drive, two optical drives, a zip drive, and a combo floppy/usb.

I will now reset the cable configuration.
0
 
LVL 3

Expert Comment

by:jwleonard1
ID: 13844752
OK all you should need to do after you reconfigure the drives is go into the BIOS and set the zip drive to ARMD like you mentioned above.  I belive that will fix your problem, also, you will not need to install any drivers.
0
 
LVL 3

Expert Comment

by:jwleonard1
ID: 13844797
While you are in the bios make sure you don't have the ITE 8212F controller set to use RAID.  It is on the advanced tab under onboard devices configuration, make sure it is set to IDE mode.
0
 
LVL 11

Expert Comment

by:huntersvcs
ID: 13844988
Sounds like you used a different version of the software (compiler) for saving the data than you are presently using trying to restore.  I've seen this literally hundreds of times during a project a few years ago.  We ended having to keep all different versions of the IOMEGA software on hand, running on different machines, just to retrieve data.  If you use a different version than the one used originally, it almost always tells you it isn't formatted and you can't access your data.

The newest and latest isn't always the best, especially when it comes to backup software.  Try using the exact same version - it may help.
0
 
LVL 11

Expert Comment

by:huntersvcs
ID: 13845007
Unfortunately, the older versions of IOMEGA's software were not necessarily compatible with XP.  That's probably why you can access the data.  Try hooking up the IOMEGA to a machine with the same OS as previously used, install the same SW used to make the backups, and you might see a difference.

Rick
0
 
LVL 3

Expert Comment

by:jwleonard1
ID: 13845055
huntersvcs, please read the entire thread, he has already had the drive working correctly by connecting it to another IDE channel using the same software.  Therefore it is NOT a software problem, the drive just isn't being detected properly due to his motherboard configuration.

realvalue, keep with our plan, I think it will fix your problem.
0
 
LVL 11

Expert Comment

by:huntersvcs
ID: 13845205
Sorry about that - I missed the one-liner!  I did read the thread, but it's kinda long and I must have just missed it :-(
0
 

Author Comment

by:realvalue
ID: 13845418
The ITE8212F is set to IDE mode.  The zip drive does not now show in the Main bios menu, the only time it has is when we made the switch earlier.  Thus setting it to ARMD is not an apparent possibility.  

The bios search for IDE devices, which takes place at boot and before entry to the bios menu, does find and show the zip present.  However, this does not translate to its recognition in the bios menu.

The current bios menu shows:Primary IDE master and slave as the dvd/cd drives, and the Third IDE master as the hard drive.  The 3rd slave and 4th master/slave show undetected (with the undetected TYPE set to auto).  I have tried setting the undetected ones to ARMD type but that does not work either.

The zip does not show in the boot list or options.
0
 
LVL 3

Expert Comment

by:jwleonard1
ID: 13845783
Try setting the ITE 8212F controller "detecting device time" to standard and see if this helps.  It is on the advanced tab under onboard devices configuration.  See page 4-27 of your manual.
0
 

Author Comment

by:realvalue
ID: 13845846
Thanks, but that I have tried, just a few minutes ago.  The result was a longer detection time, but no other change.

Your persistance is appreciated!
0
 
LVL 3

Expert Comment

by:jwleonard1
ID: 13846354
Well, as persistant as I am, I am out of options anyway.  I am SURE that we have found your problem, it is the fix that eludes me.

One last thing I can think of that we haven't mentioned yet is the jumper setting on the zip drive.  Have you tried all three positions?  If not try them, and lastly try it without the jumper installed at all.

If that doesn't work it could be a bad motherboard, the controller didn't work correctly with your optical drives either since they were detected as SCSI devices.  Depending on where and when you bought it you might want to return it for another of the same model to see if it does the same thing.  If it does the it sounds like a design problem that ASUS needs to fix.

The next best thing that I can think of is to contact ASUS and let them know about the problem, it appears to be a problem with their controller not recognizing the drives properly.  If that doesn't work try a different brand/model of board if it isn't too late to return yours.

If ASUS is unable to help you, you can't return the board, and you really want to get the zip drive working then you might want to try a PCI IDE controller card as mentioned above.  It plugs into a standard PCI slot and provides IDE connections.  The downside is it takes up a PCI slot, increases boot time by a few seconds, and doesn't always work with all drives (hit and miss) which was also mentioned above.

Sorry we didn't get it working!
0
 
LVL 93

Expert Comment

by:nobus
ID: 13848859
i would suggest disconnecting the cd drive, if the burner is the DVD drive; you have little use of it, and with all the devices connected, you can run into power problems too.
0
 

Author Comment

by:realvalue
ID: 13856016
The following is the response to this problem by ASUS:

Zip drives will not work on the PRI_RAID port. Use the optical drives connected to this port, and use a 80 conductor cable (labeled as Hard Drive). As far as them being detected as SCSI, this is how windows detects some drives that are connected to raid controllers in IDE mode.

Best Regards
Aaron
Asus Technical Support
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Finding original email is quite difficult due to their duplicates. From this article, you will come to know why multiple duplicates of same emails appear and how to delete duplicate emails from Outlook securely and instantly while vital emails remai…
A look at what happened in the Verizon cloud breach.
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…
Despite its rising prevalence in the business world, "the cloud" is still misunderstood. Some companies still believe common misconceptions about lack of security in cloud solutions and many misuses of cloud storage options still occur every day. …
Suggested Courses
Course of the Month20 days, 9 hours left to enroll

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question