Duplex mismatch - Switch changes port speed

Posted on 2005-04-22
Last Modified: 2008-03-04
I have a Cisco 2950 switch.  I have a port duplex mismatch between a port on the switch and a server.  The NIC in the
server is an Intel Pro/1000 CT Gigabyte card.  It has the latest drivers dated 11/22/04.   The port on the switch
is set to 100/Full.  This NIC doesn't like that setting and will only run, if I set both the port and NIC to auto.

When I set the port on the switch to Auto, it will run for a couple of days, but eventually will set itself back
to 100/full.  Has anyone ever heard of this?  

Thank  you
Question by:keicy01
    LVL 79

    Expert Comment

    Here's the thing ...
    If you set the server NIC to 100/full, then you have to set the switchport to 100/full
    If you leave the server NIC at auto, then the switchport must be on auto
    If you set the switchport to 100/full, then you must set the server to 100/full

    If it works at auto/auto, then what is the issue?


    Author Comment

    It works at auto/auto but the switch port changes back to 100/full leaving the NIC at auto which causes the mismatch.
    I found a small blurb about some switches not able to negotiate link speed with the Intel Pro/1000 CT card.  I swapped out the card and that seemed to work.
    LVL 79

    Accepted Solution

    If you're looking at the switchport using "show interface" it will show whatever speed/duplex it has negotiated.
    If you look at the config with "show config" and you should not see the speed/duplex settings. If you see them in the config as below, then I would be concerned because a Cisco device can't automagically configure itself..

      interface fast 0/4
       speed 100


    FastEthernet0/2 is up, line protocol is up (connected)
      Hardware is Fast Ethernet, address is 000e.842b.ea82 (bia 000e.842b.ea82)
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      Full-duplex, 100Mb/s, media type is 100BaseTX  <=== "negotiated speed/duplex"

    There is no speed/duplex setting in the configuration from 'show config'

    interface FastEthernet0/2
     switchport mode access
     switchport port-security
     switchport port-security aging time 2
     switchport port-security violation restrict
     switchport port-security aging type inactivity
     macro description cisco-desktop
     spanning-tree portfast
     spanning-tree bpduguard enable

    Featured Post

    How to run any project with ease

    Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
    - Combine task lists, docs, spreadsheets, and chat in one
    - View and edit from mobile/offline
    - Cut down on emails

    Join & Write a Comment

    Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
    Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

    733 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    23 Experts available now in Live!

    Get 1:1 Help Now