?
Solved

Others can't access my apache web server off of Linksys Router on Port 80

Posted on 2005-04-22
5
Medium Priority
?
479 Views
Last Modified: 2013-12-14
Hi Guru's I really need your Help today!

It seems that outside users aren't seeing my apache web server on port 80 on my Linksys BEFW11S4 4 hub Wireless Router.  What people are getting is a dialog box requesting user name and password to the routers admin page.  So I am believing this is where the holdup is.

Here are some of the details:

I am running a two workstation and laptop  on Roadrunner Cable. Both computers use windows xp pro and have no problem accessing the internet via the router.  Both computers seem to have no problems communicating with each other (after I installed the Netbui protocol).  

Internally Apache web Server seems to work fine on http://localhost:8080 url.

I have no problem accessing the Admin page of the Router.

Roadrunner national level 2 support assures me (today) that they are not blocking port 80.

Even though I am using ZoneAlarm firewall basic it shows no attempts to access the computer in its logs.  As a reality check I've also turned off ZoneAlarm completely and it still doesn't seem to make a difference.

I am now attempting to use port range forwarding of port 80 address 198.168.1.100 in the Linksys Admin Setup.
Doesn't seem to have an effect.

Has anyone solved this issue?
Sure would appreciate some help with this.

Thank you

Ted

0
Comment
Question by:tcalbaz
  • 2
  • 2
5 Comments
 
LVL 14

Expert Comment

by:ckratsch
ID: 13847869
So you intend visitors to your web server to access it on port 8080?  In that case you need to forward as follows:

WAN interface port 80 > localhostIP port 8080

That way, people will hit your outside IP address at port 80, which will get passed to port 8080 on the web server inside.
0
 
LVL 1

Author Comment

by:tcalbaz
ID: 13848469
ckaratsh,
Thanks for responding.  I am not sure where to set the WAN Interface port 80 to Local host IP Port 8080 so please feel free to correct me if I am wrong.

In the Linksys Admin Setup Screems I went ahead and applied changes to the Application and Games Section - Port Forwarding as follows:

Application: Apache
Port Range: Start to End: 80 to 80
Protocol: Both
IP Address: 192.168.1.100
Enable: True

For Application and Gaming - Port Triggering I set the following changes:

Application: HTTP
Ext. Port: 80
TCP: TRUE
UDP: FALSE
Int. Port: 8080
IP Address: 100
Enabled: TRUE

Is there anything else I should change?
Thank you,

Ted
0
 

Expert Comment

by:LyndonJE
ID: 13849773
I don't have any experience with Linksys, however it sounds as thought the Linksys router is listening on port 80 itself. If this is the case I would look to see if there are any settings to choose or disable which interfaces the router admin is available on. If you can disable the router from listening on the WAN interface on port 80, then it may then take note of your port forwarding rules, depending on which takes priority in the first place - port forwarding or router admin?
0
 
LVL 14

Accepted Solution

by:
ckratsch earned 2000 total points
ID: 13850156
I just looked at my own Linksys configuration - and it doesn't appear to allow port forwarding with a port number change.  Your best bet in this case is to have Apache run on port 80 instead of port 8080.  Then you can do away with the port triggering rule.  You've set the port forwarding rule properly already.

And yes, the reason that your users are getting the dialog box to log into the router itself is because it's listening on 8080 on it's WAN interface.  Disable (or at least change the port on) "Remote Management" in your router.  If you do this, you can then make a port forwarding rule for port 8080, just like the other rule you have, and direct users to http://outside:8080 to get to Apache.
0
 
LVL 1

Author Comment

by:tcalbaz
ID: 14019941
sorry for the delayed response.  ckratsch provided the best lead. Thank you all!

Ted
0

Featured Post

NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

    Over the past few years, small business and home owners have become so dependent on internet that a need for redundancy has arisen.    What happens when your small business or home / home office loses its internet connection?  The results c…
Why do some people recommend buying business VoIP from an ISP? What are the benefits to my company? What are the costs?
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …
When cloud platforms entered the scene, users and companies jumped on board to take advantage of the many benefits, like the ability to work and connect with company information from various locations. What many didn't foresee was the increased risk…
Suggested Courses

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question