• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 337
  • Last Modified:

IIS 6.0 / ASP issue

I have an  asp page that displays images that are located in a vitural directory.  This asp page worked spectacularly in IIS 5.0.  I am now using IIS 6.0 and the page loads in the browser, but the images do not display.  An x displays in the place of the pictures, however, if you check the properties of the x it displays the correct path.  Any ideas as to why this is happening?
0
QueenKretee
Asked:
QueenKretee
1 Solution
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Security?

Also, just checking, did you enable ASP in IIS 6.0
0
 
QueenKreteeAuthor Commented:
I have enabled ASP in IIS and I'm pretty sure that my security configurations are correct.
In a netshell, here's what the page does:
Takes a parameter JobNumber
From the JobNumber, the path is determined like "./Photos/"+JobNumber
The number of .jpg files in the directory is counted
A two column wide table is produced according to the number of photos
The photos are displayed in the table

Now, it's able to count the number of photos, create the table correctly, but the photos themselves don't appear in the table.  There are variable numbers of photos in each directory and the table is always produced correctly, yet the photos aren't displayed.  Like I said, this worked perfectly in IIS 5.0.  Any ideas?
0
 
Chris DentPowerShell DeveloperCommented:

You can't use path traversal by default in IIS6 (./Photos...). It will disallow the ".".

I would advise you use correct paths relative to the web root.

If that isn't an option parent paths can be enabled with:

Properties for the Site (IIS Manager)
Home Directory
Configuration (Application)
Options
Enable Parent Paths

But it should be noted that Parent Paths are disabled because they are not secure.

Chris
0
Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

 
planzaCommented:
Did you check the permissions for the image directory? You may have to allow view access to IIS_Anonymous or whatever account is used...
0
 
QueenKreteeAuthor Commented:
Brilliant, planza (yeah, why didn't I come up with that?)  Thank you.  Enjoy the points!
0
 
planzaCommented:
Glad to be able to help. I had fought with something similar a while back...

Thanks for the points.
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now