Adding additional SMTP servers in Windows 2003 Server

Very strange thing going on with Windows 2003 server and the SMTP service. Can't find any info on the web related to my problem.

I setup and installed a Win2003 server with IIS6 in Jan. 2004. When I set it up, I created 4 SMTP servers each having there own IP address. (So a CFMX app can distribute mail across them, seemed to have a performance boost v.s. sending all the mail to the 1 single default SMTP server that IIS gives you.)

Current Problem:
I want to duplicate my setup on another server and have installed another brand new install of Win2003 server with IIS6 and for the life of me cannot setup multiple SMTP servers. The machine has multiple IP addresses bound to it, but when I try to add another SMTP server the second step of the wizard gives a drop down box that does not include any of the additonal IP addresses bound to the machine. So I can't setup additional unique SMTP servers with there own IP addresses. Crazy right! But it gets better.... When I look at the original server that has 4 SMTP servers and is working great, and try to add a 5th, (yes I have an IP available) it does the same thing! Second step of the wizard shows a drop down box with 1 IP address, none of the ones I want to use. When you setup a new IIS instance the wizard lets you type in the IP address, but the SMTP server does not let you.

I think maybe a MS update has screwed up IIS, becuase I swear when I first set this up, I typed in the IP's for the additional SMTP servers, this drop down box thing might be new......

Does anyone have an idea of what the problem is? Can anyone replicate my problem? Go ahead, try and setup your Win2003 server with multiple SMTP servers (not virtuals, but whatever) each with their own IP address.

Who is Participating?
alimuConnect With a Mentor Commented:
sorry this took so long, have been swamped the last couple of weeks.
have been searching around for something that might cause this,  it's possibly a patch or some other software installed..
This particular KB article says the missing IP issue can be caused by installation of Application Centre.
Even if you don't have this installed, there's a possibility that the workaround they use here could get you going again.
They add addresses to the hosts file to get them displayed again and then you can go about your business pretty much..
give it a try anyway and let me know how you go.
regardless of whether this is a web or smtp service (they're both part of IIS), you should be getting all IP addresses bound to the server's TCPIP in that dropdown box.  You shouldn't have to type them in.  
IIS will let you type in non-bound IP so that you can setup load balancing, however any non-bound IPs should be ignored by the system.

Can you try a couple of things for me:
-at cmd prompt do an ipconfig /all and check that all your ips are showing up against the enabled adapter/s
-try creating a new website and see if the IP addresses you are looking for are available in the dropdown box for that. (trying to determine if it's an IIS-wide problem).
-check your event logs to see if you are getting any IP conflict messages when the server boots up.

At first glance this looks like a problem with your TCP/IP bindings - either corruption or IP conflicts with something else on your network.
If it's not an IP conflict issue, you could try re-applying your TCP/IP bindings and rebooting.

Let me know how you go,
Hi Brian,
can you please update me on where you're at with this / how you went answering my questions in my last post?
I'd like to help but I need your feedback to do that
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

brian_summitAuthor Commented:
Hi alimu,

I ran an ipconfig /all and all the IP's are showing up against the enabled adapter.
When creating a new website, the IP's are NOT available, but I can type them in and they work. Can't type them in for SMTP.
There are no IP conflicts.
I am having this problem on an older Win2003 server and a brand new install.
Could it have to do with the IP scheme I am using? An example IP and mask I'm using would be /
Thanks for your help.

Hi Brian - how did you go? any luck with the workaround?
brian_summitAuthor Commented:
Adding the addresses to the host file did the trick. Works great, thanks!

good news - thanks for the points Brian.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.