?
Solved

Spontaneous Re-boot

Posted on 2005-04-22
39
Medium Priority
?
8,858 Views
Last Modified: 2008-01-09
I'm running WXP w/SP2, AMD 2000 w/512mg ram.  I just did a clean install and have been experiencing spontaneous reboots. I have read that it most likely is a bad power supply.  I have a 400w ps but its about 2 yrs old. Is there anything else I can check before I purchase another ps?  Thanx, taz
0
Comment
Question by:tazman405
  • 20
  • 10
  • 3
  • +4
39 Comments
 
LVL 3

Expert Comment

by:jwleonard1
ID: 13847828
I am assuming that you didn't have these spontaneous reboots before you reinstalled, if that is wrong please let me know.

Did you reformat and reinstall windows to a blank disc or did you just install over the old copy?

I would look at all of the drivers first:  check the device manager for items that drivers are not properly installed for.  Look for new drivers for all of your hardware by checking the manufactures hardware; start with the motherboard, then the video card, and lastly all remaining hardware.  Also, make sure you have the most current bios for your motherboard.

If that doesn't fix it download the ultimate boot cd and use the tools on it to test your memory and hard drive.
http://ubcd.sourceforge.net/download.html
0
 
LVL 10

Expert Comment

by:tfjeff
ID: 13848343
spontaneous reboots are generally caused by a bad power supply or bad memory.  Swap with a known good power supply from a friends machine if you can, it may be easier to swap with known good memory first though.
0
 
LVL 4

Expert Comment

by:Diane258
ID: 13849196
Before you go swaping out power supplies and all that, update ALL the drivers, esp the motherboard drivers.
0
Reclaim your office - Try the MB 660 headset now!

High level of background noise often makes it difficult for employees to concentrate fully on their jobs – or to communicate clearly on calls. The MB 660 headset helps you create a disruption free workspace.  

 
LVL 1

Expert Comment

by:Gir19
ID: 13849365
If you want to be able to try to determine what is causing the reboots in windows xp. there is an option so that you will get the blue screen that gives you information about what might be causing the problem. to set your system to do this follow the following instructions.

Go to the CONTROL PANEL
Double click SYSTEM
Go to the tab labeled ADVANCED
click the button labeled SETTING under Startup and Recovery
Then uncheck the box that is labeled Automatically Restart

Once you reboot the system this setting will be in effect and wait for the next time windows crashes and in the first line it should give you a vague idea of what is causing the crashes. Try to write down the first line and post it here.
0
 
LVL 9

Expert Comment

by:MrAruba
ID: 13849729
reboots can also be caused by overheating. check if your cpu fan spins.
goto www.memtest.org and download the memory test utility.
0
 

Author Comment

by:tazman405
ID: 13850799
jwleonard1;
Diane258:
MrAruba;
No spon. reb. before re-install.  Complete format w/ntfs.  Upgraded mobo, video drivers. Did not flash bios for fear of doing it wrong and really screwing thins up. Fans and mem. ok.  No reboots so far and have been up and running a couple of hours.
Gir19;
No blue screens for 2-3 days. Previous bsod were as follows:
DRIVER_IRQL_NOT_LESS_OR_EQUAL
BAD_POOL_CALLER
IRQL_NOT_LESS_OR_EQUAL (3 TIMES).
Did as you asked and disabled auto restart.
Thanx, taz


0
 
LVL 1

Expert Comment

by:Gir19
ID: 13851077
If you no longer get reboots, and the bsod is all you get from now on it just means that there is a problem within windows that needs to be fixed, it is not your power supply. But if it does reboot without showing the blue screen then there is still a chance it could be your power.  Now as for the bsod's you have recieved say DRIVER_IRQL_NOT_LESS_OR_EQUAL tells me that there is a problem with one of your drivers and it's irq setting which just might be that it is conflicting with another driver or has been corrupted, as to which one I cannot say, did it give you a name of a dll file if so that is a good lead to the troublesome driver.
0
 
LVL 3

Expert Comment

by:jwleonard1
ID: 13851113
Need you to clarify a few things:

When you posted originally you obviously were having the problem, but are you saying you had already udated the MB and video card drivers or that you did that after I suggested it in my first post?

It is fine that you didn't flash the BIOS, that is most likely not the cause since you didn't have problems before you reinstalled.  At the time I posted that I didn't know for sure if you had the problem before reinstall.  It is great that you know you limits!

Next, you said "No reboots so far and have been up and running a couple of hours", I am assuming that is after you upgraded the drivers.  Is that correct.

Then, in your response to Gir19 you said "no blue screens for 2-3 days".  Does this mean you had already set this to show the BSOD instead of rebooting?  Then if so did you really not have any for 2-3 days?

Lastly, how long was it (on average) between crashes, and at this point how long has it been since it last crashed?
0
 

Author Comment

by:tazman405
ID: 13851243
jwleonard1:
Gir19
I updated after your first post. I did not have the problem before the re-install. I did not disable re-boot until this morning. I just had another bsod after about 4hrs. Indication was again IRQL_NOT_LESS_OR_EQUAL.  I was getting bsod or re-boot 30min to 1hr during up time after re-install. I didn't notice any reference to a dll but will make sure next time.  I had no reason to re-install other than I like to do it about once a year for a fresh start. Thanx, taz
0
 
LVL 12

Expert Comment

by:GinEric
ID: 13851504
Driver IRQ Not Less Or Equal means two things, first, an IRQ collision, secondly, it was brought on by BIOS and Plug and Play.

While Microsoft has a lot of solutions for IRQL > [yes, it's easier to say it as IRQ Greater Than, meaning the same thing logically as IRQ Not Less Or Equal], it really means that the IRQ in PnP [greater than 15] did not match the PnP IRQ it was expecting.

Read this:

http://www.microsoft.com/resources/documentation/Windows/XP/all/reskit/en-us/Default.asp?url=/resources/documentation/Windows/XP/all/reskit/en-us/prmd_stp_ottj.asp

find your stop error code in the list on the left, and click on "Stop Message Checklist"

It can occur for many reasons, not the least of which is not reserving certain IRQ's in BIOS for certain devices, thus taking them away from Plug and Play, using BIOS cache, when Windows also wants to use it for something else, and the fact that Plug and Play was just not an adequate solution for the need for more real IRQ's.

Meanwhile, I will continue to hound Intel, AMD, Microsoft, and others, until they redesign the IRQ buss to be the full witdth of the processor buss, currently 64 bits.

They have 10,000 solutions for the same problem that an engineer solves with one simple solution, usually after their bad hardware and software have failed miserably for many years.
0
 
LVL 3

Expert Comment

by:jwleonard1
ID: 13851798
We need the rest of the error to help you figure out which driver is causing the problem. The next time it happens, please write down all of the codes that show up on the screen.  You could also take a picture of the screen and post it on a site like yahoo photos, then post a link to it on here so we can look at it.
0
 

Author Comment

by:tazman405
ID: 13881835
I apologise for not posting sooner.  I had a good 24hrs with no problem and it hit again.  Same irql not less or equal with Ox0000000A.  I reformatted again and did not "force" install any drivers e.g. "These drivers amy make WXP unstable. had no problems until last night. BSOD this time was PFN_LIST_ CORRUPT_ w/hex no. 0x0000004E. I have also had two instances where the video went blank therefore could not see bsod.  I ran  SiSoft Sandra and it sait my system, cpu etc., was a little warm but checked my BIOS readings and temps were well within limits. Again, sorry for the delay but I thought Iwe might have had it whipped. Thanx, taz

PS: I run AVG antivirus, registry first aid, and diskeeper religiously for the last 2 yrs.
0
 

Author Comment

by:tazman405
ID: 13881882
As a further of mine a few mins. ago, when I did the first format/re-reinstall I loaded my video drivers from the cd that came with my new vid-card (nvidia 5200) which I have had for 3 months was the first time WXP said anything about the drivers may not be compatable and to let windows install them. The first time I ignored the warning and went ahead, the last time I didn't install them and let wxp do its thing. Same results. They want to control every thing!!! Why does this not surprise me!!!
0
 
LVL 12

Expert Comment

by:GinEric
ID: 13882896
A couple of sources; it looks like BIOS, or RAM, both, overclocking, or using caching in BIOS:

http://www.mcse.ms/archive55-2003-11-127070.html

Page Frame Number List is apparently involved, and gets corrupted by either the drivers or just poor memory performance.  If it worked before you did a clean reinstall, then something in the new install is inadequate.

People are reporting such problems with SP2.

One of the people did delete the page file, then put it back I imagine, which cleans up the page file, as scandisk and defrag, unfortunately, do not clean this area regularly.  Once corrupt, it stays corrupt, and that is where the Page Number Frame List is, I believe.

Although 512meg RAM shouldn't be a problem, the newer processor seem to be having lots of timing and addressing problems. Having to do with, actually, working too fast.  One patch is in to add 7 no ops to one driver to slow it down for at least one microprocessor, and another for indirect addressing in vector mode. These are new concepts for programmers and have to be considered on new machines.

You also need to state a full Error Report, such as : STOP (0x0000008F,,0x00433132,0x00073132,0x000000000)

This one almost gets down to the root cause, which is Microsoft's "misunderstanding" of indirect addressing, in addition to the bad concepts incorporated into MFT, pagefile, and general memory management in Windows.  Which points to the underflow in multithreading processes of a stack with no timing, bottom, top, or limit.  Which is the root cause of all exploits currently trying to exploit memory and code inadequacies.  If you decrement your pointers too fast, while the driver has the pages locked, then they eventually underflow.  This results in a BSOD, rather than a simple report, which would have sufficed and worked much better.  Multithreading of lockable memory works within limits; no routine should be indexing a locked memory without first checking to see if its pointers are going to underflow.

Yeah, they want to control everything, however, the shortcoming is that they, none of them, have enough education, experience, and knowledge to even attempt to do so.  Check this article out:

http://www.osronline.com/article.cfm?id=334

by someone who seems to know a lot more than Redmond employees.
0
 

Author Comment

by:tazman405
ID: 13890872
GinEric:

This is the second time to send this reply as I just had another bsod "not less or equal. so forgive the misspellins as I just want to get this off. Stop codes as follows:
0x0000000A (0xFFFDFFFF, 0x00000002, 0x00000000, 0x804E3F5A)
I have SDRAM 2100, woul faster RAM i.e 2700 or greater cure the problem?  I upgraded mobo drivers to no avail, would newer mobo cure the problem? Finally, I never had trouble with WXP original, should I go back to it. I'm about ready for anything. Need to get this off before I crash again. If the past holds up I should not have another bsod for a couple of hrs.  thanx, taz
0
 

Author Comment

by:tazman405
ID: 13891282
GinEric:
Second time on this post too.    bsod:
Problem caused by following file:  PartMgr.sys
PAGE_FAULT_IN_NON_PAGED_AREA
sTOP:  0X00000050 (0xE9766547, 0x00000001, 0xF87BE348, 0xF87BE348, 0x00000002)
PartMgr.sys says Address F87BE348 base at F87BE000 Date stamp3b7dc5a.

Playing Quake 3 at the time.  taz
0
 

Author Comment

by:tazman405
ID: 13891294
Have increased points to 300.
0
 
LVL 12

Expert Comment

by:GinEric
ID: 13892026
Page Fault in non-paged area:

STOP:  0X00000050 (
0xE9766547, Memory Address E9766547 [3,916,850,503d]
0x00000001, Was during a Write
0xF87BE348, Memory Address of Instruction that accessed 0xE9766547
0xF87BE348, reserved
0x00000002  reserved
)

This is the same old page fault that used to be General Protection Fault [GPF], since Windows 3.1

You hadn't said you were playing Quake before, which makes a big difference.  PartMgr.sys says it
was while routining Partition Manger system file driver, inherent intrinsic system routine.

Split your page file across hard drives to improve performance.  Smaller pagefile on OS drive and partition, I should think no more than 64 meg, and RAM size times 1.5 distributed across other hard drives.  This speeds up performance by using multiple disk accesses during paging.  Undo "allow Microsoft to manage my memory."

"*" is Logical AND
"+" is Logical OR

First dilemna: IRQ [Not Less Than OR Equal To] ::=  -[(IRQ-X)+(IRQ*X)] gets -[(15-X)+(15*X)] gets -15+15 - 15*15 gets 0
Second dilemna:IRQ Not[Less Than] OR [Equal To]  ::=  -(IRQ-X)+(IRQ*X) gets -(15-X)+(15*X)] gets -0-0 gets -0 gets true.

The difference is extremely subtle and has to do with exactly how a binary compare actually works on a computer hardware "adder."  

Between this and IRQ> there is a difference.

As X-X is always negative [true] if X is 15 or less because of the use of subtraction, instead of compare.  Compare uses Logical Operators and the result of a Logical Operator is true when the sign bit is on, or, negative, even if the number is zero.  Because both the compiler and the programmer are not fully aware of the exact way binary and logical math are worked out in hardware architecture, that is, the way its design actually works at the lowest level of registers, adders, etc., they are not always adept at generating the proper operators or micro operators to properly use code that works the way they expect it to.

This is then compounded by indexing and indirect addressing, which even Intel and AMD hardly understand, let alone the programmers, and further by vectoring.  This is the Vector anomally about the point zero in multidimensional space.

Like "the square root of minus one" problem that it is, a vector has 2(n-1) true answers, and 1 false answer.  For two dimensions, three answers will be true and only one false.  For three dimensions, it will have 5 true answers and still only one false answer.

These are Directional Vectors.  They represent indirect addressing.  In three dimensional address vectoring, there is only one zero along the line of the original direction, there are five others that are not along the line of the original direction and are therefore not zero.  Indirect Addressing requires three points, a pointer to an index base that yields an operand.  If the pointer is incremented, then indexes the base, the operand is fetched properly.  But if, as in some software and some processors the index base is incremented, the wrong operand will be fetched.  This can also be chained by having a pointer which gets another pointer which then gets the index base which then tries to get the operand.  You can see the problem here, what gets incremented in such a vector array?  This is Intel's indirect addressing and vector mode problem, evidenced by mostly Microsoft programming which does not account for the array indexes properly.

So, you fetch the wrong address and get a Page Fault.

And if that's not enough, it gets a lot more complicated than this.  Was address 0xF87BE348 the result of using index base F87BE000 to get F87BE348 or was F87BE348 supposed to be indexed to get 0xE9766547 through chaining?  And why then, apparently, does " 0xF87BE348, 0xF87BE348," appear to be a call to its own code address?

Specifically, Parameter 3 above is "If not zero, the instruction address that referenced the address in parameter 0x00000001."

From:

http://www.microsoft.com/resources/documentation/Windows/XP/all/reskit/en-us/Default.asp?url=/resources/documentation/Windows/XP/all/reskit/en-us/prmd_stp_ccgm.asp

If you did as below:

"No spon. reb. before re-install.  Complete format w/ntfs.  Upgraded mobo, video drivers. Did not flash bios for fear of doing it wrong and really screwing thins up. Fans and mem. ok.  No reboots so far and have been up and running a couple of hours."

and upgraded the motherboard, how did you upgrade the motherboard?  New motherboard?  New Processor?

Can you set your basic dump to 64k?  If you can, you will find a .dmp file after the BSOD.  That can be fully used to completely debug the problem.  I've been waiting to get my hands on one of these dumps as I have the full 1 gig debugger with all Symbols, which should exactly pinpoint the problem.

I'll take a look at it if it's not too big.  No sense in debugging a full memory dump of like 1 gig, or even as little as 32 meg, although 2-4 meg would also be okay.
0
 

Author Comment

by:tazman405
ID: 13899032
GinEric:
I set the page file on my OS physical drive for 64 to 100 max.  My data physical drive I set for 768 with 1536 max.  I have been up and running for about 6 hrs and no bsod yet.  Could this setting have caused my othe problems?
I upgraded my mobo by downloading updated drivers from the gigabyte web site and installed them.  I tried to include the .dmp files but this program will not copy and paste a file.  I can send them to an email address if you like. One from April 25 and last night, 28th, wouldn't copy here. One is 88k and the other is 92k.
I'm going to fire up Quake in a min. for another test run.  Will send you another post later this evening.  Thanx so much, taz
0
 

Author Comment

by:tazman405
ID: 13899632
Here we go again...up all evening, played Quake for over an hour, no problem.  Started to re-install Nero 6 and POOF..BSOD with the following:
(no XXX_XXX_XXX notation)
Stop:  0x0000008E (0xC0000005, 0xBF802221, 0XF5864C04, 0X00000000)
win32k.sys-Address BF802221 base at BF800000, Date Stamp 41107f7a

Will try Nero install again.  taz
0
 

Author Comment

by:tazman405
ID: 13899715
Nero re-installed the second time without a hitch.........go figure........taz
0
 
LVL 10

Expert Comment

by:tfjeff
ID: 13899751
have you run the microsoft memory diagnostics yet?
if not, I advise doing this:
http://oca.microsoft.com/en/windiag.asp
0
 
LVL 12

Expert Comment

by:GinEric
ID: 13900083
Before going any further, the best pagefile is RAM size to 1.5XRAM size, in your case, 512 meg to 768 meg.  Although I would most likely set it to something like 550 meg to 768 meg.  Why?  Well, enough megs to hold the complete RAM and some OS to the size of a CDR burn image.

I have run with pagefiles as low as 2 meg, but now generally set it to something like 12 meg or 32 meg on the primary partition of the boot disk, and divide up the rest over small partitions at the end of the ohter physcial hard drives on the system.  Why?  Again, multiple disk access is faster for pagefile and paging for OS code from boot partition can be done simultaneous with other program paging, especially if other programs run on other physical disks.  Games are installed to disks other than the boot disk.  This also keeps the games from writing to the boot drive.

Here's a close one; I'm betting that your video is nvidia

http://support.microsoft.com/default.aspx?scid=kb;en-us;325730

Almost exact "bug-o" :

http://support.microsoft.com/default.aspx?scid=kb;en-us;330187
"This issue is caused by a code problem in GDI+ (the graphics device interface for Windows XP)."

My,that sure sounds like GTK+ from Linux!  

Note differences and similarities:

Stop:  
0x0000008E  - Exception
(
0xC0000005, - Access Denied
0xBF802221, - Memory Address of Instruction that called 0XF5864C04
0XF5864C04, - Protected Memory Address that was called
0X00000000  - Was called before lock.
)

or that is a close approximation.  Microsoft does not yet have their error database organized properly.

and http://support.microsoft.com/default.aspx?scid=kb;en-us;233482
"This problem occurs because there is a synchronization problem in the kernel mode Win32 subsystem (Win32k.sys). When attempting to realize a GDI palette, a lock protecting a list of device contexts is being released too early."

Basically, the hardware was faster than the Win32 subsystem software.  You obviously turned your head to fast in Quake and Windows broke your neck for being such a great grunt!  Seriously, After years of blaming everything on RAM, even Microsoft is beginning to see their Operating Systems are lacking in keeping up with the speed and method of multithreading, look-ahead logic and processing, to which even Intel admits its partner is baffled by the engineering design in an area where neither of them has hired a fully competent design engineer.  Ah, the price of not paying the best engineers what they demand!  That, and not being able to pick the truly best, rather, depending on some PhD that has no actual design credentials with such innovations.

They suggest your win32k.sys or one of your drivers is corrupt of erroneous.  Most likely their driver, as .sys endings don't make very good drivers anyway.

Nero has had this problem before too.

Oh boy, they are now to attempt a real 64-bit Operating System on a 64-bit microprocessor that even the manufacturer, Intel, does not really know how 64-bit systems work.

This should be fun over the next ten years or so.

I think both totally missed the bus [literally and figuratively] on multithreading in pre-processing and look-ahead logic timing.

If Quake task A is threaded, but arrives after task B because of no "time queue," then the results of A and B on the stack will be reversed as B, A, and the process will fail.  This all has to do with really esoteric concepts in indirect addressing and vector mode processing, which Intel admits it has a problem with, and simply boils down to a timing "race condition" in the hardware and software.

In other words, your PC was too fast.

You know, with all of this new esoteric stuff, no program runs the exact same way twice.  Which is why one install fails while a subsequent one may succeed.  It is also why Quake may run for two hours one time, and five minutes the next.

This is so far beyond their theory and design, I don't think they'll "get it."

And, Taz, the name fits!

Bugs.
 

0
 

Author Comment

by:tazman405
ID: 13901155
I set the OS drive to 12 to 32megs; second drive to 550-768; downloaded and installed mobo drivers and vidio drivers. Will update later today.
0
 

Author Comment

by:tazman405
ID: 13902000
I downloaded the mem test and ran it and memory is OK.  Will run the extended test when I go to bed tonight.
I left quake up between levels, went to run errands for about 3hrs and when I returned I had a BSOD with the "not less or equal" error with following:

Stop:  0x000000D1 (0x00000000, 0x00000002, 0x00000000, 0x00000000)

Thanx, taz
0
 

Author Comment

by:tazman405
ID: 13902387
Same situation as last post and same stop codes, Quake up but idle.
0
 

Author Comment

by:tazman405
ID: 13903470
Ran "Extended" mem test and all checked OK....no errors....
0
 
LVL 12

Expert Comment

by:GinEric
ID: 13909160
I would make the OS drive maybe 32 or 64 meg to 96 meg, just for good measure, just do that and slightly better than 512-768 total will increase as well, not a big deal, but recommended.  Overshoot, top end should be around 800 meg.

The question is, what happens after a few hours of being idle?  Does something poll the program?  Or, does something write into its cache area by mistake?  See if you can find out specifics about where Quake keeps its memory stuff, code and cache.  It looks like some driver, perhaps video, is writing to wrong area.

These problems are not easily solved.

Stop:  
 0x000000D1  - DRIVER_IRQL_NOT_LESS_OR_EQUAL
(0x00000000, - Memory referenced
 0x00000002, - IRQL at time of reference
 0x00000000, - Type of access read operation
 0x00000000  - Address that referenced memory
)

I think I have them right from:

http://www.microsoft.com/resources/documentation/Windows/XP/all/reskit/en-us/Default.asp?url=/resources/documentation/Windows/XP/all/reskit/en-us/prmd_stp_ccgm.asp

It makes sense that it would be the redirected IRQ from 9 to 2 on the Programmable Interrupt Controller.  And it seems to indicate that the interrupt got there before the IO Port Addressing did.  This could be the same problem Intel is talking about with indirect addressing.  Basically, a race condition by the driver.  They suggest the driver programmers put
7 no ops before the call.

A dump of it, 64KB dump [minidump] will identify the offending driver.  Dumps can be analyzed here:

ftp://guest@musics.com/uploads/dumps/

by uploading them.

0
 

Author Comment

by:tazman405
ID: 13914612
I am not experienced at ftp's. I downloaded a couple to try out but couldn't connect to your server for some reason. will try again tomorrow.
I have had the rig up since my last post (sat.) and have had no bsod. Used Quake extensively and no problems. I installed Doom 3 last night, didn't play but installed w/o a hitch. Go figure...I will keep trying to connect with you ftp site and let you know at first opportunity. Will also try to find out about Quakes cache, etc.  Thanx, taz
0
 
LVL 12

Expert Comment

by:GinEric
ID: 13915336
Just click on the link.  It should take any browser right to the site and directory.  You shouldn't
really need a downloaded ftp program.

There is no password, so if you use ftp it would be:

ftp Musics.com

login as guest
no passowrd [just hit return]

cd uploads
cd dumps

and just use ? to get commands.  use

help put

to find out how to upload a file.
0
 

Author Comment

by:tazman405
ID: 13922742
I believe I got the files to your ftp site.  They are labeled mini042505 thru mini042905.
Still no more BSOD's.  Thanx, taz
0
 
LVL 12

Expert Comment

by:GinEric
ID: 13924360
I saw them.  Analyzing.  I put them in folder "20050504.taz"

Basically, you have corruption in files or memory.  No doubt about it.

Mini042505-01.dmp.txt :  Probably caused by : memory_corruption ( nt!MiRemoveWsleFromFreeList+369 )
Mini042605-01.dmp.txt :  Probably caused by : hardware ( nt!`string'+0 )
Mini042805-01.dmp.txt :  Probably caused by : win32k.sys ( win32k!NtGdiFlushUserBatch+1b0 )
Mini042805-03.dmp.txt :  Probably caused by : ntoskrnl.exe ( nt!RtlpRunTable+172 )
Mini042805-04.dmp.txt :  Probably caused by : Unknown_Image
Mini042905-01.dmp.txt :  Probably caused by : win32k.sys ( win32k!xxxReadPostMessage+5e )

Three or four files you uploaded were themselves corrupt, and therefore, un-debugable.

Notice that I have put the date in order YYYYMMDD, the correct way for indexing chronologically, and
added your moniker "taz"

YYYYMMDD indexes properly, something most programmers have forgotten how to do, and, it avoids yet
another Y2K problem at least until the year 10,000

Could the game be overclocking your processor?

Try this, a kernel dump.  These are larger, but not full memory.  
My Computer | Properties | Advanced | Startup and Recovery | Settings
and in Write debugging information select Kernel Memory Dump

This will give me the complete stack with all calls and show where the error came from, Quake, NT,
or memory or hardware.

Only need one or two of these, hopefully, they will not be corrupt themselves.

Memory Addresses near 0x80nnnnnn seem to fail consitently.

These are red, bold, italic, and underlined in report:

ftp://guest@musics.com/uploads/dumps/20050504.taz/20050504_Taz_reports.html

Kernel are modules in red, bold.

0
 

Author Comment

by:tazman405
ID: 13931599
I did the Kernal Memory Dump as you suggested and couldn't find the .DMP files. I did a search on .dmp and %SystemRoot%MEMORY.DMP (listed as Dump File below the Write menu). All I came up with in the search was the minidump files I sent you. I searched all drives. Am I missing something?  Thanx again, taz
0
 
LVL 12

Accepted Solution

by:
GinEric earned 1200 total points
ID: 13931767
Not that I can see, like I said, it may not have been able to build it, hung up.  Your system is spitting out memory errors all over the place, if you look at the dumps.  It will be the date and size of the file that identifies it as a kernel dump, bigger than 64KB.

I would do a chkdsk, scandisk, and full defrag.

Other than that, memory cards may be ill seated, or just time worn with film or O2 build up and may need to be reseated.  There are creatures that are microscopic that like the heat in computers, they produce build ups and can easily get between lands of memory chips and connectors.  The proper cleaning of lands [gold tabs on edge connectors of memory chip cards, aka 'sticks'] is with methyl ethyl alcohol [pure alcohol, 200 proof].  Hospitals carry this stuff, some pharmacies do too.

The tabs should be gold, not just gold plated where the copper can scratch through, for top of the line memory and motherboards for that matter.

Silver is a better conductor, but it tarnishes, which is why it isn't used that much anymore.  Gold is "Augmentum" or always bright, as in clean and shiney.  It doesn't tarnish.  Which is why it's more expensive.

The memory problem could be the RAM or the disk cache, which is why I suggested cleaning up the disk.

0
 

Author Comment

by:tazman405
ID: 13954781
GinEric;  I have had no problems for 8 days so all of your advice must have somehow corrected my problem.  It seemed to disappear almost as suddenly as it appeared.  I never had a problem with the "plain vanilla" WXP.  So the stories about SP@ were not unfounded.  I want to thank you for your in-depth help and patience.  Best regards,  taz
0
 

Author Comment

by:tazman405
ID: 13954786
"SP2"
0
 
LVL 12

Expert Comment

by:GinEric
ID: 13954954
Thank you tazman405

Just one question: did you redo pagefile, then use chkdsk, scandisk, and defrag?  Or what did you do?
0
 

Author Comment

by:tazman405
ID: 13956095
GinEric:  All of the above ;-)  taz
0
 
LVL 12

Expert Comment

by:GinEric
ID: 13957578
Okay.  What I think was happening was a simple disk caching problem, perhaps with a few corrupt files on disk.  Once cleaned up, XP SP2 most likely did a restore point and then rewrote the flakey files to disk.  Windows has a few peculiarities in that it looks to see if a file has already been cached in the pagefile and if it has it uses that copy without ever rewriting it, sort of a read only copy.  The whole process of resizing the pagefile, chkdisk, scandisk, and defrag forces a rewrite of files, including some system files.  Therefore, the fresh copy overwrites the bad one, but usually to a different area on disk.

Which is why disk should be periodically cleaned up this way, manually.

Thanks again tazman405

Bookmarked for reference.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This is about my first experience with programming Arduino.
New style of hardware planning for Microsoft Exchange server.
Integration Management Part 2
Whether it be Exchange Server Crash Issues, Dirty Shutdown Errors or Failed to mount error, Stellar Phoenix Mailbox Exchange Recovery has always got your back. With the help of its easy to understand user interface and 3 simple steps recovery proced…
Suggested Courses

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question