?
Solved

Please help me with this pix

Posted on 2005-04-23
4
Medium Priority
?
438 Views
Last Modified: 2013-11-16
I know very little but am trying to add a subnet to this pix.


I have 10meg point to point from remote location connected to a cisco 2600 with ip address of 10.1.3.1/24
From 10.1.3.1 to switch
From switch to pix intf4 ethernet4 assign ip address 10.1.3.2/24
set default route on 2600 to 10.1.3.2

Thats pretty much all I've got. Will the 10.1.3 network be able to reach internet after connecting to ethernet4? Do I open firewall to allow traffic out from ethernet4 to outside? Do I add 10.1.3 network to currently configured access-list?

I still have to allow 10.1.3 access to vpn's but if I can just open to internet then I will tackle the next problem.

Thanks for any help......I'm totally lost with this...........
Donnie
Here is cofig from pix.......................................


: Saved
: Written by enable_15 at 18:12:00.867 UTC Wed Mar 2 2005
PIX Version 6.3(1)
interface ethernet0 100full
interface ethernet1 auto
interface ethernet2 auto
interface ethernet3 auto
interface ethernet4 auto shutdown
interface ethernet5 auto shutdown
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 moh security50
nameif ethernet3 dmz security50
nameif ethernet4 intf4 security8
nameif ethernet5 intf5 security10
enable password QNthbvjytSRLs8qa encrypted
passwd QNthbvjytSRLs8qa encrypted
hostname MA05
domain-name domainname.com
fixup protocol ftp 21
fixup protocol h323 h225 1620
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
<--- More --->
               
 fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
access-list 110 permit icmp any any
access-list 110 permit tcp any host 61.189.198.212 eq smtp
access-list 110 permit tcp any host 61.189.198.212 eq www
access-list 110 permit tcp any host 61.189.198.212 eq pop3
access-list 110 permit tcp any host 61.189.198.214 eq ftp
access-list 110 permit tcp any host 61.189.198.214 eq www
access-list 110 permit tcp any host 61.189.198.214 eq 3389
access-list 110 permit tcp any host 61.189.198.215 eq www
access-list 110 permit tcp any host 61.189.198.219 eq citrix-ica
access-list 110 permit tcp any host 61.189.198.219 eq 1604
access-list 110 permit tcp any host 61.189.198.216 eq ftp
access-list 110 permit tcp any host 61.189.198.216 eq www
access-list 110 permit tcp any host 61.189.198.213 eq ssh
access-list 110 permit tcp any host 61.189.198.213 eq www
access-list 110 permit tcp any host 61.189.198.217 eq ftp
access-list 110 permit tcp any host 61.189.198.217 eq www
<--- More --->
               
 access-list 110 permit tcp any host 61.189.198.217 eq 3389
access-list 110 permit udp any host 61.189.198.218 eq domain
access-list 110 permit tcp any host 61.189.198.218 eq domain
access-list 110 permit tcp any host 61.189.198.220 eq www
access-list 110 permit tcp any host 61.189.198.220 eq https
access-list 110 permit tcp any host 61.189.198.214 eq https
access-list 110 permit tcp any host 61.189.198.220 eq 8080
access-list 110 permit tcp any host 61.189.198.214 eq ssh
access-list 110 permit tcp any host 61.189.198.214 eq 1433
access-list 110 permit tcp any host 61.189.198.215 eq domain
access-list 110 permit tcp any host 61.189.198.215 eq smtp
access-list 110 permit tcp any host 61.189.198.215 eq pop3
access-list 120 permit icmp any any
access-list 120 permit ip any any
access-list 120 permit tcp any any
access-list 120 permit udp any any
access-list 150 permit ip 10.1.1.0 255.255.255.0 162.13.229.0 255.255.255.0
access-list 150 permit ip 10.1.1.0 255.255.255.0 208.232.113.0 255.255.255.0
access-list 150 permit ip 10.1.1.0 255.255.255.0 208.232.115.0 255.255.255.0
access-list 150 permit ip host 192.168.4.1 208.232.113.0 255.255.255.0
access-list 150 permit ip 10.1.1.0 255.255.255.0 162.13.248.0 255.255.255.0
access-list 150 permit ip 10.1.1.0 255.255.255.0 162.13.249.0 255.255.255.0
access-list nonat permit ip 10.1.1.0 255.255.255.0 162.13.229.0 255.255.255.0
access-list nonat permit ip 10.1.1.0 255.255.255.0 208.232.113.0 255.255.255.0
<--- More --->
               
 access-list nonat permit ip 10.1.1.0 255.255.255.0 208.232.115.0 255.255.255.0
access-list nonat permit ip host 192.168.4.1 208.232.113.0 255.255.255.0
access-list nonat permit ip 10.1.1.0 255.255.255.0 162.13.249.0 255.255.255.0
access-list nonat permit ip 10.1.1.0 255.255.255.0 162.13.248.0 255.255.255.0
access-list nonat permit ip 162.12.0.0 255.255.0.0 192.168.254.0 255.255.255.0
access-list nonat permit ip 10.0.0.0 255.0.0.0 192.168.254.0 255.255.255.0
access-list nonat permit ip 192.168.254.0 255.255.255.0 10.0.0.0 255.0.0.0
access-list nonat permit ip 192.168.254.0 255.255.255.0 162.12.0.0 255.255.0.0
access-list nonat permit ip 192.168.254.0 255.255.255.0 192.168.4.0 255.255.255.0
access-list nonat permit ip 192.168.4.0 255.255.255.0 192.168.254.0 255.255.255.0
pager lines 24
logging on
logging buffered debugging
logging trap informational
logging host dmz 192.168.4.7
mtu outside 1500
mtu inside 1500
mtu moh 1500
mtu dmz 1500
mtu intf4 1500
mtu intf5 1500
ip address outside 61.189.198.210 255.255.255.240
ip address inside 162.12.0.1 255.255.0.0
ip address moh 192.168.8.2 255.255.255.0
<--- More --->
               
 ip address dmz 192.168.4.1 255.255.255.0
no ip address intf4
no ip address intf5
ip audit info action alarm
ip audit attack action alarm
ip local pool pptp-pool 192.168.254.11-192.168.254.15
no failover
failover timeout 0:00:00
failover poll 15
no failover ip address outside
no failover ip address inside
no failover ip address moh
no failover ip address dmz
no failover ip address intf4
no failover ip address intf5
pdm location 10.1.1.0 255.255.255.0 inside
pdm location 10.1.1.3 255.255.255.255 inside
pdm location 10.1.1.36 255.255.255.255 inside
pdm location 10.1.1.151 255.255.255.255 inside
pdm location 10.1.1.170 255.255.255.255 inside
pdm location 10.1.2.0 255.255.255.0 inside
pdm location 10.0.0.0 255.0.0.0 inside
pdm location 162.12.0.2 255.255.255.255 inside
pdm location 162.12.0.5 255.255.255.255 inside
<--- More --->
               
 pdm location 192.168.0.0 255.255.255.0 inside
pdm location 10.1.10.1 255.255.255.255 moh
pdm location 10.2.48.17 255.255.255.255 moh
pdm location 10.2.48.37 255.255.255.255 moh
pdm location 10.2.48.38 255.255.255.255 moh
pdm location 10.2.64.5 255.255.255.255 moh
pdm location 10.96.10.26 255.255.255.255 moh
pdm location 10.97.20.10 255.255.255.255 moh
pdm location 10.97.20.12 255.255.255.255 moh
pdm location 10.97.20.13 255.255.255.255 moh
pdm location 162.12.0.2 255.255.255.255 moh
pdm location 192.168.4.3 255.255.255.255 dmz
pdm location 192.168.4.4 255.255.255.255 dmz
pdm location 192.168.4.7 255.255.255.255 dmz
pdm location 192.168.4.8 255.255.255.255 dmz
pdm location 192.168.4.11 255.255.255.255 dmz
pdm location 162.13.229.0 255.255.255.0 outside
pdm location 208.232.113.0 255.255.255.0 outside
pdm location 208.232.115.0 255.255.255.0 outside
pdm location 206.126.161.158 255.255.255.255 outside
pdm location 202.65.252.0 255.255.255.192 outside
pdm location 192.168.4.1 255.255.255.255 inside
pdm location 162.13.248.0 255.255.255.0 outside
pdm location 162.13.249.0 255.255.255.0 outside
<--- More --->
               
 pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 61.189.198.211
global (moh) 1 interface
global (dmz) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
nat (dmz) 0 access-list nonat
static (inside,outside) 61.189.198.219 10.1.1.151 netmask 255.255.255.255 100 50
static (dmz,outside) 61.189.198.214 192.168.4.3 netmask 255.255.255.255 0 0
static (dmz,outside) 61.189.198.216 192.168.4.4 netmask 255.255.255.255 0 0
static (inside,dmz) 10.1.1.0 10.1.1.0 netmask 255.255.255.0 0 0
static (dmz,outside) 61.189.198.217 192.168.4.7 netmask 255.255.255.255 0 0
static (dmz,outside) 61.189.198.218 192.168.4.8 netmask 255.255.255.255 0 0
static (inside,outside) 61.189.198.220 10.1.1.170 netmask 255.255.255.255 0 0
static (inside,outside) 61.189.198.213 10.1.1.36 netmask 255.255.255.255 0 0
static (inside,outside) 61.189.198.215 10.1.1.3 netmask 255.255.255.255 0 0
static (dmz,outside) 61.189.198.212 192.168.4.11 netmask 255.255.255.255 0 0
static (inside,dmz) 10.1.2.0 10.1.2.0 netmask 255.255.255.0 0 0
access-group 110 in interface outside
access-group 120 in interface dmz
route outside 0.0.0.0 0.0.0.0 61.189.198.209 1
route inside 10.0.0.0 255.0.0.0 162.12.0.2 1
<--- More --->
               
 route inside 10.1.2.0 255.255.255.0 162.12.0.2 1
route moh 10.1.10.1 255.255.255.255 192.168.8.1 1
route moh 10.2.48.17 255.255.255.255 192.168.8.1 1
route moh 10.2.48.37 255.255.255.255 192.168.8.1 1
route moh 10.2.48.38 255.255.255.255 192.168.8.1 1
route moh 10.2.64.5 255.255.255.255 192.168.8.1 1
route moh 10.96.10.26 255.255.255.255 192.168.8.1 1
route moh 10.97.20.10 255.255.255.255 192.168.8.1 1
route moh 10.97.20.12 255.255.255.255 192.168.8.1 1
route moh 10.97.20.13 255.255.255.255 192.168.8.1 1
route inside 192.168.0.0 255.255.255.0 162.12.0.2 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 202.65.252.0 255.255.255.192 outside
http 162.12.0.5 255.255.255.255 inside
http 10.1.1.0 255.255.255.0 inside
http 162.12.0.0 255.255.0.0 inside
http 192.168.0.0 255.255.255.0 inside
<--- More --->
               
 snmp-server host inside 162.12.0.1
no snmp-server location
no snmp-server contact
snmp-server community public
snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set strong esp-des esp-sha-hmac
crypto ipsec transform-set Shaw esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set strong
crypto map vpnmap 20 ipsec-isakmp dynamic dynmap
crypto map ShawMap 50 ipsec-isakmp
crypto map ShawMap 50 match address 150
crypto map ShawMap 50 set peer 208.232.126.236
crypto map ShawMap 50 set transform-set Shaw
crypto map ShawMap interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp key ******** address 208.232.126.236 netmask 255.255.255.255
isakmp identity address
isakmp policy 30 authentication pre-share
isakmp policy 30 encryption des
isakmp policy 30 hash md5
<--- More --->
               
 isakmp policy 30 group 2
isakmp policy 30 lifetime 86400
isakmp policy 50 authentication pre-share
isakmp policy 50 encryption des
isakmp policy 50 hash md5
isakmp policy 50 group 1
isakmp policy 50 lifetime 28800
vpngroup vpnusers address-pool pptp-pool
vpngroup vpnusers idle-time 1800
vpngroup vpnusers password ********
telnet 10.1.1.0 255.255.255.0 inside
telnet 162.12.0.2 255.255.255.255 inside
telnet 192.168.0.0 255.255.255.0 inside
telnet 162.12.0.2 255.255.255.255 moh
telnet timeout 5
ssh 202.65.252.0 255.255.255.192 outside
ssh 206.126.161.158 255.255.255.255 outside
ssh 51.223.101.61 255.255.255.192 outside
ssh 10.1.1.0 255.255.255.0 inside
ssh timeout 60
management-access dmz
console timeout 0
vpdn group 1 accept dialin pptp
vpdn group 1 ppp authentication pap
<--- More --->
               
 vpdn group 1 ppp authentication chap
vpdn group 1 ppp authentication mschap
vpdn group 1 client configuration address local pptp-pool
vpdn group 1 pptp echo 60
vpdn group 1 client authentication local
vpdn username vpnuser password ********
vpdn username vpnuser password ********
vpdn enable outside
terminal width 80
Cryptochecksum:58de3e547a8767c6dd09e16ff22bc6498

 MA515#  
0
Comment
Question by:Donnie4572
  • 2
  • 2
4 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 2000 total points
ID: 13857954
Relevant parts of the puzzle:
>I have 10meg point to point from remote location connected to a cisco 2600 with ip address of 10.1.3.1/24
What is the subnet(s) on the other side of the 2600 at the remote location?

>  interface ethernet4 auto shutdown <== nothing happening until this interface is enabled
>  nameif ethernet4 intf4 security8
>  no ip address intf4

We'll need to change those with these commands:

  interface ethernet4 auto
  nameif ethernet4 remote
  ip address remote 10.1.3.2 255.255.255.0
  route remote <remote subnet> <mask> 10.1.3.1
  nat (remote) 1 0 0
 



0
 
LVL 12

Author Comment

by:Donnie4572
ID: 13858917
lrmoore thanks again.

I got this working yesterday.

Can you tell me this?

The pix has a site to site vpn that connects to a cisco concentrator, on the other end. After changing configuration and rebooting the pix, the vpn lost it's connection. The connection was restored only after resetting the concentrator on the other end.

Is ths normal?

Does this mean every time I reboot the pix I can expect to trouble shoot VPN connection problems?

Does this mean every time I change configuration on the pix I can expect to trouble shoot VPN connection problems?

Thanks,

Donnie
0
 
LVL 12

Author Comment

by:Donnie4572
ID: 13858955
lrmoore,

Your solution for this question is exactly what cisco told me. Thanks.

Donnie
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13859193
>Does this mean every time I reboot the pix I can expect to trouble shoot VPN connection problems?
No, it should come back all by itself with no intervention.

>Does this mean every time I change configuration on the pix I can expect to trouble shoot VPN connection problems?
Not unless you change some configuration that affects the VPN, i.e. access-list nonat, access-list 150, sysopt, etc..
0

Featured Post

Managing Security Policy in a Changing Environment

The enterprise network environment is evolving rapidly as companies extend their physical data centers to embrace cloud computing and software-defined networking. This new reality means that the challenge of managing the security policy is much more dynamic and complex.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Considering cloud tradeoffs and determining the right mix for your organization.
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses
Course of the Month9 days, 15 hours left to enroll

569 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question