• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 503
  • Last Modified:

Connection to Windows Server Fails on large file transfer

I have a network that has a Windows Server 2003 (Enterpise edition) working as a file server and it's also the AD domain controller.  I have clients that include domain-member XP PCs and Macs and non-domain member PCs using the Guest account on the server.  The network is running with a separate DHCP server (LinkSys) and Gigabit LAN cards on all PCs and MACs.  All the functions appear to work normally....

I have a 5Gig file that I saved to the server from an XP PC and I can't read it back from the server to the PCs without the following error "Cannot Copy <filename>:The specified network name is no longer available" appearing after maybe 30 seconds.  I proved that this also happens if copying folders that contain large amounts of data so it's not that specific file and it doesn't matter if it's a domain member PC or not.

I'm using windows explorer and mapping a network drive to the server.  When starting the transfer, the server network card is maxing out on transfer rates but apears to stop and then, maybe 20 seconds later, the client PC pops up the "Cannot Copy <filename>:The specified network name is no longer available" error message - annoyingly, file explorer never seems to lose its connection to the server and I can still explore the remote file share immediately after the message - i.e. the connection is still there.  There appear to be no significant errors in any of the server or client access logs.  A MAC (OS X) can copy the file to it's hard drive without errors but watching the network card activity on the server shows that there are gaps where the data transfer rate drops to almost zero and then picks up again - the file copies without error though.

Ideas?
0
MSProjectGeek
Asked:
MSProjectGeek
  • 3
  • 2
  • 2
  • +1
1 Solution
 
bmquintasCommented:
Why don't you test it with another nic?
0
 
MSProjectGeekAuthor Commented:
The main PC I have the issue is a Dell laptop Latitude D610 which has WiFi and Gigabit NICs, both NICs exhibit the same issue.  Also, tests from another PC (a domain member PC), give exactly the same problem.  I have tried changing cables etc.

The MAC that successfully downloaded the file was connected wirelessly so I could argue that irons it down to just the laptop but I got the same error from a desktop PC that was connected via a different NIC.

Logic says that it's a problem with Windows XP authenticating with Windows Server 2003; I know the error message says "Cannot Copy <filename>:The specified network name is no longer available" but that's a message that is clearly very common given the number of hits I get on web searches and the network name clearly IS available as I can still browse the remote server drive after explorer gives the error.
0
 
bmquintasCommented:
Are you using a switch? what kind 10/100? 1000?
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
LazarusCommented:
Try setting your MTU size to less than the 1500 XP's default. Set it to like 1472 instead. You may have to experiment a bit to get it right. That usually fixs that problem.
You don't mention wheter the XP machines are using SP2. There was a bug in the original version that had to do with Large file size problems.

0
 
Michael PfisterCommented:
1) I saw this happen when the automatic speed negotiation between switch and NIC fails to find the corecct settings. I.e. NIC has 100/half duplex, switch is set to 100/full duplex. When you try to copy from the server it works, if you try to copy to the server, it fails after some MBs. Try to set both ends to a fixed value of 100/full.

2) You could try and update your NIC driver.

3) Look at the performance counters of the server. See if the virus scanner takes up all cpu while attempting to scan the large file. Try to disable the virus scanner temporarily.

Hope this helps,

Michael
0
 
MSProjectGeekAuthor Commented:
I won't be able to test the above suggestions until later today 4/25/05 but some quick answers to questions are as follows:

Am I using a switch? - Yes, I'm using a Netgear GS108 switch that is an 8 port Gigabit switch.  I have a second one of these that I could use to substitute, I'll try that.
MTU size setting - I've read about that, please tell me where I go to change it.
Service Pack Status of XP PCs - all have SP2 and have ALL the upgrade downloads etc. offered by Microsoft Windows Update - same for the 2003 Server
Update NIC driver - I have looked but can't find more recent one - also, I have the same issue on my Dell Laptop using either of 2 NICs and I also have problem on desktop PC
Virus Scanner - that's a good idea

Later
0
 
LazarusCommented:
mpfister - Here's a link to guide you through setting your MTU's - There in the registery. http://www.speedguide.net/read_articles.php?id=157&print=friendly
0
 
LazarusCommented:
The MTU size on large files usually fixes that problem, but if he never gets back to us, who knows if it was the fix...
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now