Cisco VPN Client behind Cisco 827 router

Hi all,

I'm trying to connect to my company network through cisco vpn client. I'm using Cisco 827 router as the internet gateway (I'm new to Cisco routers). The Cisco VPN client can establish connection with my company network however, I couldn't ping any computers there. Additionally, I'm disconnected from my local network!

My config file:

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
enable secret 5 xxxxxxx
enable password xxxxx
!
clock timezone AEST 10
mmi polling-interval 60
no mmi auto-configure
mmi pvc 8/35
mmi snmp-timeout 180
ip subnet-zero
ip name-server 220.233.0.4
ip name-server 220.233.0.3
ip dhcp excluded-address 192.168.0.4
ip dhcp excluded-address 192.168.0.12
ip dhcp excluded-address 192.168.0.163
!
ip dhcp pool cisco_pool
   network 192.168.0.0 255.255.255.0
   domain-name climbingrose.mine.nu
   default-router 192.168.0.253
   dns-server 220.233.0.4 220.233.0.3
!
!
!
!
interface Ethernet0
 ip address 192.168.0.253 255.255.255.0
 ip nat inside
 hold-queue 100 out
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 8/35
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 bundle-enable
 dsl operating-mode auto
 hold-queue 208 in
!
interface Dialer0
 ip address negotiated
 ip nat outside
 encapsulation ppp
 dialer pool 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname xxxxxxx
 ppp chap password 0 xxxxxxx
!
ip nat inside source list 8 interface Dialer0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
!
!
access-list 1 permit 192.168.0.3
access-list 8 permit 192.168.0.0 0.0.255.255
snmp-server community public RO
banner motd ^CWelcome to Cisco 827 router^C
!
line con 0
 stopbits 1
 speed 115200
line vty 0 4
 password xxxxx
 login
!
scheduler max-task-time 5000
end


I used Netgear DG834G router before and Cisco client can connect just fine. Can any expert help me out with this? I think I need to enable to IPSec passthrough or VPN tunnelling but not sure how to do that.

Any help appreciated!
myroses83Asked:
Who is Participating?
 
magicommincCommented:
few things you may want to check:
1) you are getting 192.168.0.0/24 IP from cisco 827, when you use VPN client connect to your company network, what is the IP address pool range from your company VPN server/gateway? make sure it's not overlap with 192.168.0.0/24.
2) "access-list 8 permit 192.168.0.0 0.0.255.255", why is this subnet different from your pool (192.168.0.0 255.255.255.0)? it should work, but for trouble-shooting, can you change that to "access-list 8 permit 192.168.0.0 0.255.255.255"?
3) what is your OS and Cisco VPN client? for XP w/SP2, you need to have Cisco VPN client 4.6
4) you can enable IPSec passthrough by right click vpn profile-->modify-->under transport tab, check "enable transport tunneling-->IPSec over UDP(NAT/PAT).
0
 
myroses83Author Commented:
Anyone?
0
 
yang11Commented:
if you cannot ping, icmp may be filtered.

and when you connect using cisco vpn client, you lost connection to your LAN. I encountered that in my work.
and that behavior seems controlled on the server side. and if someone enable it, it would open the doors wide..
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.