Cisco VPN Client behind Cisco 827 router

Posted on 2005-04-25
Last Modified: 2010-05-18
Hi all,

I'm trying to connect to my company network through cisco vpn client. I'm using Cisco 827 router as the internet gateway (I'm new to Cisco routers). The Cisco VPN client can establish connection with my company network however, I couldn't ping any computers there. Additionally, I'm disconnected from my local network!

My config file:

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname Router
enable secret 5 xxxxxxx
enable password xxxxx
clock timezone AEST 10
mmi polling-interval 60
no mmi auto-configure
mmi pvc 8/35
mmi snmp-timeout 180
ip subnet-zero
ip name-server
ip name-server
ip dhcp excluded-address
ip dhcp excluded-address
ip dhcp excluded-address
ip dhcp pool cisco_pool
interface Ethernet0
 ip address
 ip nat inside
 hold-queue 100 out
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 8/35
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 dsl operating-mode auto
 hold-queue 208 in
interface Dialer0
 ip address negotiated
 ip nat outside
 encapsulation ppp
 dialer pool 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname xxxxxxx
 ppp chap password 0 xxxxxxx
ip nat inside source list 8 interface Dialer0 overload
ip classless
ip route Dialer0
no ip http server
access-list 1 permit
access-list 8 permit
snmp-server community public RO
banner motd ^CWelcome to Cisco 827 router^C
line con 0
 stopbits 1
 speed 115200
line vty 0 4
 password xxxxx
scheduler max-task-time 5000

I used Netgear DG834G router before and Cisco client can connect just fine. Can any expert help me out with this? I think I need to enable to IPSec passthrough or VPN tunnelling but not sure how to do that.

Any help appreciated!
Question by:myroses83

    Author Comment

    LVL 6

    Accepted Solution

    few things you may want to check:
    1) you are getting IP from cisco 827, when you use VPN client connect to your company network, what is the IP address pool range from your company VPN server/gateway? make sure it's not overlap with
    2) "access-list 8 permit", why is this subnet different from your pool ( it should work, but for trouble-shooting, can you change that to "access-list 8 permit"?
    3) what is your OS and Cisco VPN client? for XP w/SP2, you need to have Cisco VPN client 4.6
    4) you can enable IPSec passthrough by right click vpn profile-->modify-->under transport tab, check "enable transport tunneling-->IPSec over UDP(NAT/PAT).

    Expert Comment

    if you cannot ping, icmp may be filtered.

    and when you connect using cisco vpn client, you lost connection to your LAN. I encountered that in my work.
    and that behavior seems controlled on the server side. and if someone enable it, it would open the doors wide..

    Featured Post

    Looking for New Ways to Advertise?

    Engage with tech pros in our community with native advertising, as a Vendor Expert, and more.

    Join & Write a Comment

    When you connect to your workplace's VPN, you may not notice that you are using your workplace's servers to serve up webpages.  This might be undesirable since the workplace can log all the places you've been.  It also might be very slow to load pag…
    Overview Often, we set up VPN appliances where the connected clients are on a separate subnet and the company will have alternate internet connections and do not use this particular device as the gateway for certain servers or clients. In this case…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

    734 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    24 Experts available now in Live!

    Get 1:1 Help Now