• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 339
  • Last Modified:

Remote Server Login Error

When I attempt to run a select query against a remote server:

SELECT * FROM SQLSERVER1.OPES.dbo.SY_MASTER

I get the following error message:

Server: Msg 18456, Level 14, State 1, Line 1
Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'.
0
tbaseflug
Asked:
tbaseflug
  • 5
  • 2
1 Solution
 
michaelpgCommented:
Hi tbaseflug

In enterprise manager go to security, then go to linked servers, right click properties on SQLSERVR1.
Go the the securities tab, not sure what options are selected but i reccomend take the Be made using this security context option, then enter a user login and password with adequate permissions to do what you need to remotely.Then try again.

Cheers
0
 
rafranciscoCommented:
Verify the configuration of the SQLServer1 linked server.  In Enterprise Manager, go to the Security, then to Linked Servers and right click on SQLServer1 to go to Properties.  Check how the Security is configured and try selecting 'Be made using this security context' and specify a user name and password that can connect to SQLServer1.
0
 
tbaseflugAuthor Commented:
michaelpg -

I have eveythign set in this context with a linked server - however, I noticied a remote server setting as well.  Both point to teh same server - however the linked server has an alias that works, the linked server is named with the actual server name (the query against the actual server name fails).
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
michaelpgCommented:
Remote server setting should not effect the linked server from functioning.
What setting you you have under the securities tab of the linked server properties?
If you have an aliased linked server that works why not use the alias in your query?
0
 
michaelpgCommented:
Also make sure that the linked server in not in Windows Authentication mode.
Obviously if you state a sql login in your linked server properties it won't work unless the linked server in in mixed mode.
0
 
tbaseflugAuthor Commented:
michaelpg -

Let me take a look - I know that the server in question is a subscriber in replication - do you know if being a subscriber requires remote Vs linked server?
0
 
michaelpgCommented:
Actually looking at your error seems like SQLSERVRE1 is in windows authentication mode.
In that case you must stipulate - Be made using the logins current security context.And you must login with windows authentication and make sure that domain user has a login and access to the required database.Or change SQLSERVER1 to be mixed mode authentication(last resort).
0
 
michaelpgCommented:
No a remote server simply lets you connect to one instance of SQL Server to execute a stored procedure on another instance, this is used in replication but does not effect linked servers what so ever, checkout above comment about windows auth, i think that is more or the right track.
0

Featured Post

Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now