one of 4 PC's can see the others in Network Neighborhood, but they can't see it.

Hi, I've got 4 pcs I've connected via a linksys wifi router, plust a Maxtor shared drive connected to the router. PC#1 can see the other 3 pcs in Network Neighborhood and the maxtor. But, the other 3 pc's cannot see PC1.   I can open a shared folder on PC1 if I enter \\pc1 in the Run command on PC2-4, but that's it.

Additional weirdness: all were working last week, before I set up the maxtor and exchanged one of the 4 pc's (it was defective)

Any suggestions on how to solve this?
thePrisonerAsked:
Who is Participating?
 
bmquintasCommented:
control panel->network connections->local area connection (or whatever connection you're using) properties->tcp/ip properties->advanced->WINS tab->enable netbios over tcp/ip
0
 
pseudocyberCommented:
What kind of Linksys router?  Most of them only have 4 LAN ports.  Could you have one of your devices in the Internet/WAN port?
0
 
bmquintasCommented:
Check if the computer browser service is running, administrative tools->services , if not start the service and set it to automatic (all pc's)
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

 
thePrisonerAuthor Commented:
pseudocyber -

PC 1 is ethernet wired to the router ( Linksys wifi g - a week old), the other three are wifi.

bmquintas -

What is the computer browser service, and do I run it from any of the pcs, the router or the PC with the problem?
0
 
pseudocyberCommented:
Triple check that PC1 doesn't have any software firewall running on it.
0
 
thePrisonerAuthor Commented:
bmquintas -
Under MMC on the problem PC, computer browser service is running and set to automatic...
0
 
bmquintasCommented:
Taken from http://www.theeldergeek.com/computer_browser.htm


 Straightforward as can be, it keeps track of your computers on the network. If you're on a LAN, set it to Automatic. For stand alone systems, Disable is the way to go.

You should run it from all the pc's, it's located in administrative tools->services the search for a service called computer browser and make sure it is started and set to automatic.


Just a note, i did a setup like yours about a week ago, and one funny thing is that they took some time (up to 15m)  to show up in Network Neighborhood, but they did.
0
 
thePrisonerAuthor Commented:
All 4 pc's have zone alarm pro - where would I look on PC1's ZAP?
0
 
bmquintasCommented:
You must ensure that zone alarm is allowing traffic for your subnet.
0
 
thePrisonerAuthor Commented:
bmquintas -

All 4 are running computer browser service, pc's have been on for past 6 hours, problem started last thursday.
0
 
pseudocyberCommented:
Easiest thing to do is shutdown ZA and see if your problems go away.  If so, then you know you have to configure ZA.
0
 
thePrisonerAuthor Commented:
bmquintas -

Re ZAP, where specifically should I be checking in it?
0
 
bmquintasCommented:
do you have netbios enabled on all pc's?
0
 
bmquintasCommented:
Firewall->Zones add your subnet to the trusted zones
0
 
thePrisonerAuthor Commented:
do you have netbios enabled on all pc's?

-Don't know: where do I check it?
0
 
thePrisonerAuthor Commented:
changed it on the sick pc - 20 minutes and no sign on other pc's network places of it showing up...
0
 
thePrisonerAuthor Commented:
The solution turned out to be to nuke the bad pc - but bmquintas gets the points.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.