[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 924
  • Last Modified:

Can't acces services behind my PIX 501

Hi, I've been asking about the 501, I had some help and it's working till certain level.
Let me explain exacly what the Cisco need to do for me.

THis is a small ISP service, we have an:
-Email Server for more than 1 Domain, (2 right now)
-Web Server for more than one Domain (idem)
-Ftp Server
-WebMail Service (8383) for IMail
-DHCP Relay for Server giving DHCP over the Outside Interface to our Clients.
-DNS Servers in 2 different Servers.

This is what is going on withthe Config that I have.
My Clients get the DHCP, OK
My Clients (inside the same IP family) can browse my Webpages inside my Server behind the Cisco OK
My clients can Recive Eamil and Open WebMAil pages. OK

My cclients acnnot Send email I have a instantly replay of cannot deliver email. VERY BAD
The Workd can't access Anything Behind the CISCO PIX 501. VERY BAD

This is the Fisical setup as we have and want.

EXTERNAL CISCO T3 who connetc our PIPE provider to our Network gives me a 99.99.99.1 / 24 (99.99.99 is not real ;-) )
connected to a Switch 10/100/1000
Then IN the Switch the users and behinde the PIX 501 our servers.

                                            PIPE Provider
                                              INTERNET
                                                   |
                                                   |  
                                         ((( CISCO T3 )))
                                     Internal IP 99.99.99.1                                                  
                                                  |_________________________
                                                                                               |
                                     {{{ SWITCH 10 /100 /1000 }}}              |
                                                |         |           |_____________|
                       ______________|          |
                       |                                   |___________ <<< Anthena to Suscriber Modules and Access Points >>> 
           [ CISCO PIX 501 ]
                 |          |
      ______|           |______
      |                                 |
SERVER NS2               SERVER NS1
192.168.1.101             192.168.1.100
192.168.1.105             192.168.1.102
Email                          192.168.1.106
DNS                            Web
WebMAil                     DNS
DHCP                          DHCP (future)

This is my actual COnfig, please tell me What is wrong here?
why can't I access them from outside our network?

pixfirewall(config)# show config
: Saved
: Written by enable_15 at 14:54:50.490 UTC Fri Apr 22 2005
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 permit tcp any host 99.99.99.102 eq www
access-list 101 permit tcp any host 99.99.99.106 eq www
access-list 101 permit tcp any host 99.99.99.101 eq smtp
access-list 101 permit tcp any host 99.99.99.105 eq smtp
access-list 101 permit tcp any host 99.99.99.101 eq domain
access-list 101 permit tcp any host 99.99.99.100 eq domain
access-list 101 permit tcp any host 99.99.99.101 eq 8383
access-list 101 permit tcp any host 99.99.99.105 eq 8383
access-list 101 permit tcp any host 99.99.99.105 eq pop3
access-list 101 permit tcp any host 99.99.99.101 eq pop3
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 99.99.99.2 255.255.255.0
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.1.102 255.255.255.255 inside
pdm location 192.168.1.106 255.255.255.255 inside
pdm location 192.168.1.101 255.255.255.255 inside
pdm location 192.168.1.105 255.255.255.255 inside
pdm location 192.168.1.100 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp 99.99.99.102 www 192.168.1.102 www netmask 255.255.255.255 0 0
static (inside,outside) tcp 99.99.99.106 www 192.168.1.106 www netmask 255.255.255.255 0 0
static (inside,outside) tcp 99.99.99.101 smtp 192.168.1.101 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp 99.99.99.105 smtp 192.168.1.105 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp 99.99.99.101 domain 192.168.1.101 domain netmask 255.255.255.255 0 0
static (inside,outside) tcp 99.99.99.100 domain 192.168.1.100 domain netmask 255.255.255.255 0 0
static (inside,outside) tcp 99.99.99.101 8383 192.168.1.101 8383 netmask 255.255.255.255 0 0
static (inside,outside) tcp 99.99.99.105 8383 192.168.1.105 8383 netmask 255.255.255.255 0 0
static (inside,outside) tcp 99.99.99.101 pop3 192.168.1.101 pop3 netmask 255.255.255.255 0 0
static (inside,outside) tcp 99.99.99.105 pop3 192.168.1.105 pop3 netmask 255.255.255.255 0 0
access-group 101 in interface outside
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.33 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcprelay server 192.168.1.101 inside
dhcprelay enable outside
terminal width 80
0
sirexilon
Asked:
sirexilon
  • 5
  • 4
1 Solution
 
lrmooreCommented:
One issue right off the bat...
>access-list 101 permit tcp any host 99.99.99.101 eq domain
>access-list 101 permit tcp any host 99.99.99.100 eq domain

DNS uses UDP, not TCP. Add the following
  access-list 101 permit udp any host 99.99.99.101 eq domain
  access-list 101 permit udp any host 99.99.99.100 eq domain
  static (inside,outside) udp 99.99.99.101 domain 192.168.1.101 domain netmask 255.255.255.255 0 0
  static (inside,outside) udp 99.99.99.100 domain 192.168.1.100 domain netmask 255.255.255.255 0 0


Since your DNS is internal, you may want to add the "dns" tag to your static xlates for public services:
>static (inside,outside) tcp 99.99.99.102 www 192.168.1.102 www netmask 255.255.255.255 0 0
>static (inside,outside) tcp 99.99.99.106 www 192.168.1.106 www netmask 255.255.255.255 0 0
>static (inside,outside) tcp 99.99.99.101 smtp 192.168.1.101 smtp netmask 255.255.255.255 0 0
>static (inside,outside) tcp 99.99.99.105 smtp 192.168.1.105 smtp netmask 255.255.255.255 0 0

Should be:
static (inside,outside) tcp 99.99.99.102 www 192.168.1.102 www dns netmask 255.255.255.255 0 0
static (inside,outside) tcp 99.99.99.106 www 192.168.1.106 www dns netmask 255.255.255.255 0 0
static (inside,outside) tcp 99.99.99.101 smtp 192.168.1.101 smtp dns netmask 255.255.255.255 0 0
static (inside,outside) tcp 99.99.99.105 smtp 192.168.1.105 smtp dns netmask 255.255.255.255 0 0
                                                                                              ^^



0
 
sirexilonAuthor Commented:
OK good, so I should delete this

>static (inside,outside) tcp 99.99.99.102 www 192.168.1.102 www netmask 255.255.255.255 0 0
>static (inside,outside) tcp 99.99.99.106 www 192.168.1.106 www netmask 255.255.255.255 0 0
>static (inside,outside) tcp 99.99.99.101 smtp 192.168.1.101 smtp netmask 255.255.255.255 0 0
>static (inside,outside) tcp 99.99.99.105 smtp 192.168.1.105 smtp netmask 255.255.255.255 0 0

and add the new ones U gave me.
Now How I delete them? I'm very new with the 501.
Thanks BTW.
0
 
lrmooreCommented:
delete them with "no"

no static (inside,outside) tcp 99.99.99.102 www 192.168.1.102 www netmask 255.255.255.255
no static (inside,outside) tcp 99.99.99.106 www 192.168.1.106 www netmask 255.255.255.255
<etc>
Then just add the new ones in.
0
Automating Your MSP Business

The road to profitability.
Delivering superior services is key to ensuring customer satisfaction and the consequent long-term relationships that enable MSPs to lock in predictable, recurring revenue. What's the best way to deliver superior service? One word: automation.

 
sirexilonAuthor Commented:
OK got it.
So that will fix the problem from outside our network too?

I really don't get why from the same family outside the PIX I can get to the services behind the PIX but if I'm on internet from any other provider I can NOT get to the webpages or email
That is Odd.

Any ideas there?
0
 
lrmooreCommented:
For access from the internet to services behind the pix, you need two things:

1) access-list permissions (and applied to the outside interface, of course)
  access-list 101 permit tcp any host 99.99.99.102 eq www

2) and static NAT or port Xlate
  static (inside,outside) tcp 99.99.99.102 www 192.168.1.102 www netmask 255.255.255.255

That's all you need for outside users to access the www pages. If it doesn't work, there are two reasons:
1) DNS is not resolving to the proper IP address. Can users get to http://99.99.99.102  ?
2) No default routing from server through the PIX

Hosting DNS on the inside poses a whole new set of "issues"
DNS must resolve to the public IP address for external users
DNS must resolve to the private IP address for internal users
You can see that having just public DNS servers poses an issue for internal hosts. If the public DNS server is hosted outside the PIX, there is a function called "dns doctoring" whereby the PIX will intercept DNS resolves for the public IP and replace it with the private IP if the request came from inside the PIX.

You may have to re-think how you resolve these sites for internal users..
0
 
sirexilonAuthor Commented:
Internal users is not a problem. I don't have any..
all what is interna lsre the Servers,
if you check the graphic on my Postting, you'll see that the ISP Clients are outside the PIX ans the Internet GLobal users are too.

Behind the PIX are only the 2 servers.

The problem I have is that users on the same IP family will be abel to get to the pages, and users from the Internet Workd wont.

I don't know if this lines that  U gave me wil fix that.

static (inside,outside) tcp 99.99.99.106 www 192.168.1.106 www dns netmask 255.255.255.255 0 0

0
 
lrmooreCommented:
sirexilon,
>and users from the Internet Workd wont.

The whole exercise here was to make it so that the Internet world CAN access your web pages, right?
If you have the static and the access-list, then there is no reason why Internet world cannot see your web pages.
0
 
sirexilonAuthor Commented:
OK.. I didn't want to get lost ,
I will try your config, soon,
it makes a lot of sence so, I will be back in a few days with that. final review.
Thx
0
 
lrmooreCommented:
Are you still working on this?
Have you found a solution?
Do you need more information?

This question will be classified as abandoned soon if we don't get some feedback from you.

Can you close out this question? See here for details:
http://www.experts-exchange.com/help.jsp#hs5

Thanks for your attention!
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now