?
Solved

How can I install Fedora 3 from a dvd in a linux computer with dvd/cd to a windows computer with an empty partition that only has a cd rw drive?

Posted on 2005-04-25
18
Medium Priority
?
351 Views
Last Modified: 2010-03-18
How can I install Fedora 3 from a dvd in a linux computer with dvd/cd rom to a windows computer with an empty partition that only has a cd rw drive?
I set both up on a local lan with just 2 computers 192.168.2.45 linux, 192.168.2.46 windows computer, both not connected to the internet.. Put dvd contents in Fedora subdirectory of /var/www/html with subdirectories of base and RPMS. Put test files index.html in each subdirectory and could read index.html in /var/www/html, /var/www/html/Fedora, /var/www/html/base, etc. with no problems from Windows computer; e.g., in windows computer put in browser the following, http://192.168.2.45/Fedora/index.html.
All the files in the various directories had drwxr-xr-x rights except the rpms which were read only for group and other.
I don't know why I was supposed to boot from the dvd and put the dvd contents in the linux computer.  Seems like there should be some way to just do it directly from linux apache server.
When I tried to install from the linux computer, booting from the dvd and selecting an http install it would never recognize the path of Fedora from the linux computer.
0
Comment
Question by:elmendor
  • 8
  • 4
  • 4
  • +2
18 Comments
 
LVL 1

Expert Comment

by:IBCIT
ID: 13861453
Is the option of downloading the CD ISO's out of the question?
0
 

Author Comment

by:elmendor
ID: 13862405
Yes - connection too slow.
0
 
LVL 3

Accepted Solution

by:
joju earned 400 total points
ID: 13864279
Hi,

   If you are trying to install on windows system do the following

1. copy contents of CD to eg: /var/www/html/install of linux system
2. make sure apache is running
3. take a new floppy and put in linux system
4. give command  dd if=<path>bootnet.img of=/dev/fd0
for this commad replace path with path to bootnet.img in CD tree at /var/www/html/install
5. now boot windows system with floppy
6. input required perameters.. thats it..


Thanxs
Joju.


0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
LVL 20

Expert Comment

by:nedvis
ID: 13873299
*********************Network Based Linux Installation****************************************

Setup Your Webserver    (   http://www.linuxhomenetworking.com/linux-adv/network-install.htm  )
You will  have to setup Apache to give the file listings of your
 /data/network-install/Fedora
                and
/data/network-install/ISO
directories by pointing your browser to the
URL http://192.168.2.45/network-install/Fedora/RPMS/
 or
http://192.168.2.45/network-install/Fedora/ISO/ respectively.
 ...Remember to restart Apache to make these settings take effect: "
******************************************************************
1.      Connect your client Linux box to the DHCP network.
2.      Boot your system using the first Fedora installation CD. This is the only CD you'll need network installations.
3.      Enter the command "linux askmethod" at the boot: prompt
4.      Hit the <Enter> key
5.      Go through the usual steps until it prompts for the "Installation Method". You will see a number of choices
Local CDROM
Hard Drive
NFS Image
FTP
HTTP
6.      Select the network option of your choice (NFS, FTP, HTTP)
7.      Select the Ethernet device to which the installation client is connected to the installation server network. This would most likely be interface "eth0".
8.      Type 192.168.2.45 in the following "Configure TCP/IP" screen.

          If You Selected The HTTP Method
You will now reach the "HTTP Setup" menu. Enter the IP address of the installation server when prompted for a "Web site name".The "Red Hat directory" will be "/network-install". The following menus will be text based versions of the usual Fedora installation screens.
******************************************************************************************
RH Fedora 3 network install stuff:
http://www.mae.virginia.edu/linuxboot/
Hassles doing a network Fedora Core 3 install:
http://www.zen.org/?p=291
*******************************************************************************************
Since kernel 2.6 cannot fit on standard 1.4 Mb floppy there is no other way to boot your Windows laptop other than creating bootable CD rom and boot from CD to proceed with network installation method.
NOTE you cannot install Fedora ( nor other distros )  by trying to initialize installation process withing Windows GUI !!!!
 
good luck
 nedvis
0
 

Author Comment

by:elmendor
ID: 13873333
Joju,

I have been trying to test out your answer but have had the following problems:

- It took me awhile to find bootnet.img - I did find a redhat 7.0 version with plip which it said would not hurt anything

- I think I finally made the dd command work; I forgot to mention I only have a floppy on the windows machine, so I quickly installed a minimal version of Mandrake 10.1 community on the empty partition of the windows machine to be able to copy the bootnet.img file to a floppy. I was only able to do this by doing the following:
     starting mandrake,
     mounting the floppy on /mnt/floppy (mount /dev/fd0 /mnt/floppy),
     deleting all files (an old windows data floppy)
     putting the bootnet.img file in the /boot directory
     issuing the command dd if=/boot/bootnet.img of=/mnt/floppy
     it then copied the image to /mnt/floppy with 1457664 bytes and
           with permissions of -rwxr--r--
Now the problem is I get a non-system disk error when I try to boot up from the floppy. Can you tell me how to make this a bootable linux disk so I can try out the rest of your solution. I haven't worked with floppies for a long time.

Thanks,

Jim
0
 
LVL 3

Expert Comment

by:joju
ID: 13874469
I guess you didnt unmount floppy before running dd command.

Follow the exact steps

1. boot mandrake
2. put floppy into drive ( dont mount)
3. give command  dd if=/boot/bootnet.img of=/mnt/floppy
4. reboot system
5. enter Bios
6. Make floppy as first in default boot sequence
7. Save and Exit from Bios to boot from floppy

Thanxs,
Joju.



0
 
LVL 3

Expert Comment

by:joju
ID: 13874475
sorry .. Third step should be:

3  give command  dd if=/boot/bootnet.img of=/dev/fd0


Thanxs,
Joju.
0
 

Author Comment

by:elmendor
ID: 13879182
joju

command above does not work, I get the message "no such device or address"

In the device dirertory there is

fd@
fd0
fd1
/floppy

in /floppy there is
0@
0
 

Author Comment

by:elmendor
ID: 13879342
Nedvis,

I only have a dvd/cd unit on my laptop that only reads cds. On the dual boot principally windows desktop computer I have a floppy and read only cdrom.

I read the linuxhomenetworking site article which I had read before.

Are the /data/network-install/fedora directories mandatory or can I leave things as they are with /var/www/html/Fedora?

Is the ISO subdirectory the same as the isolinux subdirectory on the dvd?

I assume I don't have to make an iso image of the dvd as mentioned in the nts installation option. If I had the listing of each cd, I could probably make iso images of each cd, make cds and do a normal install but I have not been able to find the listings and now I really want to figure out how to do this through an http installation.

I would prefer to use specific IP addresses rather than dhcp to avoid setting more things up. I am only doing all this on a home network with no outside connection to the internet and ip addresses of 192.168.2.45 and 46 connected to a hub so the setup is pretty simple.

I rather think  right now that the problem is more the boot floppy than anything else. Since I can write to it with the linux os I assume I should be able to do the "dd bootnet.img" thing but as you can see from the last note above I have not been able to get past the boot floppy problem.

Thanks,

jim
0
 

Author Comment

by:elmendor
ID: 13879473
I made an idiot mistake. I could do the floppy dd command. Sorry. Will try out the rest tonight.

Many thanks.

Jim
0
 
LVL 20

Assisted Solution

by:nedvis
nedvis earned 400 total points
ID: 13879784
1.      Connect your client Linux box to the DHCP network
                                                                                 line in yur case should read :
1.      Connect your client Linux box to the peer-to-peer network ( or just ignore it )
                                                                                 since you have only one more PC on two-PC network .
__________________________________________________________________________________________
I would say  http://192.168.2.45/network-install/Fedora/RPMS  path to source is MANDATORY , but I'm not sure !
------------------------------------------------------------------------------------------------------------------------------
The most important thing is to boot your desktop to linux environment ( either from floppy or from CD ) and tell setup where to look for source files on network . In your case it would be  http://192.168.2.45/network-install/Fedora/RPMS
Since you're not going to burn installation CDs from iso images , no you don't need pointer to iso files .

good luck
nedvis
0
 

Author Comment

by:elmendor
ID: 13882147
Booted windows machine up with floppy,

booted linux laptop machine up and set to dynamic dhcp

Message - What type of media contains the packages to be installed? NFS, FTP, HTTP

Selected HTTP

Message - Which driver should I try?

Selected VIA VT86c100A Rhine-II PCI which is the type of network card I have in my linux laptop

Message - Specify module parameters – left blank, hit ok

Message – failed to insert via-rhine module

.......

Tried process again, but after rebooting windows machine

typed linux dd

Message comes up asking if I have a driver disk, I say yes,

Message that disk is not a driver disk

I then say no I don't have driver disk

follow screens and get same results as the first time


Don't know what the driver disk is if  it is not the boot disk I have already.
Or maybe my bootnet.img file is bad?

Getting closer but not there yet.
0
 
LVL 20

Expert Comment

by:nedvis
ID: 13882276
A driver disk adds support for hardware that is not otherwise supported by the installation program. The driver disk could be produced by Red Hat, it could be a disk you make yourself, or it could be a disk that a hardware vendor includes with a piece of hardware.
http://www.linux.cu/documentos/RedHat/ref-guide/ch-driverdisk.htm

Your NIC is well supported by RedHat and it uses  via-rhine.o  kernel module

nedvis
0
 
LVL 3

Expert Comment

by:joju
ID: 13882963
where you got bootnet.img?
in the same path there will be another image drvnet.img
copy drvnet.img to your mandrake's /tmp/ folder
put another new floppy ( dont you the other .. its needed for booting)
give command "dd if=/tmp/drvnet.img of=/dev/fd0"
now your network driver floppy is ready

now put in you boot floppy to boot
at boot: prompt type linux dd
and insert the driver floppy when asked.

let me know where ur struck next..

Thanxs
Joju.


0
 
LVL 20

Expert Comment

by:nedvis
ID: 13884724
Look for the file bootnet.img in either :

d:\dosutils
d:\dosutils\autoboot
or
d:\images
on your installation CD-DVD

good luck
nedvis
0
 

Author Comment

by:elmendor
ID: 13915320
I keep getting "Failed to insert via-rhine module". I have researched this and it appears to be the via-rhine-o module that I need plus making it part of a boot and/or driver disk. Am researching this now but until I can figure out how to make this I will be stymied.

Jim
0
 
LVL 3

Assisted Solution

by:TimEliseo
TimEliseo earned 1200 total points
ID: 14015307
I'm not sure why you're messing with floppies when you've got a CD burner on your Windows box. Just copy the 76MB image from /images/rescuecd.iso on the Fedora Core 3 DVD to your Windows machine and burn it onto a CD (make sure you burn this as an image and not do something silly like have it be a file in a filesystem created by your CD burning app). Then boot the CD and do an HTTP installation reading from the Linux machine as others have instructed.

Since this is a full FC3 2.6 kernel on the rescue CD, it should have the via-rhine driver (I know because I have a VIA box that uses the same thing and have successfully installed FC3 on it).
0
 

Author Comment

by:elmendor
ID: 14019388
Thanks TimEliseo. Will try this and let you know.
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question