?
Solved

PIX to PIX VPN Issue

Posted on 2005-04-25
8
Medium Priority
?
436 Views
Last Modified: 2012-05-05
I am installing a PIX (501) to PIX (501) VPN solution to connect our home office with our warehouse.  Below are the relevant portions of the two PIX configurations.  I used the PDM to create the configurations for both but they will not connect.  Assuming the username and password and IPs (which are "X"ed out) are correct in both configurations, what is wrong? I can ping the external interface of each PIX from the other Pix (ie. I can ping the external IP of the warehouse PIX from the office PIX).  I appreciate your assistance.

WAREHOUSE PIX CONFIGURATION:

interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password arc.pix
passwd arc.pix
hostname ARCWHPIX
domain-name XXXXXXX.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.1.0 ARCHQNETWORK
access-list inside_outbound_nat0_acl permit ip 172.16.16.0 255.255.255.0 ARCHQNETWORK 255.255.255.0
access-list outside_cryptomap_20 permit ip 172.16.16.0 255.255.255.0 ARCHQNETWORK 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside XXX.XXX.XXX.XXX 255.255.255.248 pppoe
ip address inside 172.16.16.9 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location ARCHQNETWORK 255.255.255.0 inside
pdm location ARCHQNETWORK 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 70.245.175.47 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 172.16.16.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer XXX.XXX.XXX.XXX
crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map interface outside
isakmp enable outside
isakmp key as2002 address XXX.XXX.XXX.XXX netmask 255.255.255.255 no-xauth no-config-mode
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet ARCHQNETWORK 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group pppoe_group request dialout pppoe
vpdn group pppoe_group localname arc.warehouse@sbcglobal.net
vpdn group pppoe_group ppp authentication pap
vpdn username xXXXXXX password XXXXXXX
dhcpd address 172.16.16.100-172.16.16.120 inside
dhcpd dns XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside


MAIN OFFICE PIX CONFIGURATION:

interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password XXXX
passwd XXXX
hostname ARCHQPIX
domain-name arcticshield.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.1.2 FS
name 172.16.16.0 ARCWarehouseNetwork
access-list inside_access_out deny tcp any any eq 135
access-list inside_access_out deny udp any any eq 135
access-list inside_access_out deny tcp any any eq 137
access-list inside_access_out deny udp any any eq netbios-ns
access-list inside_access_out deny tcp any any eq 138
access-list inside_access_out deny udp any any eq netbios-dgm
access-list inside_access_out deny udp any any eq 139
access-list inside_access_out deny tcp any any eq netbios-ssn
access-list inside_access_out deny tcp any any eq 445
access-list inside_access_out deny tcp any any eq 593
access-list inside_access_out permit icmp any any echo
access-list inside_access_out permit icmp any any echo-reply
access-list inside_access_out permit ip any any
access-list inside_access_out permit tcp 10.8.1.0 255.255.255.0 any
access-list inside_access_out permit ip 10.8.1.0 255.255.255.0 any
access-list outside_access_in permit tcp any any eq pptp
access-list outside_access_in permit icmp any any  
access-list 101 permit icmp any any
access-list 101 permit ip 10.8.1.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list 101 permit ip 192.168.1.0 255.255.255.0 10.8.1.0 255.255.255.0
access-list 101 permit ip 192.168.1.0 255.255.255.0 ARCWarehouseNetwork 255.255.255.0
access-list outside_cryptomap_20 permit ip 192.168.1.0 255.255.255.0 ARCWarehouseNetwork 255.255.255.0
access-list 102 permit ip 192.168.1.0 255.255.255.0 ARCWarehouseNetwork 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside XXX.XXX.XXX.XXX 255.255.255.248
ip address inside 192.168.1.5 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ARCPPTPOOL 10.8.1.1-10.8.1.5
pdm location FS 255.255.255.255 inside
pdm location 192.168.1.10 255.255.255.255 inside
pdm location 192.168.1.11 255.255.255.255 inside
pdm location 192.168.1.20 255.255.255.255 inside
pdm location 10.8.1.0 255.255.255.248 outside
pdm location 192.168.1.12 255.255.255.255 inside
pdm location 10.8.1.0 255.255.255.0 inside
pdm location 192.169.1.0 255.255.255.0 inside
pdm location 10.8.1.0 255.255.255.0 outside
pdm location 192.168.1.0 255.255.255.0 outside
pdm location ARCWarehouseNetwork 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) XXX.XXX.XXX.XXX 192.168.1.10 netmask 255.255.255.255 0 0
static (inside,outside) XXX.XXX.XXX.XXX FS netmask 255.255.255.255 0 0
static (inside,outside) XXX.XXX.XXX.XXX 192.168.1.11 netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
access-group inside_access_out in interface inside
route outside 0.0.0.0 0.0.0.0 XXX.XXX.XXX.XXX 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address 102
crypto map outside_map 20 set peer XXX.XXX.XXX.XXX
crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map interface outside
isakmp enable outside
isakmp key as2002 address XXX.XXX.XXX.XXX netmask 255.255.255.255 no-xauth no-config-mode
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet 192.168.1.0 255.255.255.0 inside
telnet 10.8.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group PPTP-VPDN-GROUP accept dialin pptp
vpdn group PPTP-VPDN-GROUP ppp authentication mschap
vpdn group PPTP-VPDN-GROUP ppp encryption mppe 40
vpdn group PPTP-VPDN-GROUP client configuration address local ARCPPTPOOL
vpdn group PPTP-VPDN-GROUP client configuration dns FS
vpdn group PPTP-VPDN-GROUP client configuration wins FS
vpdn group PPTP-VPDN-GROUP pptp echo 60
vpdn group PPTP-VPDN-GROUP client authentication local
vpdn username XXXXXXX password XXXXXXX
vpdn enable outside
dhcpd address 192.168.1.6-192.168.1.37 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside

0
Comment
Question by:Winnercomm
  • 2
  • 2
  • 2
  • +1
7 Comments
 
LVL 79

Assisted Solution

by:lrmoore
lrmoore earned 400 total points
ID: 13862131
First, try removing the access-list off the inside interface on the MAIN OFFICE firewall
>access-group inside_access_out in interface inside

You're blocking all the necessary lan traffic to connect between the two sites.


0
 
LVL 6

Assisted Solution

by:BILJAX
BILJAX earned 200 total points
ID: 13862179
I'm not too convinced about either one of those:
access-group outside_access_in in interface outside
access-group inside_access_out in interface inside
0
 
LVL 2

Assisted Solution

by:Vladan_MOBTEL
Vladan_MOBTEL earned 400 total points
ID: 13866346
I would start using normal networks not names, at least in the IPSEC related access-lists, so in the first configuration in the access-list use 192.168.1.0 not ARCHQNETWORK. I am hunting in the wild, but lets give it a shot...

Also, could you turn on debug isakmp sa and post the output, when you try to establish a tunnel.

Thanks
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:Winnercomm
ID: 13867051
Irmoore,

I made the requested change.  I'm still not getting a connection.  I will simply redo the IPSEC configuration tonight unless you have another suggestion.

0
 

Author Comment

by:Winnercomm
ID: 13867719
Also, since I removed the "access-group inside_access_out in interface inside" the pix ignores the following lines:

access-list inside_access_out deny tcp any any eq 135

access-list inside_access_out deny udp any any eq 135

access-list inside_access_out deny tcp any any eq 137

access-list inside_access_out deny udp any any eq netbios-ns

access-list inside_access_out deny tcp any any eq 138

access-list inside_access_out deny udp any any eq netbios-dgm

access-list inside_access_out deny udp any any eq 139

access-list inside_access_out deny tcp any any eq netbios-ssn

access-list inside_access_out deny tcp any any eq 445

access-list inside_access_out deny tcp any any eq 593

access-list inside_access_out permit icmp any any echo

access-list inside_access_out permit icmp any any echo-reply

access-list inside_access_out permit ip any any

access-list inside_access_out permit tcp 10.8.1.0 255.255.255.0 any

access-list inside_access_out permit ip 10.8.1.0 255.255.255.0 any
0
 
LVL 79

Assisted Solution

by:lrmoore
lrmoore earned 400 total points
ID: 13868201
>since I removed the "access-group inside_access_out in interface inside" the pix ignores the following lines:
Of course it is ignoring these lines. That was the purpose of removing it from the interface...

Before you re-do it, can you post result of
"show crypto is sa" and "sho crypto ip sa" from both the router and the pix?


0
 
LVL 2

Accepted Solution

by:
Vladan_MOBTEL earned 400 total points
ID: 13924654
Could you post the debug part if you start debugging with:

debug crypto isakmp

and then try to establish a tunnel, by generating some interesting traffic. Could you post:

sh access-list 101
sh access-list 102

as well?

Thanks
0

Featured Post

 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is a collection of issues that people face from time to time and possible solutions to those issues. I hope you enjoy reading it.
This program is used to assist in finding and resolving common problems with wireless connections.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question