[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 7385
  • Last Modified:

Cannot Find Server (only ONE website/IP and only in my network, rest of internet OK ;-)

This is an odd one.

I am working on a website for a client, and today for some reason I have started to get "Cannot Find Server, or DNS Error" when opening the page in Internet Explorer on XP Professional.

I opened the page succesfully yesterday.

FTP and Secure Shell access are also not working.

I can ping the IP address, and a traceroute finds the route succesfully.

I cant open the webpage using the IP address (212.227.109.225)

I have no other problems with any other web pages, ftp sites etc.  I have tried sites I have never visited before.  I have confirmed that I can see sites hosted with the same company.

I've asked my friends and contacts to try the site and they can all open the webpage without any problems.

The hosting company has run tests and there is no problem at their end.

My ISP is useless - they have little interest in solving the problem, even though their own engineers can't open the webpage.

I have three computers on this network, two XP Pro, and one W2K.  None of them can see the site.

I am sitting behind a Draytek DSL Router, with a secure but flat configuration, there's no restrictions on the router, and it is configured to be issued with DNS server addresses dynamically.  DNS requests are passing through the router correctly, and the IP address I am receiving is correct.

WTF is happening?  This has me baffled.


Just in case you ask, and even though this condition exists on three seperate workstations - my network settings on *this workstation* have not changed as far as I know since I was looking at the site yesterday.  The only thing I dont know recognise is the second DNS server, but this is only on *this* computer

Windows IP Configuration

        Host Name . . . . . . . . . . . . : <snip>
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : 3Com Gigabit LOM (3C940)
        Physical Address. . . . . . . . . : <snip>
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.<snip>
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.2.1
        DHCP Server . . . . . . . . . . . : 192.168.2.1
        DNS Servers . . . . . . . . . . . : 192.168.2.1
                                                   194.98.0.1                      <----  *** I dont recognise this ***
        Lease Obtained. . . . . . . . . . : 25 April 2005 20:08:42
        Lease Expires . . . . . . . . . . : 28 April 2005 20:08:42


My hosts file is empty and my cache has been cleared.
0
siliconbrit
Asked:
siliconbrit
  • 13
  • 10
  • 5
  • +4
1 Solution
 
rindiCommented:
Have you tried using a real webbrowser, like firefox? Have checked the security settings of your IE for certain blocked sites?
0
 
BILJAXCommented:
I agree with rindi, however, since you can't SSH or FTP, I would think that the firewall at your client is garbled.
0
 
siliconbritAuthor Commented:

The site does not open in Firefox, Opera, raw Mozilla or Internet Explorer.

The IE settings should allow the site to be seen.

Remember that I have tried this on three different computers all on the same network.  This is not a machine specific problem.
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 
siliconbritAuthor Commented:

"Firewall at your client"..  Do you mean the firewall on each of three machines?

One XP machine is running ZoneAlarm

One XP machine is running native XP SP2 Firewall

The W2K machine is not fire-walled.

The router firewall is reset to factory defaults - see above - "no restrictions on the router"

Thanks anyway, but this is not a client issue.  This is a networking issue.
0
 
xrokCommented:
Try the different DNS Server
Maybe your ISP is having problem with DNS Server

0
 
siliconbritAuthor Commented:

Not sure this is possible xrok, after all I can "ping <url>" and "traceroute <url>" succesfully, both of which start by resolving the URL using the DNS server.

The DNS server is returning the correct IP address.
0
 
rindiCommented:
Did I understand you correctly, does the connection also not work if you enter the site as an IP, or does it just not resolve correctly when you enter it in the domainname form? If that is the case check your Internal DNS Server for missconfiguration. Also since you don't understand the 2nd DNS server entry, check your DHCP Server and remove that entry. Maybe that is also the cause of your problems. If the two dns servers have different entries for your website, your system will get confused.
0
 
siliconbritAuthor Commented:

If I enter the site using the IP address only - it does *not* load ("Cannot Find Server").

The DHCP server is built into the router, and issues IP addresses to machines on the local network.  All other DNS requests are passed by the router to my ISP.  So the router acts as the DNS on the network, but external IP addresses are resolved by the ISP's DNS Servers.

DNS resolution of the URL to the IP address is working correctly.
0
 
xrokCommented:
Can any other computer on your LAN can get on?

I still get that 2nd dns entry like rindi recommended.
It is not needed, since you are getting ip from DHCP

0
 
mtpcbypcCommented:
reboot your router.  Your ISP has changed or upgraded their DNS server.  Also you can add a DNS address for another company  in the dynamic dns section of your router config.
0
 
siliconbritAuthor Commented:
Xrok - I've clearly stated that all three computers on this LAN have the same problem

rindi/mypcbypc - can you expand on your answers, bearing in mind that when I reboot everything, including the router, and then try "ping www.x.com"  the ping CORRECTLY resolves the IP address, using the currently configured DNS server.  What makes you think that the DNS is incorrect if it is resolving the IP address correctly?

0
 
xrokCommented:
sorry...my bad.. >> Xrok - I've clearly stated that all three computers on this LAN have the same problem

0
 
rindiCommented:
It's just a hunch. Can you try setting up one of those PC's using static IP settings? Just give it one dns server etc. Also make sure you don't have any proxy server setting in the "connection" settings of your browsers.
0
 
mtpcbypcCommented:
Gad - I though I read better that that , Sorry.
I just tried the site and I get error 400 bad request.
Is it possible that the isp shut down the site?
It resolves to schlund.de and their primary name server as listed in www.dslreports.com/who is comes back as invalid.
If I ping ns.schlund.de I get dns resolve on my end of 195.20.224.97- that seems to function, access to the site from here is not happening either.
I'd ask the server whats going on.
0
 
siliconbritAuthor Commented:
=> Answer to rindi

Sorry rindi, no dice with static IP - it makes no difference and I did this in early investigation - see more information below.

This is the last time I will say this "The URL is already correctly resolving with the current DNS".

What makes you think that the DNS server remains involved in an HTTP request once I have discovered the IP address?
0
 
siliconbritAuthor Commented:
=> Answer to mtpcbypc

If you get a 404 bad request, thats fine, it means you are connecting to the server OK.  404 means that it can't find the specific page you have requested, and in this case you haven't requested a page, and the IP address is not enough for Apache to find the Virtual Host and therefore find a default page, so you get a 404.  This is all good and should tell you that you can complete an HTTP request.

You mentioned www.dslreports.com/who which is a list of people who contribute to the dslreports site, and not a list of servers or ISPs.  Are you sure that this is the page you used to search for ns.schlund.de?  If so, I'm not surprised it comes back as invalid ;-)

0
 
siliconbritAuthor Commented:
LOL - I knew I shouldn't have posted anything about the client networking setup ;-)

I'll try to make it clear - perhaps I didn't give the right information:

This is a networking problem.  The information I have given narrows it down to either my router or some glitch in the broadband ISP, not the hosting company or my computers.  My router has been bounced several times and reset to factory defaults, with the exception of the actual broadband connection details.

I do not believe that this is not a DNS issue, for two reasons:

   1) On any client, and using various tools (browser, ping, traceroute etc), I can resolve the IP address of the website correctly.  

   2) I have tried static DNS on client and router and repeated with a non-ISP DNS, and have tried a hosts file entry for the URL.  None of these work, its not a DNS issue.

So, I need either some direction on problems with the router config or some idea on how to narrow down possible problems on my broadband ISP's servers so that I can talk to them and tell them exactly what to look for.  Without this, they'll just throw me back to the hosting company.

The hosting company have been excellent, running a series of diagnostic tests and contacting their own partners in other countries to make sure that the site is operating as expected.  They are the largest hosting company in Europe and I have sites on the same server and on peer servers which I can load without difficulty.

Before I attract a new flood of 'quick' replies, I want to state just one more time:

  - it is not a problem with a client computer, its a networking issue.
  - the router is now at factory settings.
  - the DNS resolution process is working correctly.

Sorry to rindi/mtpcbypc/BILJAX, all your help so far has been good advice, but nothing to do with my problem. (ROTFL - With the exception of mtpcbypc forgetting to read the posts ;-)
0
 
xrokCommented:
1. Everyone can reach the site with Public IP (400 bad request).
2. Your Network Can't Reach using Public IP.
3. Your Network can reach by Ping and Treacert using IP.

 It is not DNS resolution (Since you are using IP Address)

>>My ISP is useless - they have little interest in solving the problem, even though their own engineers can't open the webpage.
Do they get "400 bad request" or "Cannot Find Server, or DNS Error"

I can come up one theory if your ISP Engineer are getting "400 bad request"
1. They block your Public IP.



0
 
siliconbritAuthor Commented:

Thanks Xrok - first real attempt at the actual problem

I have a call in with the broadband ISP since yesterday to find out if they are blocking the IP address of the website.  Perhaps some other site on the same server has been responsible for spam or other abuse.  Their first reaction was that they never block any IP addresses, that took a little re-education to get over ;-).  Now I'm expecting a call back this afternoon with an answer on that question.  I'll let you know if this is the case.

The 404 Bad Request is actually delivered by the web server itself, which means that the HTTP request passed through to the web server, and the reply came all the way back to the client.  If you try it and get the same response, you'll see what I mean - the 404 page actually includes an image that resides on the host webserver, so the HTTP request passes through OK.

The ISP engineers won't tell me wether they are getting "404" or a "Cannot Find Server".  I guess they are afraid I might be able to use the answer to ransack their current accounts or DoS the entire UK :-)

0
 
xrokCommented:
>>The 404 Bad Request is actually delivered by the web server itself, which means that the HTTP request passed through to the web server, and the reply came all the >>way back to the client.  If you try it and get the same response, you'll see what I mean - the 404 page actually includes an image that resides on the host >>webserver, so the HTTP request passes through OK.

You are Correct

>>The ISP engineers won't tell me wether they are getting "404" or a "Cannot Find Server".  I guess they are afraid I might be able to use the answer to ransack their >>current accounts or DoS the entire UK :-)

If they are willing to share that information, It would make your job eaiser to found the problem.
Least it will narrow to WAN or LAN
If you are williing to share ISP DNS, I will try it from my end
Least That will narrow down a little
0
 
siliconbritAuthor Commented:
The ISP is BT Broadband - I dont know the IP addresses off hand, but a quick google yielded 194.74.65.69 and 217.35.209.180 (from http://usertools.plus.net/tutorials/id/27)

I'd be interested to see what you find out.

0
 
xrokCommented:
Can you give me the register domain name for 212.227.109.225?
0
 
siliconbritAuthor Commented:

I'm going to have to close this question, points unallocated.  While xrok made a last-minute attempt to start looking at routes, nobody really got to the heart of the matter, and for that I blame myself for a poorly worded question.

The problem lay with a node on my broadband ISP's network.  Something was blocking any attempts to reach that IP address.  The IP address was not intentionally blocked by the ISP, but they ended up booting the router for that node and clearing the issue.

I discovered the root of the problem after comparing the traceroute output from my own network to that of a friend on another broadband ISP.  My traceroute showed one of the network hops appearing repeatedly in the route, and looping on some attempts.  The strangest thing is the traceroutes always terminated on the correct web server, showing that it was possible to pass traffic between my network and the web server, but I guess that is more to do with the network protocol used by traceroute.  I don't think I'll ever get a straight reason why it was so difficult to diagnose the problem.

You can continue to post on this thread, but I wont be reading the answers, and there won't be any points awarded.
0
 
pcavenueCommented:
try this dude,

go to

windows\system32\drivers\etc\

delete any host files

and for good measure after that do the following

run
cmd - enter
ipconfig /flushdns
ipconfig /registerdns
net stop netlogon
net start netlogon
exit

try it now.
0
 
siliconbritAuthor Commented:
{edited my lrmoore PE}
Did you not bother to read this thread - how many times do I have to say that the problem is nothing to do with the clients.  How can this help when all clients on the network are having the same problem?

I've also stated in my last entry that the problem is fixed and the case is closed.

{edited my lrmoore PE}
0
 
mtpcbypcCommented:
I'm not sure why no points got awarded.  Xrok got it right as did I.  With all your troubleshooting, the only thing that could possibly remain is the ISP. Just for future reference it is http://www.dslreports.com/whois . I'm not sure how the space got in there.  I would also like to comment that I never received error 404 only 400.  That is "bad request".  Also on a personal note.  Please don't be rude just because you are frustrated.  Everyone here has the best of intentions and was actively trying to assist you.
0
 
xrokCommented:
mtpcbypc, what or how does http://www.dslreports.com/whois pull reports??
I have use dslreports for speed and etc... and never even saw the link to that until now.
I always like to play with new utilities....:)

but when I type my domain IP and it came up with company I have no idea.  but it should been my domain name.
they are not my ISP hosting Domain either.
when I type domain name from same link, it points correctly to my ISP (Who is hosting my web site).

I just want a add to my education.





0
 
mtpcbypcCommented:
Here's a shot of one of my associates ISP's.  DSL reports is using a database created by ARIN.  It's just a reverse DNS lookup.
cheers

Check another:  or back to dslreports.com/whois
Result for 208.16.167.10
--> /usr/local/bin/fwhois 208.16.167.10@whois.arin.net
[whois.arin.net]
Sprint SPRINTLINK-BLKS (NET-208-0-0-0-1)
                                  208.0.0.0 - 208.35.255.255
BENJAMIN VALDEZ FON-349075225653169 (NET-208-16-167-0-1)
                                  208.16.167.0 - 208.16.167.255

# ARIN WHOIS database, last updated 2005-04-27 19:10
# Enter ? for additional hints on searching ARIN's WHOIS database.
--> /usr/local/bin/fwhois "!NET-208-16-167-0-1@whois.arin.net"
[whois.arin.net]

OrgName:    BENJAMIN VALDEZ
OrgID:      BENJAM-11
Address:    PO BOX 20258
City:       BILLINGS
StateProv:  MT
PostalCode: 59104
Country:    US

NetRange:   208.16.167.0 - 208.16.167.255
CIDR:       208.16.167.0/24
NetName:    FON-349075225653169
NetHandle:  NET-208-16-167-0-1
Parent:     NET-208-0-0-0-1
NetType:    Reassigned
Comment:
RegDate:    2000-06-22
Updated:    2000-06-22

TechHandle: BV110-ARIN
TechName:   VALDEZ, BENJAMIN
TechPhone:  +1-406-651-5484
TechEmail:  VALDEZ@wtp.net

# ARIN WHOIS database, last updated 2005-04-27 19:10
# Enter ? for additional hints on searching ARIN's WHOIS database.

 
 
 
 
Thursday, 28-Apr
17:31:49  © 1999-2005 broadbandreports.com/dslreports.com.
Terms of Use - Privacy Policy. Use signifies your agreement.
Another Satisfied Customer of Net Access Corp. - DSL,Hosting & Co-lo.  
0
 
xrokCommented:
Thanks :)  
This is great information.

0
 
mtpcbypcCommented:
http://www.arin.net/education/WHOIS_CBT/

this is a desciption from ARIN

But DSLreports seems to do a more thorough dive into there data than I can do at ARIN's website
0
 
siliconbritAuthor Commented:

mtpcbypc, and with all due respect mate, I dont agree that you "got it right", and here is why - Your two suggestions were:

1)    "reboot your router.  Your ISP has changed or upgraded their DNS server"

        So I need to reboot my router because my ISP has upgraded their DNS server.
        Not valid or correct, they hadn't and this wasn't the problem, and in my third
        comment, before this one, I believe I stated clearly that the router had been
        reset to factory settings.

        Plus - this was NOT a DNS issue.

and...

2)     "Has the isp shut down the site... I'd ask the server whats going on"

        Not correct otherwise nobody else would be able to see the website - in my
        original post I clearly explain that lots of people can see the website succesfully,
        the problem was on my subnet and possibly anyone on BT Broadband.

        I also clearly state that the "server" had already run a series of tests, clearly
        showing that I had already 'asked the server what was going on'.


It took lots of posts for xrok to start working along the right lines and get close to where I was when I posted the thread, but by that time, I was back in contact with my Broadband ISP looking at traceroute output, and spotted the looping router.  As soon as that router was booted, the problem was fixed.  Nothing to do with DNS, or my router, or the web-server.

So, no - you didn't 'get it right', you just repeated a few things that had already been covered in the thread, most of which I had covered in my original post.  Neither did Xrok, although he had started to understand the problem.

I should have stated clearly in my original post that I was looking for help finding the problem between my router and the web server, and for this I apologise for not making the question clear enough, but you're still not getting points ;-)

Xrok started to move in the right direction, but if you read this thread thoroughly, he is only agreeing with what I've already said, with the exception that he reckoned the ISP was blocking the Web Server IP address, which they were not.  We started to formulate a plan to find out more, but then I had a phone call, and I 'fixed it myself' based on my output from traceroute and a friends copy.  Perhaps Xrok would have been the one to provide the traceroute had the phone call not come in, but sadly he wasn't.

As for my 'rant' to pcavenue, I agree that I was harsh, but the very last line of my Original Post says "My hosts file is empty and my cache has been cleared." - So for pcavenue to tell me to delete my hosts file and flush my DNS cache - ....well you get the picture.  I just hate to see this exchange cluttered with people who dont bother to read the original posts, but see a few keywords and jump in with an obvious answer.

You're right though, I shouldn't have blasted him on here, so please accept my apologies for that.

In the meantime, this thread is still closed and there will be no points awarded because I 'fixed it myself', and NOBODY actually stated what the problem was, because nobody knew the answer - it was a hardware glitch on a POP node (not a DNS server).
0
 
xrokCommented:
glad its working


0
 
xrokCommented:
Great!
0
 
RomModCommented:
The question has been PAQ'd and the 500 points have been refunded.
RomMod
Community Support Moderator
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

  • 13
  • 10
  • 5
  • +4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now