?
Solved

how to install pgsql on Linux(Redhat9)

Posted on 2005-04-25
6
Medium Priority
?
1,304 Views
Last Modified: 2008-05-29
Hi there,

I have a simple Query. My activity is to install pgsql on Linux Redhat9. However I installed postgresql-7.3.2.tar.gz like this……..

[root]# cd /usr/local/src
[root]# gzip -cd postgresql-7.3.2.tar.gz | tar xvf -
[root]# cd postgresql-7.3.2
[root]# ./configure
[root]# make
[root]# make install
[root]# adduser postgres
[root]# mkdir /usr/local/pgsql/data
[root]# chown postgres /usr/local/pgsql/data
[root]# touch /var/log/pgsql
[root]# chown postgres /var/log/pgsql

But when I run the following command

[root@localhost root]# su postgres
[postgres@localhost root]$ /usr/local/pgsql/bin/postmaster -D /usr/local/pgsql/data

FATAL:  data directory "/usr/local/pgsql/data" has group or world access
DETAIL:  Permissions should be u=rwx (0700).
[postgres@localhost root]$

I am facing the above the Above Error………is there anybody to Help me.

And can I install pgsql through RPM ?? if yes plz give me Detail step by step Info…for that…..

I waiting for Reply ASAP.

Thanks in Advance.
0
Comment
Question by:Mohan_Hasa
  • 2
3 Comments
 
LVL 88

Expert Comment

by:rindi
ID: 13865048
You should be able to find rpm's for redhat9 via the fedora legacy project, which still has some support of the obsolete redhat 9 system:

http://fedoralegacy.org/download/

the postgresql rpm is available in the following link:

http://download.fedoralegacy.org/redhat/9/os/i386/

and I suggest you also install yum, which is an update manager similar to debian's apt-get which you can use to manage software installations and updates:

http://download.fedoralegacy.org/redhat/9/legacy-utils/i386/

Personaly I would suggest you upgrade to fedora-core 3, as this is the modern version of redhat and works stably (at least on my system).

0
 
LVL 88

Accepted Solution

by:
rindi earned 500 total points
ID: 13865071
For your above installation you probably only need to run chmod on the folder as the postgres user and from inside the folder /usr/local/pqsql/:

chmod 700 data

0
 
LVL 22

Expert Comment

by:pjedmond
ID: 13869658
Got exactly the same when I tried it, again on a redhat 9.0 system

rindi is correct in that you only need to chmod the folder, however you will find that it possibly needs to be:

chmod -R 700 data

This is definitely the case if you have used a previous version of pgsql on that system. Alternatively, the Redhat 9.0 discs have the RPM format for installing pgsql.

HTH:)
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The purpose of this article is to demonstrate how we can upgrade Python from version 2.7.6 to Python 2.7.10 on the Linux Mint operating system. I am using an Oracle Virtual Box where I have installed Linux Mint operating system version 17.2. Once yo…
In this article we will discuss all things related to StageFright bug, the most vulnerable bug of android devices.
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.
Suggested Courses

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question