RAS IP Addresses

Can anyone tell me how I can stop my DHCP server from assigning RAS IP addresses to clients.

The server is running Routing and Remote Access and is configured using NAT to the clients. It is not needed (and I thought) not configured as a remote access server, however I can still get external access for myself through a remote desktop connection.
I cannot work out where it is specified that the DHCP server needs to assign an address listed in the unique identity as RAS (has a little phone by the icon) as well as a normal IP address from inside the network. It isn't a complex scope, using the 10.0.0.0 range with two subnets.

The problem is that these RAS addresses are eating up available IP's as each client is effectively getting two, one RAS and one normal IP address. Is this a client configuration, a DHCP setting or a RAS setting ?

Yesterday I reconfigured RRAS again, just to make sure that it was not configured as a remote access server. Thought I had cracked it and then sure enough, those little telephone icons started popping up in the lease settings and the amount of available IP's was considerably reduced.
I have trawled the expected places, especially Technet with no further progress.

Very confused and need to get this one sorted ????
LVL 1
SeventhZenAsked:
Who is Participating?
 
Rick111Commented:
Go into RAS, right click the server, choose props
Click the IP tab, and change it to a static IP pool

This will stop RAS grabbing a load of addresses to use for VPN allocation etc...

0
 
SeventhZenAuthor Commented:
Ok, but how do I stop the DHCP server from assigning IP addresses for RAS completely ? Where can this configuration be found ? Is it a RRAS function. When I bring up the properties of my RRAS server, it is set to act as router for LAN only and the check box for Remote Access server is unticked ? So how do the clients keep getting remote access IP's ???

0
 
Rick111Commented:
DHCP server does not assign them, RAS requests them... if you do what I said RAS will no longer request them from the DHCP server. SO after the DHCP lease has expired on those addresses they will then only be used for DHCP requests on your network and not the RAS server.

Basically RAS grabs a load of IP addresses and then assigns these addresses out when needed, but scene as you are only using RAS for routing there will be no requirement for RAS to hold the addresses.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
SeventhZenAuthor Commented:
So let me get this right in my head....

I have now setup RAS to assign IP's from the next subnet from my clients ie 10.0.1.xx, so this will be where all the RAS IP's will live and my normal subnet 10.0.0.xx won't have RAS IP's. Then after these RAS IP's from 10.0.1.xx have expired, they will no longer be assigned as there isn't actually anything configured for remote access. Therfore, with this change, once they are expired, they are gone and will be no more....
0
 
Rick111Commented:
When they expire your DHCP server will have them back available in the pool for use with your normal clients and RAS wont touch them.
0
 
SeventhZenAuthor Commented:
OK, thanks. The points are yours.

So as I understand it from your posts, if you are running RRAS then there is no way to stop RAS IP addresses from appearing even if you don't actually want to allow any remote dial access, and the server is not configured as a remote access server. The reason for the remote dial clients is because I am using NAT, correct.
0
 
Rick111Commented:
"" there is no way to stop RAS IP addresses from appearing"" - I don't understand what you mean... Under IP tab you could just configure a static pool of 0.0.0.0 with 'number of addresses' set to 0 and then RAS would not use any...

Where are these addresses appearing? If you mean under DHCP Leases, then this is because the RAS service has taken a chunk of them to assign out when needed, if RAS was not setup on the server, or you set RAS as I say at the start of this post, then no, RAS would not grab any IP's.
0
 
SeventhZenAuthor Commented:
I apologise...I am a mere novice trying to understand.

I didn't realise that you could assign the static pool as 0.0.0.0, of course if there are no addresses, then none will be assigned. I understand now.

I will close this off and bother you no more.
0
 
SeventhZenAuthor Commented:
Just as a final point,

I went into the static pool and tried to assign the address 0.0.0.0 and the server flagged up a message stating that the start address was invalid.

So I used 10.0.1.1 as the start and 10.0.1.2 as the end, giving me a total number of 2 available addresses.

For anyone searching through, you cannot use 0.0.0.0 as a static address pool. Or at least, I couldn't.
0
 
Rick111Commented:
i was able to, you must have a feature of ras enabled which requires the allocation of ip addresses.

i was on a 2003 sp1 machine

cheers
0
 
SeventhZenAuthor Commented:
This actually didn't work.

Checked my active leases to find that there are 13 RAS IP's assigned again today, so the static pool trick didn't work for me.
If anyone knows how you can prevent RAS from grabbing these addresses post away.
0
 
Rick111Commented:
How long are your leases set to for? They just may have not yet expired
0
 
SeventhZenAuthor Commented:
Hello again Rick111,

just checked the setup and they DHCP scope was set to 8 days.....
Changed it to one to see if that does the trick.

Thanks for the follow up.
0
 
Rick111Commented:
You can also delete the leases from DHCP and see if they're then grabbed by RAS again. Because you've changed the lease after it had been assigned to RAS, they will still be held for 8 days unless you delete them manually.

Cheers
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.